8 Replies Latest reply: Jun 23, 2009 11:23 AM by flajrw
goldenbear95 Level 1 (0 points)
Loaded the 3.0 upgrade today. Never had a problem with connecting to the internet before. Now I show a connection to my wifi network but safari, mail, and web apps won't work. No problem with my laptop (over wifi) or VOIP phone line.

Anyone else have this problem or found a solution? Already reset network settings with no luck and cycled my router/modem.


Windows Vista
  • flajrw Level 1 (0 points)
    I'm guessing something in how the TCP/IP stack works has changed in 3.0. Data transfers seem jerky/slow and sometimes don't finish - to sites other than apple.com.
    Using Wireshark to look at some of the traffic, it looks like some of the packets being sent out are getting blocked as not recognized as part of an ongoing session/state. Maybe it's a strange interaction between the changes they made and some 802.11b access point implementations - mine is kind of unusual, but was working fine before OS 3.0 update.
  • Anthony Cook Level 2 (335 points)
    I am having a similar problem. The wifi icon disappears from the top of my iPod touch and then I go back to settings and click on the connection. Once the connection comes back, if I go to the iTunes music store, my connection gets dropped. Wierd.
  • flajrw Level 1 (0 points)
    A few more observations -
    At a different access point I have no problems with OS 3.0. Only with my home access point with 3.0 (no problems with earlier versions). This is reason I think Apple changed something in TCP/IP behavior in 3.0 that may interoperate well in some unusual firewall vendor/configurations. Just a guess.
  • Chris Wainscott Level 1 (5 points)
    I have the same problem since upgrading to 3.0. The iPod shows that I am connected to the network but I cannot access the internet.
  • Tony V Level 1 (20 points)
    I had problems with the 3.0 update, especially with connecting to my wireless router at home. It's taken me the best part of 2 days to sort the problem, and I've been tearing my hair out!I don't think I've got exactly the same problem as others, but I found a solution to the wireless "security" issue that some have been complaining about!

    I COULD connect wirelessly, but only by turning off security to the "none" setting. I use WPA2 for my Mac laptop, and I don't like having to disable it, as it's a real hassle. Changing settings on my Netgear router is nearly always a pain, because it always takes hours to get my mac to connect again.

    Anyway,finally, by changing the name of the network, and adding a new password, I've finally got the ipod to connect to the network using WPA2 security again! I never had this problem with the 2.2.1 software update, I just entered my details and password, and it connected automatically.

    In future I'm going to wait to see if the problems are ironed out, before updating, as I don't want to ever go through this hassle again. I even tried restoring my ipod to the previous software, but it wouldn't let me (gives an error message, apparently the ipod doesn't support you doing that!).

    I've noticed that the ipod is a bit sluggish when using the touch screen as well, since the update. Sometimes I have to press "buttons" several times to get a function to work, and there is a noticeable delay until it "works". Some of the "apps", don't work properly either, but it's not a major problem for me, since most of them are "free" ones.

    I really didn't need the updated functions particularly, but I can't go back to the previous 2.2.1 software, so I'll have to live with it. I'm glad I got wi-fi working again with WPA2, and I just have to live with the other problems until Apple come up with a solution for them, I guess.
  • Chris Wainscott Level 1 (5 points)
    Thanks Tony. Changing the SSID name of my home network solved the problem for me too.
  • luvlabs Level 4 (3,610 points)
    I'm going to throw this out to all of you who have posted so far. There are a few things drifting around out there that may lead to a resolution of a number of WiFi issues noted.

    Weak or varying signals
    Either restart or reset your iPod. Normally I would suggest you reboot your router as well.

    Enable to connect to internet until you changed your SSID
    Before you do this, I suggest you take a look at the DNS settings on your touch. Tap the blue > next to your network name. Look at the DNS IP addresses - are the separated by a space or a comma? If they are still separated by a space, I suggest you reset your network settings and then log back into your network via the Other Network prompt. This should reset that parameter and allow you to resume normal activity.

    Again, not 100% confirmed at this point, but worth looking into.
  • flajrw Level 1 (0 points)
    Recap w/ more details:
    Symptom - after 3.0 update, could not reliably transfer data over WiFi. Packet trace (via WireShark on laptop) indicated many resent packets indicating different behavior in TCP/IP or WiFi area than previous OS.
    However, iPod worked fine with a different access point, indicating problem isn't universal.

    New data - added additional WiFi card to firewall that has problem. Old WiFi interface based on Prism chipset, new WiFi interface based on Atheros chipset. Two interfaces are bridged together so should be no difference on firewall side, other than chipset/OS level driver processing.

    iPod works fine on new interface.

    So the problem seems to be an interaction of OS 3.0 with some possibly older? WiFi access points.