Previous 1 2 Next 20 Replies Latest reply: Jul 3, 2009 9:37 AM by emmaismycatsname
Sanks Level 1 (0 points)
Just updated my iPhone 3G to version 3.0 and the Camera App has disappeared.
So far I`ve:
Checked all pages - not anywhere
Done a full restore - still not returned.
Check Restrictions - they were not on.
Allocated Camera to home button but still not working

Can anyone help PLEASE?

Iphone 3G, iPhone OS 3.0
  • Alicekal Level 1 (0 points)
    I also lost most of my Apps with the upgrade, however, when I type in the name of the App in Spotlight, my iPhone finds it. Also, as the support page indicates, check to make sure that all App updates have been downloaded.
  • Sanks Level 1 (0 points)

    Thanks for the post but searched for it in spotlight & nothing related to Camera found.

    And have check via iTunes & had all available updates downloaded.

    Its driving me demented...
  • Micro67 Level 1 (0 points)
    I have the same problem. I updated 3 company phones yesterday to 3.0 and everything worked perfectly after. But this morning all three phones were missing the camera app.

    I have checked everything I can think of including limitations, settings aso. But nothing. It's not likely a hardware problem since three phones got the same problem. Likely an issue with the 3.0 update.

    Can anyone advise. An apple representative perhaps?
  • Rudy Milkovic Level 2 (260 points)
    There appears to be a bug with this new update (3.0) - If you're using Exchange (sync) support with the new firmware, then the camera disappears. If you deactivate the Exchange email account ( temporarily) the camera magically appears.

    Maybe Apple will call this a 'security feature'? < said as a joke > because many larger organizations shun using camera phones internally. In fact, many government/federal institutions do not allow you to bring camera phones into their offices...

    Whatever the reason, it's a bug.. not sure if it's a completely 100% known one but the next small point update should alleviate that.

    Try deactivating the exchange account and see if your camera icon shows up.. .Mine does..

    Good luck....

  • bryan mahin Level 1 (0 points)
    I found a solution to the problem.

    Exchange 2007 has active sync policies. One of the options is to disallow the camera.

    To resolve the problem do the following.
    1) Open Exchange Management Console
    2) Click "Organization Configuration"
    3) Click "Client Access"
    4) On the right you should see your active sync policies. Right click the policy and chose "Properties"
    5) Click the "Device" tab
    6) Check "Allow camera"
  • Sanks Level 1 (0 points)
    Thanks Micro / Rudy / Bryan,

    At least I know I am not alone in this!

    Bryan, I assume you are refering to amending the settings in Exchange Server rather than on the iPhone? As I don`t have access the my work mail server. But I am using an active sync.

    Turned off active sync & the Camera App re-appeared so it would seem this is the issue.

    I hope Apple takes note of this & provides a phone-based-solution as it is an issue that should be dealt with, as my iPhone is private but I use it for work mails when not in the office.

    Thanks all.

  • bryan mahin Level 1 (0 points)
    Apple doesn't need to do anything to phones missing the cameras due to exchange side configurations. Technically this "problem" is really a new feature. All phones that connect to a 2007 exchange server are subject to the policies outlined by the exchange administrator. Before the 3.0 update, iphones were not applying the policies correctly.

    The camera functionality was either disabled on purpose or accident by the exchange admin. If by accident, the admin just needs to re-enable it. You may have to remove the exchange account from your phone and re-add it after he makes the config change.
  • taisontan Level 1 (0 points)
    I do not use activesync or any kind of sync and my camera was not there after my upgrade to firmware 3.0.

    How I solved my problem was:

    Settings-> General-> Restriction->

    I then turned on restrictions.
    Then disabled all the programs.
    Home button

    Settings-> General-> Restrictions->

    Enabled all programs again
    Home button

    Settings-> General-> Restrictions->

    disabled restrictions
    Home button

    My camera then reappeared.
  • VSolis Level 1 (0 points)
    you sir/ma'am, are a GENIUS! thanks.
  • cwallison Level 1 (0 points)
    Brilliant solution - thanks so much. I also had no sync or Exchange server to complicate things. This solved the problem right away. I hope it is fixed in the software update b/c I'd like to use the resricion settings on a couple of programs.
  • Sanks Level 1 (0 points)

    I take you point & thanks again for the clarification.
    But I still feel this is a pointless hinderance for private phones users.

    If the iPhone is a corporate devise then surely the more elegant solution would be for the phone to have its configuration 'locked' by the corporate IT during its set-up.

    What we have is private users having functioality removed from the phone without their permission.

    Let's be honest, to use the camera, all I have to do is disable the sync & take whatever pictures I like. Hardley a true 'security feature' of the new software.

    This should have been dealt with in a more sensible manner by Apple & I hope the allow private users a solution to this.

    Thanks again for your replys,

  • Rudy Milkovic Level 2 (260 points)
    This worked PERFECTLY! I am now getting my exchange emails, mobileme mails and i can now take pictures as well... Thanks Bryan!

  • bryan mahin Level 1 (0 points)
    I'm not going to debate with you for apple, but I can see the advantages and disadvantages of iphone/active sync policies from a user and infrastructure standpoint.

    I haven't tested any of the other server side settings with an iphone, but there are quite a few available. Other settings do make sense even if they are able to be re-enabled by disabling corporate email. These options include disabling wifi, disabling bluetooth, setting a maximum attachment size, disallowing consumer email accounts to be setup, limitations on how far back email or calendar items are syncd, etc.

    Disabling wifi and bluetooth for example help limit potential security risks while the device is syncing with an exchange server.
  • bryan mahin Level 1 (0 points)
    No problem. Glad I could help.
Previous 1 2 Next