12 Replies Latest reply: Aug 9, 2009 1:04 PM by Pucks98
varod Level 1 Level 1 (0 points)
prior to updating i was running iphone os 2.x and i had no issues with any wifi around anywhere. all my know networks would auto connect in seconds and work great. yesterday i decided to upgrade to 3.0 and since then i started having problems. when update completed all of a sudden my wifi disappeared on me. i checked out my wifi settings, it was showing my network as available and it was checked off as connected but i was not getting any wifi signal. after i rebooted the phone, wifi finally connected but not for long. shortly after the reset the signal got progressively weaker and disconnected. i thought it was my network maybe, i reset my network to make sure its not bugged (and while sitting 5 feet away from the router with my phone and my laptop tried it again). my laptop picked up on the wifi fast and worked beautifully, iphone on the other hard had a hard time connecting. i rebooted it once more and got the wifi to work, but shortly thereafter it disconnected again. i wiped the phone to its original factory settings but i wasn't able to roll it back to 2.x. it installed 3.0 with factory settings. wifi still buggy, not working, going in and out all the time. sometimes it doesn't find my network while clearly its up or i wouldn't be able to browse the net. when it connects after 5-10min of thinking it disconnects shortly after. anyone else experiencing similar problem? any advice on how to fix it?

iPhone OS 3.0
  • tpcville Level 1 Level 1 (0 points)
    I have the same problem. I have never had any issues prior to the 3.0 update. Now, it DOES find my network every time, but the connection never lasts more than a few minutes. The wifi symbol says I'm still connected, but nothing works. I have to switch back to Edge to get anything done- email, Twitter client, Safari, etc. AND sometimes it looks as if I've lost my wifi (icon disappears), but under the settings, it says I'm still connected.

    I'd gladly give up the new copy and paste to have my wifi back.

    I'd love more ideas if anyone has them.
  • barshnik Level 1 Level 1 (85 points)
    Sorry, no help here. WiFi worked perfectly before 3.0, now it doesn't show existing networks. Battery life 1/2 of previous version. App icons for newly installed apps are overlaid with icons from previously deleted apps. I'll be making a Genius appointment and insist on reverting to previous version and/or a new phone with 2x installed. Quite a mess, this 3.0.
  • Iken1 Level 1 Level 1 (0 points)
    Have been experiencing the same problem since 3.0 upgrade. Before upgrade it worked perfectly, and WiFi is running smoothly when accessed from my laptop. My home WiFi is delivered through Time Capsule.
  • EternuS Level 1 Level 1 (0 points)
    Gosh, I thought I was the only one with this problem.
    ideas anyone?

    I heard Apple is already coming up with a 3.1 software update that may fix this.
  • MarceePauff Level 1 Level 1 (5 points)
    I'm having the same problems. I find when I restore to factory settings it seems to work ok, but if I restore any of my backups, the problem returns. I'd happily give up copy/paste to have my phone work again. I want my 2.x back.
  • morrybo Level 1 Level 1 (5 points)
    yeah! for my mate he upgraded to 3.0 from 2 and his wifi doesnt work:(

    whats going on??

    tired everything
  • modemlooper Level 1 Level 1 (0 points)
    The day I upgraded to 3.0 the wifi quit and will work sometimes but mostly never. I just turned it off and only use phone data now
  • bryan23 Level 1 Level 1 (0 points)
    Since upgrading, my phone tells me that it will connect to all known networks, as it used to, but it doesn't.
    ive had to re-input the network password three times this month as if im a brand new user.
    In settings everything is ok yet each time i walk in the house it shows Edge or 3G for about 20/30 seconds before joining Wi-Fi.
    Version 2 was instant.
    Under V 3.0 it frequently asks 'Do you want to join ?' when its telling me at the same time that will join known networks automatically.
    It's as if it's forgotten my "known" network.
    In anticipation, Yes, ive re-booted it, several times.
  • Dutchie71 Level 1 Level 1 (20 points)
    Fix: Change from DHCP to fixed IP address on your iPhone. Also change channel from Auto to 11 on your router. No wifi issues anymore. Never drops now and I have full strength all the time now!
  • rester555 Level 1 Level 1 (0 points)
    @ Dutchie71 You are correct. The Wifi issued was solved on my router when the channel was changed to 11 instead of auto. I also had the IP set manually...
  • kevin_pgu Level 1 Level 1 (0 points)
    since i have upgraded version 3.0 in my iphone 3G, my wifi no any function at all..anybody help here?
  • Pucks98 Level 1 Level 1 (0 points)
    I took my 2.0 phone to the local Apple store and they would not even look at it. They said it was out of warranty and I would need to upgrade to a 3.0 through ATT for $200.00. At this point, It has been a few months since the 3.0 disaster has taken effect and Apple will not even acknowledge this issue.

    < Edited by Host >