Previous 1 2 Next 23 Replies Latest reply: Oct 31, 2009 1:33 AM by bobtdiver
Erik713 Level 1 Level 1 (0 points)
Okay, after I installed the version of iTunes and tried to plug in my iPhone, I got a message stating essentially that the version of Apple Mobile Device Support is wrong, and to uninstall AMDS and iTunes and reinstall them. Of course, after doing that, it still gave the error.

After hours of trying things and coming up with nothing with Apple Tech Support, this finally fixed the problem. I don't know if it'll help anyone, but if it does, great!

You will need:
1. The previous version of iTunes - 8.1.1
2. The current version of iTunes - 8.2
3. WinRAR

This is what I did that worked:
1. Delete the folder "C:\Program Files\Common Files\Apple\Mobile Device Support"
2. Using WinRAR, extract "applemobiledevicesupport.msi" from the 8.1.1 iTunes installer file to your desktop.
3. Run applemobiledevicesupport.msi to install the previous version of Apple Mobile Device Support. This won't jive with iTunes 8.2. If you try to run it, you'll just get the old error message.
4. Using WinRAR, extract "applemobiledevicesupport.msi" from the 8.2 iTunes installer file to your desktop overwriting the old version.
5. Run applemobiledevicesupport.msi to intstall the new version of AMDS over the previous version.
6. Start up iTunes.
7. Plug in iPhone

It should now recognize the device.

Let me know if it works for ya!


iPhone 3G, iTunes, Windows XP
  • ra1larsen Level 1 Level 1 (0 points)
    Has anyone tried it yet? Vista will not allow me to delete folder "C:\Program Files\Common Files\Apple\Mobile Device Support" another wonderful upgrade from Microsoft that complicated or failed more than it improved. Apple Tech I spoke with for hours did not know about this. Or he knew of problem deleting folders in Vista. We could not resolve and higher up Techs could take a week to even respond.
  • Erik713 Level 1 Level 1 (0 points)
    Did you try this without deleting the folder? Perhaps it might work...

    I don't have Vista, so maybe a variation of this might be in order.

    Message was edited by: Erik713
  • ra1larsen Level 1 Level 1 (0 points)
    Miracles do happen. I found another post regarding how to perform Device Firmware Upgrade. I connected iPhone and low and behold iTunes identified phone and asked if I wanted to upgrade to 3.0. I declined that upgrade as everything is working just fine now and plan to wait on 3.0 quite sometime. I did nothing new today I just connected and it worked, who know why or what caused problems prior two days.
  • DarrellJ88 Level 1 Level 1 (0 points)
    This seems like the exact thing I needed, but it wont let me install apple mobile device. It says installer encountered errors before completing. And after I installed itunes, there wasnt even a folder called apple mobile device in programfiles/commonfiles/apple/

    So I had nothing to delete, and just extracted the applemobiledevice.msi from the 8.1.1 installer and tried to use that, and the errors continue. It seems no matter what I do its an endless loop of installation errors everyway around.
  • ra1larsen Level 1 Level 1 (0 points)
    I was wrong as once again iTunes 8.2 is back with error. Iphone detected but cannot be identified. I tried multiple shutdown and start up combinations between PC, iTunes and iPhone all to no avail. There has got to be some conflict here and it seems to be Apple software with the issue not my iPhone or my PC. They can and did work once since the upgrade nothing changed to fix it Saturday and again nothing done that should cause it to fail Sunday and Monday.
  • Erik713 Level 1 Level 1 (0 points)
    Darrell, I tried using the old version of AMDS with and it didn't work either. After you install the old version of AMDS, try installing the new version right over it. Don't remove the old version.
  • DarrellJ88 Level 1 Level 1 (0 points)
    It wont allow me to install AMDS at all. I don't currently have AMDS installed as far as I can tell, its not in my add/remove programs and not in programfiles/commonfiles/apple there is no folder for AMDS even there. When I install itunes it does not install AMDS at all for me, and when I tried to extract that older AMDS as this solution says, it will not allow me to install (The installation encountered errors try again later).
  • MiCkBaBy Level 1 Level 1 (0 points)
    Hi Erik,

    Your basic suggestion actually worked for me. But this is what I did for others who are having issues removing/installing etc.

    1. Download the latest iTunes 8.2. You should end up with a file iTunesSetup.
    2. If you dont already have WinRAR, download free copy from and install.
    3. Right click on iTunesSetup and choose "Extract" to somewhere you know. eg C:\itunetemp
    4. Open up folder where you extracted iTunesSetup and double-click applemobiledevicesupport.msi
    5. It should ask you if you want to repair or remove... choose remove.
    6. REBOOT your PC.

    7. Go back to where you extracted iTunesSetup and double-click applemobiledevicesupport.msi and go through the install.
    8. Plug in your iPhone.

    If all is well iTunes should automatically start and start syncing your iPhone.

    Goodluck all!

  • DarrellJ88 Level 1 Level 1 (0 points)
    Mine does not give me that option to remove/repair, which I'm pretty sure is because I don't actually have any applemobiledevice installed, and that kind of turns this problem into an endless loop of not being able to get it installed. I can't just upgrade/repair/remove because I don't have one installed, and I can't just install one because it says the installation encountered errors.
  • Mr Kev Level 1 Level 1 (0 points)

    I am having same issue - my iphone is on 3.0, updated on a work machine, which dowlnloaded latest version of itunes and works fine. Issue is with home pc, which when downloading, it won't install the new version of amds - goes to "rolling back" action.

    Followed the advice above, ie removing and then installing older version via a winrar extract - the older version still works and installs. Then, when I try to install the newer version of AMDS with 8.2.23, it just won't load it - it encounters an error before you are, I seem to be going around in circles. Have you found a solution, or does anyone know one??!!
  • andyschouten Level 1 Level 1 (0 points)
    Erik, I'm using Windows 7 RC1 x86 on iMac with Bootcamp and I'd struggled with this for hours.
    Removing AMDS that came with iTunes, installing the AMDS that came in iTunes 8.11 and then reinstalling the version from again worked a treat. Thank you!
    BTW, what made you think to use AMDS from iTunes 8.11?
  • wordtamer Level 1 Level 1 (0 points)

    I'm having this same issue, and I attempted your suggestion but could not delete the folder: C:\Program Files\Common Files\Apple\Mobile Device Support. It says it could be encrypted or full. Do you have any insight into this? I've attempted this whole process about four times, (i.e., updating to 8.2); and it never recognizes my iPhone. I always have to back down to 8.1.1 and uninstall/cleanup everything. So, I'm attempting your steps now. The only hang-up is the fact that I can't delete the above folder. I am the only user as it's a home computer. Any input you may have would be wonderful.
  • gungaapple Level 1 Level 1 (0 points)
    Thanks for taking one for the team and through tech support nightmare!

    It worked great.
  • Katrina S. Level 7 Level 7 (24,095 points)
    Try the old DOS trick or renaming that folder instead of trying to delete it.

    In WinExplorer, right-click > rename, and change it to something like
    C:\Program Files\Common Files\Apple\Mobile Device SupportDELETEME

    Sometimes the OS gets confused and will let you rename something, but not delete it.
Previous 1 2 Next