Previous 1 2 3 Next 42 Replies Latest reply: Aug 25, 2009 3:51 PM by Payton Garner
24Golfer Level 1 Level 1 (30 points)
So I synced my 3GS -

I go to click on the Contacts, and I see "All Contacts" - and in my list, all my contacts are listed TWICE -

so I back to Groups, and there I see that it lists BOTH "From my Mac" and "MobileMe Account" - so the thing lists everything twice!

But isn't Sync supposed to make the whole thing Sync, and then Push should make it all Sync too?

MacBook Pro CoreDuo 2.0 GHz, MacBook Core2Duo 2.0, iPhone, Mac OS X (10.5.7), 2 Gigs RAM, 7200 RPM 100 Gig HDD
  • The Cure Level 2 Level 2 (190 points)
    SI'm experiencing the same issue. Even after I delete all of the duplicates, when I sync my phone after that, i get the same duplicates for all of my contacts and calendar events. I can't find a setting to prevent that from happening.

    ~R
  • ibaj Level 1 Level 1 (55 points)
    It sounds like you're syncing your contacts from both your MobileMe Account and your desktop. With iPhone 3.0, Apple supports syncing from multiple sources. Since you're already in this situation, you're going to have to do some circus act to get back into good shape.

    Step One: Turn off MobileMe syncing.
    - Go to Settings > Mail, Contacts, Calendars > Accounts > Your MobileMe Account > Contacts > "OFF"
    - The iPhone will display a dialog asking "What would you like to do with the previously synced MobileMe contacts on your iPhone?" to which you will choose "Delete from My iPhone"
    - Once this is complete, you'll only have your contacts that synced over from your computer.

    Step Two: Disable tethered syncing in iTunes
    - In iTunes, select your device and go to the "Info" tab and disable sync contacts option

    Step Three: Re-enable MobileMe syncing
    - - Go to Settings > Mail, Contacts, Calendars > Accounts > Your MobileMe Account > Contacts > "ON"
    - The iPhone will display a dialog asking "There are existing contacts synced with your Mac. Would you like to merge them with your MobileMe account?" to which you will choose "Do not merge"
    - This will prompt another dialog asking "What would you like to do with the existing contacts on your iPhone" to which you will choose "Delete"

    All done! You should now only have 1 copy of all your contacts syncing from MobileMe. The only time this is useful is when you have contacts on another computer (like at work) that you're not syncing with MobileMe and don't have access to Exchange. This way you can keep the separate, but have both available.
  • 24Golfer Level 1 Level 1 (30 points)
    So when I do this, it will now Sync as Push from MobileMe? How long does that take?

    And will I never have to Sync again in iTunes?

    So this whole "circus" round-about act is going to be eliminated in the next iteration of iTunes and iPhone 3.1, right? Cos it seems downright silly that we have to do this - why doesn't it just keep it streamlined in the first place?

    I'm worried now that I won't have it Synced in time to get back to work. We'll see, I guess.

    But I ask again: I leave the Sync Contacts to OFF in iTunes, correct?

    Thanks
  • ibaj Level 1 Level 1 (55 points)
    24Golfer wrote:
    So when I do this, it will now Sync as Push from MobileMe? How long does that take?

    See http://www.apple.com/iphone/how-to/#settings.fetch-new-data

    It will take a few minutes for MobileMe to download all of your contacts again. Depending on how many contacts you have and how long it's been since you "reset up to" MobileMe, it should take between 5 and 30 minutes.

    And will I never have to Sync again in iTunes?


    In theory, right. The only time you should have to sync with iTunes is for getting your media, photos, etc.

    So this whole "circus" round-about act is going to be eliminated in the next iteration of iTunes and iPhone 3.1, right? Cos it seems downright silly that we have to do this - why doesn't it just keep it streamlined in the first place?


    It really depends on your situation. I'm not sure how you ended up having both your contacts tether syncing and your MobileMe contacts being pushed to your phone, but it would stand to reason that at some point, you added your MobileMe account and decided to keep the data on your phone rather than delete it (which would have prevented this). I think it might have just been unclear or maybe a little scary?

    I'm worried now that I won't have it Synced in time to get back to work. We'll see, I guess.


    MobileMe push is pretty darn fast. I see my contacts sync over the air within a few minutes generally. Are you using Windows or a Mac at work? If Windows, have you already installed the MobileMe Control Panel?

    But I ask again: I leave the Sync Contacts to OFF in iTunes, correct?


    That's correct.
  • Flynnsd Level 1 Level 1 (0 points)
    did you get an answer on this? This exactly what happened to me. I want to get rid of the "sync from my computer" when i did this all info was listed twice in my iphone 3GS.

    Thanks
  • Braveheart Level 1 Level 1 (0 points)
    I had the same problem. I was asked/notified by isync when I upgraded that I had conflicts between my phone and mac, and if I wanted to delete all my contacts on my mac and keep the ones on the phone. This made me a little nervous, so I didn't delete them.
    This is probably what caused the problem for me.
    Following ibaj's steps worked perfectly for me.

    As far as I am concerned this question has been answered
    A BIG thank you to ibaj.
  • 24Golfer Level 1 Level 1 (30 points)
    Errrrrrrr............ now I have the same problem with Calendar. I tried to do the same thing with the Calendar and disabled tethering - well, it's got double of everything in the dates. Can you tell me how to do it for the Calendar?

    Thank you!
  • ibaj Level 1 Level 1 (55 points)
    So if you go look in 1 particular calendar, you have duplicated of every event? If that's the case, I can't help you there... at least not on the forums.
  • teacher24_70 Level 2 Level 2 (245 points)
    So does this same thing fix the duplicates in Mail accounts and Calendar sets? I did the same thing initially. Accidentally checked those items in iTunes (not realizing that it would duplicate MobileMe) and now I have 2 yahoo mail accounts and 2 sets of identical calendars (work, home, etc.) The only 1 that's not duplicated is the Birthday calendar since it's not available via MobileMe.

    It would be great if your fix works for both issues. It's driving me CRAZY! It worked perfectly to delete my 2nd set of Contacts.
  • teacher24_70 Level 2 Level 2 (245 points)
    Maybe I spoke too soon. Followed the steps and everything appeared as you described. But I'm not seeing my contacts repopulated on the iPhone yet.
  • ibaj Level 1 Level 1 (55 points)
    It can take a while to populate your contacts to your iPhone if you haven't reset your sync information recently. Have a look at this article: http://support.apple.com/kb/HT1497
  • ibaj Level 1 Level 1 (55 points)
    It'll work for Calendars and Contacts. For your email accounts, you should just delete them from the UI.
  • teacher24_70 Level 2 Level 2 (245 points)
    Before I do anything with calendars, I added a new event to see if that would sync. It syncs to my Touch fine, but it's not syncing to my iPhone.

    When I got the iPhone on Friday, I let it restore from my Touch backup. This was great because it brought over all of my data--Apple data and 3rd party data. But now I'm wondering if I've confused things. Is there a way to make sure that MobileMe is syncing to BOTH the Touch and the iPhone. I'm seeing that in MobileMe it sees my Touch in "Find My iPhone" (which it "saw" even before I got the iPhone), but it doesn't display my iPhone.

    I'm getting confused and frustrated now.
  • ibaj Level 1 Level 1 (55 points)
    Try not to get to frustrated - it'll make it more difficult to make progress. You can always visit an Apple Store or call AppleCare for additional help.

    As far as your calendars, just check your MobileMe account settings on your iPhone and make sure you've re-enabled Calendar syncing. If it is enabled and not working, disable, and re-enabled it (be sure to choose the delete option).
Previous 1 2 3 Next