10 Replies Latest reply: Sep 7, 2009 5:48 AM by mm81973
Tsais Level 1 (0 points)
"iTunes Library.itl file is locked, on a locked disk, or you do not have write permission for this file" shows up when attempting to start iTunes.

This is on Windows Vista 64bit, and I used the designated 64bit installer from Apple's website, v8.2.0.23.

There is another post in regards to a similar disk locked / not found error, but the solution noted there is only for windows XP, as it requires Tweak UI, which the article states does not work under Vista.

Does anyone know how to fix this in Vista?

thanks

Windows Vista, iTunes 64bit v.8.2.0.23
  • _Muttly Level 1 (0 points)
    I have the same problem with 32 bit Vista.

    I have tried uninstalling all Apple products and resetting my iPod. I then re-installed, this looked like it worked initially so I reimported all my tunes (5K tracks). Then it came up again, most frustrating!

    My iPod syncs fine in my wife's PC which is also Vista and has the same version of iTunes (8.2.1.6)

    Unless anyone else has any better ideas my next step is to install my entire PC.
  • polydorus Level 6 (11,955 points)
    Usually when you get this problem in vista, it is to do with folder permissions.

    The account you are using needs full control of the iTunes and iTunes Music folder.

    Vista file folder permissions help
    http://windowshelp.microsoft.com/Windows/en-US/Help/2464a180-e5dc-45d1-a2b8-3c8a 2b571e9d1033.mspx
    http://www.mydigitallife.info/2007/05/25/how-to-take-ownership-and-grant-permiss ions-in-windows-vista/
  • _Muttly Level 1 (0 points)
    OK so that fixed the issues with the iTunes Libray.itl.

    Now it is telling me I cannot sync my iPod because I do not have enough access permissions
  • polydorus Level 6 (11,955 points)
    I haven't seen that one before, but I guess it is a similar issue with permissions.
    You know that if you do manage to sync to the libary on your PC it will remove all content synced on the other PC?

    Maybe if you enable to iPod for disk use, perhaps on the other PC if you can't do it on yours, and then check out the permissions on your PC?

    But I am just guessing.
  • Ceadol Level 1 (0 points)
    I usually get around the permissions errors by installing things anywhere but my Program Files folder. If I install things to a folder in my C:\ drive, I rarely if ever have problems running programs. Hopefully this helps.
  • polydorus Level 6 (11,955 points)
    Perhaps I should have mentioned that the folders on the iPod are hidden so you would need to make hidden folders visible in Windows Explorer>>tools>> folder options.
  • _Muttly Level 1 (0 points)
    Just an update for all, the problem is definately to do with the permissions my domain login in account has. If I log in as the local administrator of the PC then all works fine.

    Even though the domain account is in the local administrators group for the PC which has full access to all the iTunes areas I can think of I still have permissions problems syncing my music in the iPod. Transferring App works fine, it is only the music sync from what I can make out.

    For now I have given up and will workaround using the local administrator account. If anyone has any other ideas let me know and I'll give then a go.
  • evpoole Level 1 (0 points)
    I have a similar problem. I just purchased an external hard drive and copied my music files to it so I could free up space on my internal drive. I did not delete the music files from the internal drive yet but went into I Tunes as directed and specified a new location for the music files. I also told it to organize the folder. Now I cannot open I tunes - I get a message "The folder ITunes is on a locked disk or you do not have write permissions for this folder". I can only find solutions on Apple for Windows XP. I am using windows Vista 32 bit.
  • apple_switcher Level 1 (0 points)
    What I did to make this work was make sure my *Comouter name and User account name matched.* FOr some reason mine did not. Example: Accont Name John Doe, PC name Win7-PC/John. Change them so they both either are John or John Doe.
  • mm81973 Level 1 (0 points)
    I had the same problem on Windows Vista 64bit. To fix it I did try other things mentioned that didn't help. What did work was simple, go to the properties of the iTunes folder and uncheck the Read-only box, click Apply, click OK to change all the subfolders, then click OK and then I was able to open iTunes and it works with no problems.

    I hope that helps some of you.