1 2 Previous Next 18 Replies Latest reply: Sep 22, 2009 6:31 PM by Paea
paperblade Level 1 Level 1 (0 points)
Hi guys,

I have a problem with my MacBook Pro, recently updated to 10.5.7

For some reason, I can't get Internet Sharing to work. It used to work when I was back in 10.5.6, but one day it just stopped working. I want to share from Ethernet and out via Airport (so I can use my iPhones as I don't have 3G access on campus residence). Even if I have airport on, I can't get the "internet shared" icon (that would be in place of the airport icon up in the task bar when Internet Sharing is activated) to show even if I check Internet Sharing in System Preferences. I've tried restarting, I've updated everything that can be updated but I still can't get it to work.

Anybody have any clues?

MacBook Pro, Mac OS X (10.5.7), Internet Sharing
  • 1. Re: Internet Sharing not working?
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)
    Hi,

    As a Start I would ask if you have stated in Internet Sharing how the other is connecting. I have found myself reading the boxes and saying to myself "that's what I want to do" and forgetting to tick the box.

    Next I would ask what settings you have in System Preferences > Security ?

    What info is showing in the tabs for the Airport Card (System Preferences > Network > Advanced Button).

    Answers to these questions may help others to pinpoint your issue.



    10:13 PM Monday; June 22, 2009
  • 2. Re: Internet Sharing not working?
    paperblade Level 1 Level 1 (0 points)
    Thanks for a reply.

    I do not understand by "how the other is connecting"? My internet comes from the Ethernet port, and I have checked sharing via Airport. It used to work until recently.

    I have "Allow all incoming connections" checked for System Preferences>Security.

    For Airport Card (system preferences) > Network > Advanced Button, I have DNS Servers set up for 208.67.222.222 and 208.67.220.220, configuring IPv4 using DHCP, and Ethernet is configured "automatically"

    Thanks.
  • 3. Re: Internet Sharing not working?
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)
    OK,

    It was whether the Other (in this case the iPhone) was ticked in the Airport box.

    The IP in Airport should show a Self Assigned number start 169.xxx.xxx.xxx

    The Ethernet should show either your router's LAN IP or the Public IP from your ISP if the Modem passes that info on and you don't use a router.



    9:57 PM Monday; June 22, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • 4. Re: Internet Sharing not working?
    paperblade Level 1 Level 1 (0 points)
    Hi Ralph,

    Where can I find the Airport box to tick "the Other (iPhone)"? I don't see that option or box anywhere?

    IP in Airport does not show a self assigned number. Like I said, the Internet Sharing icon does not show in taskbar even after I check the box to "start" it.

    The ethernet does show the public IP, and Internet works perfectly fine.

    Thanks
  • 5. Re: Internet Sharing not working?
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)
    Hi,

    I was just trying to be clear that this Box for Airport had been ticked in the List.
    Sharing

    Like this one shows Firewire as the Output Network.

    Does this Thread provide any Extra info
    http://discussions.apple.com/thread.jspa?threadID=2035280
    The poster posts about setting the Channel the Airport Card uses (for An iPod Touch - An iPhone already connected)



    8:46 PM Tuesday; June 23, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

    Message was edited by: Ralph Johns (UK)
  • 6. Re: Internet Sharing not working?
    paperblade Level 1 Level 1 (0 points)
    Hi Ralph,

    Yes, "Airport" is checked.

    Everything used to be working fine until recently. It also didn't work when I updated to 10.5.7. Thanks for providing the thread, unfortunately, choosing different channels doesn't work either.

    Thanks though.. Any other solutions?
  • 7. Re: Internet Sharing not working?
    Ralph Johns (UK) Level 9 Level 9 (67,505 points)
    Hi,

    I must admit I am right on the edge of my knowledge in this area.

    I started with what I thought would be the simplest thing.

    Hopefully someone else will join in.



    10:09 PM Tuesday; June 23, 2009

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
  • 8. Re: Internet Sharing not working?
    Matthew Lu Level 1 Level 1 (55 points)
    I have the EXACT SAME PROBLEM. I cannot get internet sharing to work on the latest version of Leopard, but it works perfectly on the latest version of Tiger.

    Can anyone help? Why doesn't internet sharing work?
  • 9. Re: Internet Sharing not working?
    Lumière du Jour Level 1 Level 1 (0 points)
    Ralph,
    I am also having the problems you have tried to help other with. Question - you have Leopard 10.5.7 installed, does Internet Sharing work for you? I have two very thick manuals to help me out, I have read all the posts on this subject, I have followed your excellent troubleshooting advice - all to no avail.

    Has ANYONE had success with Internet Sharing and Leopard 10.5.7?? If you have, please respond here.
    TIA
  • 10. Re: Internet Sharing not working?
    Lumière du Jour Level 1 Level 1 (0 points)
    It has been a while since I updated my profile and I notice my previous post indicates I am using Leopard 10.5.5. That is incorrect - I am now using 10.5.7.

    Message was edited by: Lumière du Jour

    Message was edited by: Lumière du Jour

    Message was edited by: Lumière du Jour
  • 11. Re: Internet Sharing not working?
    Lumière du Jour Level 1 Level 1 (0 points)
    Further troubleshooting - just to advance the discussion.

    When I turn Internet Sharing on, I see the Airport icon on my iMac change to the quarter circle with the upward / forwarding arrow in it. On my Mac laptop, I can see the network I created on the iMac. When I try to log on to any of my bookmarked sites, the progress bar will hang on the entire URL address and lock up. The Network Diagnostics window then appears.

    Clicking on the Network Diagnostics button, I then see the status of various stages of the logon attempt. The Airport button is green, as is the Airport Settings. The next button, Network Settings, is orange and that's where things stop. Pressing the Continue button, I am asked to choose the Network Port Configuration button, which I select as Airport. The next screen shows me the iMac Internet Sharing / Airport Network I created previously. I click on Continue again, and am asked if I use DHCP or PPPoE to connect to the Internet. I select DHCP and press Continue. The next screen asks me if I use a DSL or Cable modem to connect to the Internet, to which I respond 'Yes'. I am then asked to restart the cable modem. At this point, I am hesitant to do so as I have several people using online databases open on my desktop and don't want to cut them off if they are online. I shall wait until the wee hours of the morning to proceed and let you know, hopefully, of my success. I think that getting out through my cable modem is the problem. ISPs may also have ways of blocking this type of sharing, so that may be a further complication.
  • 12. Re: Internet Sharing not working?
    Lumière du Jour Level 1 Level 1 (0 points)
    Further research has found much discussion of this problem on non-Apple Sites. When setting up my Airport Network to share I see the following screen for my different connections:

    https://dl-web.getdropbox.com/get/Photos/IP%20Sharing.png?w=fda757f5

    Using Google, looked up ("self-assigned IP address" "may not connect" Mac Airport) and found this thread. The last message, #8, shows the most promise, but I am not yet ready to shut my computer down.

    http://forums.macrumors.com/showthread.php?t=712208

    Graham
  • 13. Re: Internet Sharing not working?
    lindstroem Level 1 Level 1 (0 points)
    I have exactly the same problem as above. I have version OS X 10.5.7 and I am not able to start internet sharing. The icon in the top right corner of the screen does not change to the upward pointing arrow and it does not indicate that any network has been created (nor can one be found by other computers).

    Please advise on a solution for this problem, (or bug?)
  • 14. Re: Internet Sharing not working?
    yar2050 Level 1 Level 1 (10 points)
    having the same problem, but it's not JUST the 10.5.7 update. Not sure what it is though. The other computer gets good DHCP and even good DNS, but cannot ping anything except the host (my OSX)... so the problem is definitely with OSX and it not sharing correctly. Hope to get some resolution on this soon!
1 2 Previous Next