10 Replies Latest reply: Aug 21, 2009 6:21 PM by KTtheTeacher
sprintman Level 1 Level 1 (0 points)
Hi folks,

This is the set up : I have a wireless router (Belkin) connected to the cable modem. My Dell laptop (pc) connects to the internet wirelessly via the router as does my (my wife’s actually) Macbook.

I recently purchased a Canon Pixma MX860 so that both computers could take advantage of this wireless set up.

The Dell had no problem connecting to the printer via the initial setup i.e with USB and then subsequent wireless connection.

The Mac, however, found the various networks no problem, then found the SSID no problem but then could not find the printer on that SSID. Interestingly the LCD on the Canon, which goes into sleep mode after a period of inactivity, lights up again when the Mac is searching for the printer.

I have tried various suggestions such as removing the router to try and connect directly to the printer, setting up with the Dell turned off, reloading the drivers, downloaded the driver wizard from Canon.

Things I haven’t done… I have not set it up as a shared printer; I have not downloaded “Bonjour” because the printer is not directly (via usb) connected to any of the computers. But maybe these things have to be done????

Any suggestions?

macbook 15inch, Mac OS X (10.4.11)
  • PAHU Level 6 Level 6 (15,625 points)
    To add the Canon printer when it is configured as a wireless device, you need to select More Printers > Canon IJ Network. This new window should show the MX860 with its MAC address shown in brackets. When you select the MX860 in this window the driver should automatically be selected.

    BTW - the printing forum would have been the best place for this post
    http://discussions.apple.com/forum.jspa?forumID=1224 (I saw your original post in the Airport forum)

    PaHu
  • sprintman Level 1 Level 1 (0 points)
    Thanks for the reply PaHu, couldn't find the printer forum.....

    Also, no joy with your suggestion.

    No printer is being shown. The Macbook doesn't seem to be able to find the printer.

    Spent 3 hours on the phone with Canon. They couldn't help either.
  • PAHU Level 6 Level 6 (15,625 points)
    Okay. Then you might have a problem with the Canon IJ Network Tool. There is a version that is included with Leopard and a later version that is available via the Canon web site. This later version is the one that you want.

    To check the version you are currently using, open Finder and navigate to Mac HD/Library/Printers/Canon/BJPrinter/Utilities. Here you will see the Canon IJ Network Tool. Highlight it and do a Get Info (Command I). The Info window will show you the version you have installed under the General section. If this is not v2.6.6, then I want you to trash this tool and get the latest version from

    http://support-au.canon.com.au/contents/AU/EN/0200051102.html

    After installing this version and restarting the Mac, try adding the printer again, via More Printers > Canon IJ Printer. Hopefully the MX860 will be visible now.

    PaHu
  • sprintman Level 1 Level 1 (0 points)
    Cheers PaHu,

    I'll try that.
  • sprintman Level 1 Level 1 (0 points)
    Nope,

    still no joy.

    Printer shows up when connected via USB (and prints), but nothing is showing when unplugged and Wireless Network is active. It does not show in the available printers list.

    Also, my error, I'm on 10.5 not 10.4.11.
  • PAHU Level 6 Level 6 (15,625 points)
    Can you confirm that after you click the + to add the printer, you are then selecting More Printers > Canon IJ Network. You cannot add the network printer via the Default browser view - this is only when it is connected to the Mac via USB.

    If you are selecting More Printers > Canon IJ Network, then I would turn off the power to the MX860 for about and minute and then turn back on again. Then I would try again to add the printer, selecting More Printers > Canon IJ Network. When you do select this view, the MX860 should appear with its MAC address in brackets (00.00.85.xx.xx.xx). If it does appear, then you select it and click the Add button to complete the process.

    PaHu
  • maryhark Level 1 Level 1 (0 points)
    As a note: I purchased a macbook and mx860 july 2 and am trying to set it up wireless.
    I am getting the same exact behavior as the other person.
    I also have installed all of the latest drivers and utilities from Canon.
    After the utility has done it's "Connection Performance" check (which works fine and responds good),
    But the screens that follow don't have any printers to select.

    Two things: when I remove the USB cable I'm removing it from the computer side and not the printer side -- don't know if this should make a difference.
    Also, I was wondering if there might be some setting that has to be enabled in the wireless router?

    If I can't get this working by tomorrow it will be hopeless so I'll just have to use the USB connection (which, btw, works fine).
    Very disappointing.

    btw. this thread was very helpful in showing me where the canon network utility was stored. thanks.
    ken (writing for my mom)
  • PAHU Level 6 Level 6 (15,625 points)
    Hi Ken. Not sure if I have gotten back to you in time, but in case I have then I suggest that you need to turn off the power to the printer when you disconnect the USB cable. Also, it doesn't matter which end you disconnect it from - the important thing is that it is disconnected.

    Note that if the performance check was successful, then there shouldn't be anything else you need to do with the router. Although, I have seen the Canon's get fussy when the wrong number of characters are set for the password when using WEP encryption. Are you using WEP or WPA?

    Pahu
  • inthamixxx Level 1 Level 1 (0 points)
    i can't believe how frustrating this is. I recently converted to a Mac and bought a Mac Book, iMac, Airport Extreme, and this printer. i have installed the canon software numerous times on my iMac to set up the wireless connection. yes, the airport extreme recognizes the printer and i am able to connect to my private and guest networks. the signal strength is good. It's the next part that I'm always stuck at. The Printer settings does not display when i choose More Printers and select Canon IJ Network. I called Apple support and we tried changing my network settings to an unsecured network and it still has the same issue. It was recommended this may be Canon driver issue and advised me to contact Canon. I reset the Airport, changed my network name and password .. i think i tried everything and it still does not work. What was I thinking when i said i wanted to convert to Mac? I can't move forward and connect my macbook or pc yet until I successfully connect the imac. Yes, i installed the latest canon IJ Network tool. of course the USB connection is fine but that defeats the whole purpose if why i bought this printer. please advise how to fix. this is getting very frustrating.
  • KTtheTeacher Level 1 Level 1 (0 points)
    Just in case this is still getting checked, I had the same issue you did. When I did a pcap of what the Canon tool was trying to do, it's just doing a network broadcast. If your wireless network is in a different broadcast domain, then the IJ tool won't work. The way I solved it was wired the macbook into the same network/switch with an IP in my core network, and the printer popped right in. So if you haven't tried, that might help you out.

    For me I have 3-4 wireless networks, all separated into different wireless subnets (192.168.2.x/24 for guest and home, 192.168.150/200/254.x/24 for some work related wireless networks, and my core network of 192.168.100.x/24). My Canon is 192.168.100.51, so I plugged the macbook into the core network LAN and got an IP in the same broadcast domain. Once I reran the IJ tool, the printer popped right in.

    It would be nice if Canon would allow you to manually put in an IP address to 'discover' the printer with instead of a simple network broadcast.