Previous 1 2 3 Next 1,980 Replies Latest reply: Dec 16, 2009 7:57 AM by Brett L
IanBurrell Level 1 (0 points)
Has anybody had any problems with new MacBook Pro after yesterday's firmware update with third party hard drive? I got a MacBook Pro 13" recently, swapped the 320 GB hard drive from my old MacBook. After reinstalling the OS for new hardware drivers, everything was working fine.

After the firmware update yesterday, the machine has started freezing randomly; the spinner comes up sometimes when reading or writing to the drive. The hard drive, a WD Scorpio Blue, supports SATA II. My suspicion is that there are intermittent data errors when using the SATA 3 Gbps interface. It could be an incompatibility between the controller and drive or the ribbon cable isn't good enough for newer SATA.

Does anybody know of a way to force the drive or the controller to use SATA 1.5 Gbps? Can I revert to the old firmware?

MacBook Pro 13", Mac OS X (10.5.7)
  • OnLnAgent Level 1 (135 points)
    You can restore the firmware from CD. See for more information.

    Hope this helps.
  • JoeyR Level 6 (8,280 points)
    You missed this little part...

    +*Note: This CD cannot be used to return an Intel-based Macintosh computer's firmware to a previous version if a successful update has already been performed.*+
  • neuroanatomist Level 7 (31,690 points)
    OnLnAgent wrote:
    You can restore the firmware from CD. See for more information.

    OnLnAgent - you may want to read the kbase article you to which you are providing a link. It states that a Firmware Restoration CD can only be used +" restore the firmware *_after an interrupted or unsuccessful update_.* ...This CD cannot be used to return an Intel-based Macintosh computer's firmware to a previous version if a successful update has already been performed."+ An interrupted or unsuccessful update means a computer with serious issues (i.e., cannot boot from the internal drive).

    In the OP's case, the firmware update was successfully installed (even though that installation has resulted in issues), so the Firmware Restoration CD is useless.
  • Vitaeergo Level 1 (0 points)
    I had an Intel X25 installed in my new (2 days old) MBP 15 which worked splendidly before the update. Afterwards, the MBP won't even recognize the drive, although I can use the drive in other machines.

    Not sure what happened, but I had to put the old (ahem, 2 day old) drive that came with the MBP back in to use it.
  • efenska Level 1 (0 points)
    I ordered a WD Scorpio Blue 500GB SATA II drive for my 13" MBP from Amazon, and it was delivered today. I have not applied the firmware updateyet. I am concerned that if I upgrade the firmware, and then upgrade the drive it's not going to work.

    Has anyone successfully upgraded the firmware with a 3rd-party drive installed?
  • AlecGold Level 1 (0 points)
    I had a WD 320Gb from my "old" Macbook pro 17" and after the firmware update it doesn't do very well.
    it boots, but only if I reset the PRAM, and the fan doesn't come about 2001rpm, even if the processor gets to 91C. It isn't very funny.
  • whaleface Level 1 (0 points)
    I think I'm seeing the same thing. I just bought a new MacBook yesterday and asked for a hard drive upgrade to 320gb, 7200rpm, and they gave me the WD Scorpio Blue (which I noticed because that's probably the dumbest name I can think of to describe a hard drive). I took it home and put in the new disk, and it's the same freezing behavior. No disk access can happen at all for 20-30 seconds, then usage spikes, then no disk access at all.

    It upgraded the firmware right after I installed the OS, and I'm pretty sure that's what started the issue, since it installed the OS quickly enough and booted much quicker. Though I'm not positive because I didn't use it for long before the upgrade.

    I took it back to the store and they say it works fine with the pre-installed HD (250gb, 5400rpm) but not with anything else they put in there. So I'm waiting for another call to see if I'm just going to have to deal with the factory drive.
  • jlamarp Level 1 (0 points)
    I am seeing simular issues with my WD Scorpio Blue 500GB SATA II drive after performing the firmware upgrade. I've called Apple support and have also been to the Apple Store and neither could help me resolve the problem.

    My new MacBook Pro's performance has gone down the toilet since this latest firmware upgrade. It's bordering on un-usable now.

    Since it appears that there is no way to un-install the firmware upgrade, the Apple folks suggested that I do a clean install of the OS to see if that fixes the performance problems.

    We'll see...
  • efenska Level 1 (0 points)
    It sounds like if I plan to use the 500GB WD drive I just received from Amazon, I better avoid the firmware upgrade... for now. I did notice in the statement Apple made about the firmware that although the SATA speed is now 3.0Gb, all of the traditional hard drives that are available with the latest MBP's are 1.5Gb. Thus, I see no value-added to a faster controller unless you're going with SSD. What sense is this upgrade if it renders the notebook non-upgradable? I can't believe that Apple would let this go on for long. Hard drives fail, and a notebook with such a finicky controller is going to be mighty hard for Apple to support in warranty if a mainstream hard drive won't work - even at 1.5Gb.
  • nathojg Level 1 (0 points)
    I just got a new MacBook Pro (2.53ghz 15" model). I installed a Seagate 7200.4 500gb drive which works perfectly in my old MacBook Pro (Core Duo 2ghz).

    Since applying the firmware update I'm experiencing the same problems as IanBurrell, random freezing and spinning wheel. It will also fail to boot sometimes. In verbose mode you can see read errors when trying to load the kernel.

    I tried jumpering the drive to allow 1.5gbps sata only and it actually worked well for a while (was able to copy 7gb of data before problems, rather than only 100mb) but ultimately started freezing and giving read errors on boot again.

    I hope apple can come up with a fix for this - or at least a way to reverse the firmware update. It seems the restore CDs don't support the new Machine IDs at the moment either.
  • Andrew Myers Level 1 (0 points)
    I would like to add that i'm experiencing the same thing as the above users. I am using the Intel x25-M. This is terrible, the laptop is near-unusable
  • jlamarp Level 1 (0 points)

    After dealing with this issue ALL DAY, I am finally back up and running.

    I ended up having to re-install my original 250GB HDD that came with my MacBook Pro. After a clean installation of OS X 10.5.7, I then restored my data from a Time Machine backup and it looks as if all is well, so far at least.

    Just for kicks, I put the WD 500GB HDD back into the MacBook Pro, and confirmed that the same performance issues still existed. So, it appears as if the EFI 1.7 firmware update has a problem with the WD 500GB HDD, at least in my case it does.
  • efenska Level 1 (0 points)
    I've read posts by users of Seagate and Western Digital drives having the issue, so I doubt it's specific to one brand, size, RPM, etc.

    Makes you wonder what brand of 500GB drive is available from the online store when customizing your MBP. I haven't heard of any of those going bad.

    Anybody buy the 500GB SATA drive as a CTO option from the online Apple store? What is the model & manufacturer?
  • iyacyas Level 4 (1,535 points)
    So this is scaring me. I'm contemplating the retirement of my dear old 12" Powerbook with the new 13" Pro. I was going to get the lower end model and DIY upgrade but then there was the SATA issue (even though it doesn't effect traditional drives). Then that was fixed, WoooHooo!!! No wait now there's problems again. Good thing my 12" is still a healthy work horse.

    Does anyone know if the firmware update applies to the 2.53 model which is supposedly ready for SATA II correct. If not I'll just spend the extra dough and buy it to avoid all the firmware issues. I gotta have at least 500Gs.
Previous 1 2 3 Next