Previous 1 2 3 4 Next 1,980 Replies Latest reply: Dec 16, 2009 7:57 AM by Brett L Go to original post
  • OnLnAgent Level 1 Level 1 (135 points)
    "Anybody buy the 500GB SATA drive as a CTO option from the online Apple store? What is the model & manufacturer?"

    I have the 500GB 7200 rpm SATA drive and it works fine it is a seagate and here is a link to the product info:

    http://www.seagate.com/ww/v/index.jsp?vgnextoid=3a07bfafecadd110VgnVCM100000f5ee 0a0aRCRD&locale=en-US

    This is what the Macbook is showing after the firmware update:

    NVidia MCP79 AHCI:

    Vendor: NVidia
    Product: MCP79 AHCI
    Speed: 3 Gigabit
    Description: AHCI Version 1.20 Supported

    ST9500420ASG:

    Capacity: 465.76 GB
    Model: ST9500420ASG
    Revision: 0006APM2
    Serial Number: 5VJ*KT
    Native Command Queuing: Yes
    Queue Depth: 32
    Removable Media: No
    Detachable Drive: No
    BSD Name: disk0
    Mac OS 9 Drivers: No
    Partition Map Type: GPT (GUID Partition Table)
    S.M.A.R.T. status: Verified
    Volumes:
    Macintosh HD:
    Capacity: 465.44 GB
    Available: 363.87 GB
    Writable: Yes
    File System: Journaled HFS+
    BSD Name: disk0s2
    Mount Point: /
  • efenska Level 1 Level 1 (0 points)
    OnLnAgent, you're saying you installed the Seagate 500Gb 7200.4 drive yourself, upgraded to the EFI 1.7 firmware and your MBP is running fine, is that correct?
  • GoodOmens Level 1 Level 1 (0 points)
    I am actually experiencing this exact same problem with the stock Apple drive.

    Is anyone else?
  • Mini-Mac Level 3 Level 3 (800 points)
    On June 10, 2009 (day of purchase) I installed my Western Digital Scorpio Blue WD5000BEVT 500GB 5400 RPM 8MB Cache 2.5" SATA 3.0Gb/sWD drive into my new 13.3" MBP 2.53GHz with no problems. On June 23rd I installed the MacBook Pro EFI Firmware Update 1.7 and haven't had a single problem.....in fact. My computer is running faster. The prof is the benchmark test I preformed before and after the update.

    Before total score 141.56
    After total score 152.45
  • guykuo Level 1 Level 1 (40 points)
    My MBP 13 (2.26 GHz) after the firmware update is still working fine with a Seagate 320 gb drive (an Apple drive from a new Unibody 17 inch.)

    ST9320421ASG:

    Capacity: 298.09 GB
    Model: ST9320421ASG
    Revision: AP81

    No hangs or crashes post the EFI firmware update.
  • efenska Level 1 Level 1 (0 points)
    Glad to hear this worked for you. Wondering why yours works but others with the same drive don't? Just wondering if there might be some mods by others that may be contributing to the issue, like 3rd-party RAM added, or mis-configured jumpers on the drive.

    When you put the drive in, that was the only physical upgrade you performed, right? Did you have to change any jumpers on the drive? I'm assuming from your post that you probably didn't.
  • guykuo Level 1 Level 1 (40 points)
    No jumpers on the drive.

    Memory is 4GB installed by Apple (CTO)
  • guykuo Level 1 Level 1 (40 points)
    Only thing unusual about my Seagate drive is that it is an Apple supplied unit from a Unibody 17 instead of a retail. (I pulled it to put an XM-25 SSD in the Unibody)

    However, I doubt that makes a difference.
  • whaleface Level 1 Level 1 (0 points)
    efenska wrote:
    Glad to hear this worked for you. Wondering why yours works but others with the same drive don't? Just wondering if there might be some mods by others that may be contributing to the issue, like 3rd-party RAM added, or mis-configured jumpers on the drive.


    I know in my case there was nothing else done to the machine. I took it straight out of the box and put in the new hard drive, installed the OS, upgraded the firmware and the problem started. I wonder if it's just a few specific drives that aren't working? Mine (scorpio black, not blue like I said earlier) had no jumper on it and though I didn't try messing with it, the manual doesn't seem to imply the jumper settings would downgrade sata.
  • W1ld Ch1ld Level 1 Level 1 (5 points)
    MacBook Pro 13", stock 160GB Fujitsu hard drive. After the firmware update my system reports SATA 3Gbps. From time to time I get the beach ball for 20-30 secs on all applications.
  • OliverF Level 1 Level 1 (0 points)
    Same problem here. After the upgrade my MBP freezes every 2-3 minutes for 15-30 seconds.
    It's horrible.

    I had been using it for 1 week before the upgrade without any issues.

    Ollie.
  • iain_nl Level 1 Level 1 (0 points)
    Same problem here with the Intel X25-m 80GB hard disk.
  • Xuyen Level 1 Level 1 (5 points)
    I believe I'm having the same problem here. 15'" 2.53GHz MacBook Pro, 4GB RAM, 250GB Hitachi HD. I just got my WD Scorpio Blue 500GB HD in today. Replaced the 250GB with the 500GB WD. Reinstalled Leopard from original install disc. Noticed that it took alot longer to install than normal. I'm constantly getting lag and spinning wheel while trying to do anything on the machine. Still running Time Machine Migration Assistance to get all my data/programs back. Its still running now!!

    Originally updated firmware from 1.5 to 3.0 on the original 250GB Hitachi HD when the firmware update was released by Apple. Didn't have any problems whatsoever until the HD was replaced today with the WD. Will there be a solution? Please help!
  • coop0129 Level 1 Level 1 (10 points)
    I have done the EFI 1.7 update on my MacBook Pro 13". It is all original components. 160GB Fujitsu HDD and 4 GB ram from the factory. Everything is up to date and I have no peripherals attached. I have a Seagate Momentus 7200.4 7200 rpm 500 gb hdd sitting in the retail box model number ST905003N3A1AS-RK. It does NOT have the G-Force protection as I have heard this causes kernal panic and the MBP has the SMS in it already. Since the retail outlet I purchased from has a 30 day return policy even on open hard drives, this is a no brainer to test this drive even with all the problems I have been seeing. I will put the drive in tomorrow morning and post the results. Hopefully this is not a problem on ALL MBP models that have the update and only isolated.

    Is there anything specific any of you with this problem do to make it more noticeable? I will keep updating on my experience with this process.
  • Xuyen Level 1 Level 1 (5 points)
    Well I contacted Apple support over the phone and directed the representative to this thread. He hasn't heard anything about it yet, but did suggest that I could bring in my MacBook Pro to the Apple Store to have to rollback the firmware. He said that they have a different method on doing this unlike the one that we can do ONLY if the firmware update failed. He did seem to believe that Apple will more than likely fix this issue in another firmware update that will address the incompatible hard drives. I have now reinstalled my Hitachi 250GB hard drive that came with my MacBook Pro back into my machine. Its running NORMALLY once again. I guess I will either go into the Apple Store to have them do this or I may just leave the Western Digital Scorpio 500GB hard drive that I ordered out until a solution is found.
Previous 1 2 3 4 Next