7 Replies Latest reply: Jul 3, 2009 6:09 AM by pterobyte
Nathan005 Level 1 Level 1 (20 points)
I'm running Leopard server 10.5.7.
I can send out mail, but cannot send mail to the server
when I try to send mail I receive the following error:

*554 554 5.7.1 <user@domain.com>: Relay access denied (state 14)*

The Log for the request says this:

Jun 25 00:43:33 server postfix/tlsmgr[25221]: warning: no entropy source specified with parameter tlsrandomsource
Jun 25 00:43:33 server postfix/tlsmgr[25221]: warning: encryption keys etc. may be predictable
Jun 25 00:43:33 server postfix/smtpd[25219]: connect from mail-yx0-f185.google.com[209.85.210.185]
Jun 25 00:43:33 server postfix/smtpd[25219]: NOQUEUE: reject: RCPT from mail-yx0-f185.google.com[209.85.210.185]: 554 5.7.1 <user@domain.com>: Relay access denied; from=<user@gmail.com> to=<user@domain.com> proto=ESMTP helo=<mail-yx0-f185.google.com>
Jun 25 00:43:33 server postfix/smtpd[25219]: disconnect from mail-yx0-f185.google.com[209.85.210.185]

Help would be great,
Thanks

MacBook Pro, Mac OS X (10.5.7)
  • Camelot Level 8 Level 8 (46,450 points)
    Your mail server is misconfigured - it's not set to accept mail for the domain in question.

    If that isn't sufficient information to help you solve the problem, post the contents of postconf -n so that others can highlight the problem(s).
  • Nathan005 Level 1 Level 1 (20 points)
    Thats what I thought... I haven't been able to get my Domain name to forward to my FQDN.
    Here is the output - I have been testing this by replying to a message sent from the server.

    command_directory = /usr/sbin
    config_directory = /etc/postfix
    content_filter = smtp-amavis:[127.0.0.1]:10024
    daemon_directory = /usr/libexec/postfix
    debugpeerlevel = 2
    enableserveroptions = yes
    html_directory = no
    inet_interfaces = all
    mail_owner = _postfix
    mailboxsizelimit = 0
    mailbox_transport = cyrus
    mailq_path = /usr/bin/mailq
    manpage_directory = /usr/share/man
    mapsrbldomains =
    messagesizelimit = 20971520
    mydomain = mydomain.us
    mydomain_fallback = localhost
    myhostname = server.mydomain.us
    mynetworks = 127.0.0.0/8,192.168.0.0/16
    newaliases_path = /usr/bin/newaliases
    queue_directory = /private/var/spool/postfix
    readme_directory = /usr/share/doc/postfix
    sample_directory = /usr/share/doc/postfix/examples
    sendmail_path = /usr/sbin/sendmail
    setgid_group = _postdrop
    smtpdclientrestrictions = permit_mynetworks rejectrblclient zen.spamhaus.org permit
    smtpdenforcetls = no
    smtpdpw_server_securityoptions = cram-md5
    smtpdrecipientrestrictions = permitsasl_authenticated,permit_mynetworks,reject_unauthdestination,permit
    smtpdsasl_authenable = yes
    smtpdtls_certfile = /etc/certificates/server.mydomain.us.crt
    smtpdtls_keyfile = /etc/certificates/server.mydomain.us.key
    smtpduse_pwserver = yes
    smtpdusetls = yes
    unknownlocal_recipient_rejectcode = 550
  • pterobyte Level 6 Level 6 (10,910 points)
    Add mydomain.us to Server Admin - Mail - Settings - Advanced - Hosting - Local Host Aliases
  • Nathan005 Level 1 Level 1 (20 points)
    Thanks, that worked.

    Is that always required with leopard setup, or is there a DNS/MX issue?
  • pterobyte Level 6 Level 6 (10,910 points)
    Glad you got it sorted.

    It is a glitch in Server Admin. It does not set the mydestination parameter in main.cf correctly.
  • Nathan005 Level 1 Level 1 (20 points)
    Got another error, don't know if its related

    554 5.7.1 Service unavailable; Client host [ISP.Dynamic.IP.Here] blocked using zen.spamhaus.org

    Externally my users Dynamic IP's are on zen's blacklist, and since the IP's are Dynamic there is no point in allowing them.

    Any help pointing me in the right direction would be great.
  • pterobyte Level 6 Level 6 (10,910 points)
    This is unrelated.

    You will need to setup authentication and make sure your users authenticate to send through your server.

    If you have any questions, please open a new thread.

    HTH,
    Alex