12 Replies Latest reply: Oct 23, 2009 7:25 AM by Bardiya_z
jrc362 Level 1 Level 1 (5 points)
Hello.

My optical drive will not read any burned DVD's, (DVD-R) not even ones that I burn with iMovie and iDVD. It reads Netflix DVD's etc, and CD's just fine, but any burned DVD I put in it reads it as a "blank disc". Specifically "you have inserted a blank disk..." i.e. it doesn't spit it out. The DVD's play perfectly fine on my older MacBook but not on my MacPro. I am running OS 10.5.7. I have repaired all disk permissions to no avail. Any suggestions?

MacPro, Mac OS X (10.2.x)
  • noice_T Level 3 Level 3 (545 points)
    What DVD brand disks are you using? I've always had trouble with Fuji Film for example. I found that memorex worked good for me.
  • jrc362 Level 1 Level 1 (5 points)
    I am using Maxell DVD-R 4.7 GB which I have used many times before with no problems.

    My guess is it is some kind of software problem since my computer can read "professional" DVD's and all CD's.

    Thanks for the reply.
  • noice_T Level 3 Level 3 (545 points)
    Understood, however you say you haven't been able to read ANY dvd-r from the time you bought the MP correct? And you are only using Maxell, right?

    Have you tried different brands already? The Maxell disks might work on one computer flawlessly, but have trouble with another.

    If you were able to recognize Maxell DVDs BEFORE, but NOW the MP will not, then something seems strange...however if you are only using maxell and nothing else, seriously try a different brand. It might work.
  • jrc362 Level 1 Level 1 (5 points)
    Thanks again for your reply. To clarify, my MP used to be able to read all DVD's. Now, it seems unable to recognize ANY brand of personally made DVD's. As I said before, it is able to read everything else (Professionally made DVD's and CD's as well as any brand of personally made CD's) Strange indeed!
  • l_elephant Level 2 Level 2 (375 points)
    professional, store bought titles are pressed. A master is fabricated and the copies are physically pressed, not burned with light.

    All the solutions consumers use, burn the media with lasers.

    Frankly, after seeing photomicrographs of burned media, im very, very amazed that this process works at all, for any extended length of time. At least at the prices were paying for these burners. The pits created by the laser, are very messy.

    im not surprised that i have a whole shelf of 'burned out' burners. My OEM optiarc just gave out 5 days ago. Errors reading, writing, hanging, crashing. Im not going to replace it. I put a IDE hard drive in the upper bay instead.

    what can we expect for 30$ now? Plastic parts, gears and belts. In something that spins so fast and vibrates and gets vibrated by the rest of the machine.

    my guess is that your drive is tired and dying.

    my suggestion is to try your disks that fail in any other machine you can try. If they work in other peoples drive besides your macbook, then the culprit is your tired macpro drive. Then pull it.

    my fiinal suggestion is to not depend on optical media (burned at least)
  • rwessels Level 1 Level 1 (0 points)
    I have the exact same issues. I did not find the response in the thread helpful AT ALL. Is there anyone out there who has any insight other than buy a new optical drive? HELP
  • berryday38 Level 1 Level 1 (0 points)
    Just burned short iMovie using iDVD with Maxell DVD-R media at 6X. Having similar problems. DVD will play on 2 other MACs and DVD players, but will not play on the MAC PRO used to record it. After in DVD player for a while it skips along apparently trying to buffer data. Found if I clicked on Title or Menu after about 1 minute, then could select chapter and play the iMovie as if nothing wrong. Also doing same thing on most DVD's I've recorded earlier, even one using my previous MAC. It plays purchased DVD's, data disks & CD's OK. Is it a 10.5.7 problem or is the drive going bad? It's having a problem initially mounting and reading the DVD. Sure acts like could be a DVD Player S/W problem. First time I've used it after update to 10.5.7. However the DVD plays OK on my wife's iMAC using 10.5.7. Just purchased the MAC PRO Dec 08 so guess drive is still in warranty. Thanks for any help.
  • Cut'n Paste Level 1 Level 1 (95 points)
    I too suddenly have a problem where almost any disc i burn on the internal drive will write, verify, and mount, but if ejected, will be reported as blank the next time it's inserted.

    The drive will read commercial (stamped) DVD's, but reports some discs written just weeks or months ago as blank. An external drive will read the same discs without incident, so the drive is writing properly.
  • sinsio Level 1 Level 1 (0 points)
    Hello. I am having a similar issue with my Macbook Pro. Whenever I insert a data DVD, it will try to read it for a while before ejecting it. The DVD is able to be read on my Windows XP computer. This has not been a problem for me until recently.
  • Cinemagic Level 1 Level 1 (140 points)
    Add me to the list. Burned DVD-R that used to play under 10.5 will no longer play on 10.6. They play fine on a Windows XP and Windows Vista machine. Personally, I think 10.6 broke the DVD-R play feature. They will burn, but not be recognized or play. Unless someone can say absolutely that a DVD-R will play on a MacBook Pro with OS X 10.6, I say it's a bug in 10.6
  • Cinemagic Level 1 Level 1 (140 points)
    It's not the media and it's not the burn. It's the OS. It worked well with previous versions. But it seems that 10.5.7 and later broke it.
  • Bardiya_z Level 1 Level 1 (0 points)
    I have the same problem, It exactly looks like Something fundamentally have changed about dvd handling, I have a macbook 2008, I had Lots of dvds burned with leopard with no problem, I had them all tested, some times after I upgraded to snow leopard I noticed that some dvds are not recognized at all and ejected after about 1 minutes of trying to read! but strangely this happens in a special brand of dvds and more strange is that I can write on them but can not read what I just burned! my dvd drive can read some brands perfectly (even if the dvd itself has lots of scratch on it), some brands after lots of tries, and some brands never (although it can burn the same dvds with no problem)... this all happened after snow leopard, I have used my dvds just the day before of leopard, but the day after this problem showed up! although I'm not totally convinced the problem is due to OS upgrade but I can't see any other explanation. I also have bootcamp and Windows vista installed on same macbook, and vista also can't read after upgrade! so they have done something very deeply that changed both OS behavior or they did the same change to bootcamp drivers also! I Don't know what to do!