Previous 1 2 Next 19 Replies Latest reply: Nov 19, 2009 1:24 PM by laserheart
Setagayan Level 1 Level 1 (0 points)
I set my iPhone in Airplane Mode (to not have calls coming in) while recording a long business meeting using the new Voice Memos application under iPhone OS 3.0 with my one year old 3G. When I stopped recording the counter showed that I had been recording for about 3 hours and 13 minutes.
I labeled my recording “Meeting” and it shows that my recording started 26/06/2009 at 13:30 (1:30PM).
I was looking forward to become able to transfer my recording to my iMac or MacBook PRO.
However, next time I opened the Voice Memos application and find my file correctly labeled Meeting 26/06/2009 13:30, the counter at the right (in front of the error) simply says 0s. Trying to play anything back produces no result, because the data seems to be gone (despite that the file name and date/time remains).
Do anyone here have an idea of what could have happened? Maybe I ran into some kind of maximum recording time limit? But even so, I would have expected the recording to remain up to that time limit.
As it is, the entire exercise was useless and ended in big disappointment.
My confidence in this application is currently zero.

iPhone 3G/3G S, iPhone OS 3.0
  • Setagayan Level 1 Level 1 (0 points)
    Since, so far,no one has joined this topic, and also since I found a solution myself in the meantime, I felt it would be educational to share my experience.

    Over this weekend, my cell phone provider (SoftBank Japan) had my new 3G S 32GB ready, so I transferred to the new model which really is faster, smoother, more capable. It also renders web pages better among many other minor and major improvements in performance as well as increased capabilities (not the least video).

    One problem with switching iPhone is that Notes and SMS messages do not get transferred via iTunes to the new phone, so I searched the internet for advice on methods and tools. This lead me to an application called "Phone View" by www.ecamm.com.

    After connecting the old iPhone (with SIM removed) to my iMac, the Phone View application lets me look at my iPhone as a DISK (I selected the "Show Entire Disk (Advanced Mode) option under Preferences). There is a sub-folder called "Recordings", and inside here I found two files 20090626 133024.m4a and 20090626 133024.mov. Clicking on each file made them download to my documents folder on the iMac.

    Disappointingly, the .m4a version of the file seems to be non-functional, so any clicking or even dragging it into iTunes, or even trying to open it within the QuickTime application provided no result. However, clicking the .mov file opened QuickTime and audio playback started immediately.

    The file-size was 426 MB of the entire 3 hours and 13 minutes long voice memo recording. I had the iPhone oriented upside down in my shirt pocket throughout the recording, and each of the 4 voices in the room are recorded extremely clearly so it is possible to hear every word that was spoken.

    For whatever reason the original .m4a file of "Voice Memos" have broken, while miraculously a .mov file has been created in its place.

    I have no explanation for why this happened, and I am sure that if I had not purchased the "Phone View" application, I would never had found out what happened, nor had I been able to retrieve the audio.

    Actually the main reason for acquiring "Phone View" was to transfer my "Notes" and also "SMS" messages from the old iPhone to the new 3G S. For whatever reason I have not yet been successful in transferring this data, while instead I found the lost voice memo recording.

    I hope that my story will help someone who happens to experience a similar problem.

    However, I am still interested to hear if anyone can provide an explanation to what happened
  • ckawai Level 1 Level 1 (0 points)
    I am using iphone 3G 16GBs model, not sure if my theory works but will give my 2cents on this.
    After recording, it seems that voice memo application needs some time to finish converting the .mov file into .m4a within the app. you can see that the conversion in progress when you open the recording lists straight away after a recording is finished.

    By the way, I recommend a external mic especially for this as the build in mic is too weak in picking up sound that's a arm away from you. It's initially meant for picking up your voice in phone call anyway.
  • Setagayan Level 1 Level 1 (0 points)
    Appreciate ckawai's reply. However, I am quite certain there was no visible conversion process going on after the recording was stopped. (Is there any documentation anywhere, e.g. for iPhone developers, showing that Voice Momos will record to .mov files that after completion get converted to .m4a files???) I watched the file data, recording length (3h 13 min xx sec) and everything looked well. Next time I opened the Voice Memos application, the recording length read 0s. The .mov file was invisible until I looked into my iPhone using the PhoneView application. The .m4a file was also visible, albeit with a smaller size (about 260 MB) than the .mov file (about 465 MB). The .m4a file is not playable by neither iTunes nor QuickTime.

    Regarding the capability of the iPhone's built-in mike; it was capable enough to capture 4 voices clearly in a largish conference room with a fair distance between each person. It is entirely possible to transcribe the entire 3 hours 13 minutes session without losing a single word.

    Remember this recording was done with the iPhone in a shirt pocket with mikes facing upwards (meaning the iPhone was positioned upside down on purpose).
  • SoccerPlayer22 Level 1 Level 1 (0 points)
    ckawai,

    I was wondering about that. Are there any particular external mic products that you have found to work well and would recommend?
  • dkhome Level 1 Level 1 (0 points)
    Setagayan,

    Thank you for your follow up post on a solution. You helped me recover a "lost" voice memo that I feared was lost forever.

    Your post helped me recover a conversation with a family member that I will never be able to repeat.

    Thank you!!!
  • Rainystreets Level 1 Level 1 (0 points)
    Thanks! This helped me too! Same scenario.
  • ketsensei Level 1 Level 1 (0 points)
    Setagayan,

    Thank you so much!!! Just yesterday I recorded but then was unable to play a half-hour voice memo exactly as you described. Today, after reading your post I tried what you suggested, and it worked! Thank you so much again for going to the trouble of posting your solution even though no-one had replied to your initial post.
  • hydrophilic Level 1 Level 1 (0 points)
    Setagayan,

    I want to add my thanks to the growing chorus. You have saved me and others a lot of time - not to mention recovering valuable recordings.

    This is a major flaw that needs fixing - especially given that Recorder is an important app that Apple showcased at the launch of iphone OS3.
  • JohnnyGuest Level 1 Level 1 (0 points)
    Just want to express my thanks for posting this solution. I had just recorded 45 minutes of a review for an important histology exam and was unable to listen to it. Your solution worked brilliantly. Thanks again I know other will benefit as well.
  • deadlyicon Level 1 Level 1 (0 points)
    for those of you who want to take a stab at modifying the voice memos on your iphone ive tried to make it a bit easier with this:

    !! import voice memos onto your iPhone !!

    http://github.com/deadlyicon/iphonevoicememo.rb
  • richwdo Level 1 Level 1 (0 points)
    yes, thank you very much. As a PC user, the phone view website nicely referred me to wide angle software website, home of "touch copy 09"
    After going into Options, i could view my i phone 3gs and indeed, find LOST (zero length) voice memos saved perfectly as MOV files. Who knew?? Their 15 day trial worked for me. they earned my money!
    Heavenly!!
  • jigsaw_billy Level 1 Level 1 (0 points)
    Voice Memo - Can see it on your iPhone - but does not show up in iTunes - long recording - how to retrieve the voice memo (for free)? - PC (Windows) User

    Dont worry guys, your voice memo is not lost so long as you have actually recorded it successfully!

    Here is what happened to me: I recorded 1hour 30mins on my Voice recorder on the iPhone. When I tried to play it back using my iPhone, it wouldnt work, yet I could see that there was "1hour 30mins" worth of data, but nothing would play. I was really stressed because the recording was extremely important to me.

    If you have a similar problem, I suggest to follow the steps below. It is for free, it is simple, safe and QUICK:

    1) Sync your iPhone with iTunes (and let it back it up)

    2) Reincubate:
    http://www.reincubate.com/labs/iphone-backup-extractor-how-extract-files-iphone- backup-windows/#/res/i/labs/iphonebe/3_wizard.png

    Go to the above website, if the link doesnt work by copy and pasting it, then just search "reincubate iphone extractor" in google, the first hit should be the relevant one.

    3) Download the extractor "iPhone Backup Extractor 1.0.0.12 (24th June 2009)
    Changes:Now allows for restore of calendar to CSV"

    4) Save it

    5) Open the .exe - click on "extract".

    6) Then Click on next until you come to the option to choose "manually" the files you want - clcik next

    7) Now search down for media, and under media you should see "recordings" and tick the recording that was not working (it is fairly difficult to determine which recording it is if you have many, so might be a bit of a trial and error exercise)

    8) it should save a file in your desktop - open your desktop and once you have chosen the correct file, you will be able to get your recording!

    The weird thing about this all is that I found my "voice memo" through this process to actually be a .mov file. Perhaps this happens if you go over a certain time during recording. I pressed play and it played in quicktime!

    Anyway I hope this helps. If you have any questions just reply and Ill try help!
  • CharlieinParis Level 1 Level 1 (0 points)
    great tip, I had exactly the same problem and by following your instructions I was able to retrieve a mov file which works perfectly
    I have no explanation as to why this happened, I can just add that the original m4a file was 20 MB while the mov file was over 100 MB (for a one-hour recording)
    Thanks!
  • nickwhit Level 1 Level 1 (0 points)
    Setagayan THANK YOU SO MUCH!
    This worked perfectly.
Previous 1 2 Next