6 Replies Latest reply: Jun 29, 2009 8:56 AM by Stephen J. Herzberg
Stephen J. Herzberg Level 1 (50 points)
I've looked all over and tried import within iMovie but can't do it.

I shot a short video on the phone.

Want to edit in iMovie.

How do I export from the phone or import from within iMovie?

I know this must be simple -- I just can't figure it out.

Thanks.

sjh

Dual G5 2.5, 12"PB, MBP 15" Santa Rosa, iPhone 3g, Mac OS X (10.5.4)
  • AppleMan1958 Level 7 (27,415 points)
    Sync your iPhone. The iPhoto import window should pop up. Import you movie and any photos to iPhoto.

    Now open iMovie. It should prompt you to create thumbnails for new movies from iPhoto. Say yes and let it run.

    When it is finished, look in your Events list and select iPhoto. Your movie should be there, and you can edit it by dragging clips into a project in the normal way.
  • Stephen J. Herzberg Level 1 (50 points)
    I did a sync on the phone -- the iPhoto import window did not pop up.

    And, I don't see anything in iPhoto that says movies.

    What am I doing wrong?

    Thanks.

    sjh
  • AppleMan1958 Level 7 (27,415 points)
    Is your video still in the "Camera Roll" section of the Photo App on your iPhone?
  • crumbbun Level 1 (5 points)
    I have the same problem. I have taken 2 small videos and sent them via email. Now I am trying to download them to iPhoto. I tried to download via iPhoto without syncing and I get an error saying

    "iPhoto cannot import your photos because there was a problem downloading an image"

    I get the same message for both videos. I would have thought this was a seamless process. The photo between the 2 videos downloads without any problem.
  • Stephen J. Herzberg Level 1 (50 points)
    Yes, the camera roll is on the 3GS.

    The devise is seen in iPhoto.

    However, i get a message that the files ae "Unreadable" and a list of .jpg files. The movie file is not on the list.

    The "import runs" forever with a message in the window "Finishing Import".

    The transfer worked perfectly in my MBP.

    Now what?

    Thanks.
  • Stephen J. Herzberg Level 1 (50 points)
    OK, solved it for my system.

    First, I did not have iPhoto opening up with the attachment of the phone. I do this deliberately because I don't use iPhoto -- I have an Adobe based workflow.

    Then, I found that another program that opened with the connection of the iPhone was interfering with the import into iPhoto. So I turned that program off.

    Finally I repaired permissions -- for no real reason.

    When all of this was done, it worked.