3 Replies Latest reply: Jul 1, 2009 8:35 AM by tjk
Kaytebb Level 1 Level 1 (0 points)
Ok, to make a long story short, I hope, I had an electrical fire (everyone's ok) that involved and destroyed my laptop's power cord and as part of that fun I seem to have had a power surge that has reset some of the defaults on my computer but not all. Some of the folders I created prior to the surge are gone, etc. The only real problem is that the permissions on my internal hard drive seem to have been reset. Below are the things it will and will not allow me to do.

-- I cannot copy files from a flash drive, cd or external hard drive to the internal hard drive. I get that circle with a line through it. Clicking and dragging, copy/paste, nothing works.
-- I can move stuff that is already on the internal hard drive from folder to folder.
-- I can save email attachments to the internal hard drive.
-- I can copy stuff from internal the hard drive to a flash drive, cd or external hard drive.
-- I can read the files on flash drives, cds or external hard drives, such as a movie file, just fine, they run without a glitch. The peripherals did not suffer any resets as a result of the fire/power surge. When it happened the computer shut down automatically and I think that saved the accessories from being damaged because the computer is the only thing that showed any changes after it happened.

And before someone asks, yes, I checked, I have 40 GB of HD space so it's not a space issue.

I right clicked on MAC HD and did the Get Info and looked at the details of the permissions on various files and tried shifting some of those around but even though it says Read and Write it still won't let me copy to the internal drive from other sources. Interestingly when I got to the User file it was marked Read Only but changing it to Read Write didn't help. Something I did once worked but then it stopped working so I have no idea what it was. I put everything back the way it was. Could somebody please help me? My computer is old and dieing a slow painful death but if I can make it last a little longer that will make my life so much easier. Please let me know if you need any system info or anything.

*Thank you!!*

PS. I'm not posting this on the peripheral thread because the problem isn't really the peripherals, it's the system not wanting to play nice with others, so that's why I put this over here.

Powerbook, G4, Mac OS X (10.4.11), Titanium case (for it's sake, that's a good thing)
  • tjk Level 7 Level 7 (24,165 points)
    Hi K,

    This is probably a dumb question, but you don't mention running Repair Permissions. Have you done so?
  • Kaytebb Level 1 Level 1 (0 points)
    Hi. It's not a dumb question, cause if it is then my answer is really stupid, what's a repair permission? lol I don't know what that is so I guess the answer is no, though I can guess from the name it's a program to fix permissions if the files get messed up? I knew how to change the permissions in Get Info but past that I was getting into things I don't know so I figured it was time to ask for help or I'd be on here asking how to un-erase a hard drive. jk So how would I do that and is there anything else I should do?

    Sorry if my initial post was a bit defensive. I had a moderator give me flak over some minor thing on a post once and I was supremely frustrated with this problem. Sorry if it came out kinda angry. I appreciate any help you can give me.
  • tjk Level 7 Level 7 (24,165 points)
    Repair Permissions: Applications>Utilities>Disk Utility>select HD in panel at left>click on Repair Permissions at bottom of main window and allow process to finish before quitting DU.

    Repair Disk: Boot from install disc (insert disc>restart>immediately hold down c key and keep holding it until you see “Preparing Installation”)>at first screen go to Installer Menu>open Disk Utility>select your HD in the panel on the left side>click Repair Disk at bottom of main window. Run this at least twice, and keep running it until it says “appears ok” twice in a row. If that doesn’t happen, you may need a stronger utility such as DiskWarrior or if the directory is damaged beyond repair, you may need to reinstall the OS, or you may have a damaged HD (repair utilities can only repair the directory structure, not the HD itself).