9 Replies Latest reply: Jul 1, 2009 3:26 PM by Weeble in disguise
Weeble in disguise Level 1 Level 1 (0 points)
I'm hoping someone may be able to help with a strange problem. My Pictures folder has transformed itself into a 'package' and wants an application to open it, but there isn't an option to select the finder! I can open it by right clicking and everything is there, but it isn't accessible from 'Image Capture' or for iphoto, which appears to have started a new library for itself, perhaps mistaking the 'picture' package for the library as there are files in there which are usually in the iphoto package. Is there any way to tell the folder not to be a package any more??? It seems to have happened after I restarted the computer (which I did because there were some photo files in the trash which I couldn't empty, and restarting sorted that!!)

macbook, Mac OS X (10.5.5)
  • Carolyn Samit Level 10 Level 10 (100,385 points)
    HI,

    This is a new one on me. Try deleting this file.

    com.apple.finder.plist

    /Users/YourName/Library/Preferences. Drag that file from the Preferences folder to the Trash, empty the Trash and restart your Mac.

    Since you can't access the Pictures folder from iPhoto or Image Capture, this might be a shared library issue. Go here. http://www.thexlab.com/faqs/sharedlibraryerrors.html





    Carolyn
  • Weeble in disguise Level 1 Level 1 (0 points)
    Thank you. I tried deleting the plist as you suggested but no change unfortunately. I also tried repairing permissions, and there are some items it says cannot be repaired but no idea what they are?

    "Permissions differ on "private/var/log/secure.log", should be -rw------- , they are -rw-r----- .
    Permissions differ on "System/Library/LaunchDaemons/com.apple.usbmuxd.plist", should be -rw-r--r-- , they are -rwxr-xr-x .
    Warning: SUID file "System/Library/Filesystems/AppleShare/afpLoad" has been modified and will not be repaired.
    Warning: SUID file "usr/bin/setregion" has been modified and will not be repaired.
    Warning: SUID file "System/Library/PrivateFrameworks/Install.framework/Versions/A/Resources/runner " has been modified and will not be repaired.
    Warning: SUID file "System/Library/Printers/IOMs/LPRIOM.plugin/Contents/MacOS/LPRIOMHelper" has been modified and will not be repaired.
    Group differs on "private/etc/cups", should be 0, group is 26.
    Permissions differ on "private/var/spool/cups/cache/rss", should be drwxr-xr-x , they are drwxrwxr-x .
    Permissions differ on "Library", should be drwxrwxr-t , they are drwxrwxr-x .

    Permissions repair complete"
  • Carolyn Samit Level 10 Level 10 (100,385 points)
    HI,

    Mac OS X 10.5: Disk Utility's Repair Disk Permissions messages that you can safely ignore (In other worse, you don't need to be concerned. Those are really permissions, they are messages that can be ignored.

    Did you check out the shared library link I posted?

    Since repairing permissions didn't work, you could try doing an Archive and Install.






  • Noiseboy2006 Level 3 Level 3 (905 points)
    Packages are folders with the .pkg or .mpkg extensions. The extension is often hidden but, if you select the package and press cmd+I to get info, you should be able delete the extension and revert to a normal folder.

    You obviously need the correct permissions to do this and it doesn't explain how the problem occurred.
  • Weeble in disguise Level 1 Level 1 (0 points)
    Thanks - I can't make the Pictures folder/package show me any sort of extension - I have turned on extensions in the preferences, but they are only visible for files, not for folders, and the Get Info doesn't show an extension either.

    I have copies all the contents of the Pictures folder (after 'show package contents') onto an external hard drive into a folder I have labelled Pictures. Can I delete the Pictures 'package' on my Macbook and replace it with the folder from the external drive, or will the system know it's not the proper folder? Everything else seems fine and I don't really want to have to do an 'archive and install' if I can avoid it!
  • Weeble in disguise Level 1 Level 1 (0 points)
    I should have said I also set up a 'test' account, and it sees the pictures folder as a normal folder, so it doesn't seem to be a shared library issue I would have assumed?
  • Barney-15E Level 8 Level 8 (43,325 points)
    Someone else here did the same thing. They got it fixed by going to the Apple store Genius bar. I asked for info on how to fix it, but the poster never responded.

    Try opening Terminal and type the following
    ls
    This will list your home directory.
    It should show you the name of the Pictures folder as something like Pictures.pkg. Now, rename the folder using the move command
    mv Pictures.pkg Pictures
    If the current name is something different, then replace Pictures.pkg with the actual name. Move is the rename command in unix because every file name is actually the full path to the file. So, moving the file renames it.

    Message was edited by: Barney-15E
  • V.K. Level 9 Level 9 (56,110 points)
    run the following terminal command. it will turn the Pictures folder back into a regular folder

    xattr -d com.apple.FinderInfo ~/Pictures
  • Weeble in disguise Level 1 Level 1 (0 points)
    Brilliant!
    Many thanks V.K, this did the trick, and the Pictures package/folder has miraculously turned back into a proper folder. The previous suggestion may have worked as well but I tried V.K's solution first and all is back to normal.