Previous 1 2 Next 18 Replies Latest reply: Jan 31, 2011 8:44 PM by milifehn
Brittany Bychkowski Level 1 (0 points)
so my internet isn't working on my pro, it says my airport card isn't installed but i have had my mac for about 2 years now and have been using wireless internet the whole time. Its not my internet, because there is another macbook in my house and it is working fine.

What is the problem, and how do i fix it?

Mac OS X (10.5.6)
  • sig Level 8 (35,785 points)
    You may have a faulty card and/or a bad antenna connection. I would have the genius check it out.
  • Whiteguy1314 Level 1 (0 points)
    I am also getting the same problem, if you find a solution please post it here =)
  • bukharin Level 1 (10 points)
    I am so frustrated by this problem. I have been getting the "no airport card installed" message for weeks. I took my computer to an Apple dealer. Just then the computer displayed the card! I set up my computer at home and for several weeks had no problem. I now have the dreaded message again. I have uninstalled and reinstalled, zapper the PRAM, used all sorts of home remedies found on the web all to no avail. If I switch back to Tiger I have no problems but Tiger does not use the latest iTunes and Safari software (mainstays of my computing).

    I wonder if Apple scans these pages and whether they will help? Absolutely nobody seems to know what they are talking about on this problem. Please Apple!!
  • sig Level 8 (35,785 points)
    bukharin it might help if you provide information about which Mac you have, model, and OS running. This is a user to user forum and Apple is not here. We are users like yourself helping each other. That said, did the card work suddenly at the Apple dealer? Did they do any trouble shooting? What router do you have? Have you the latest router firmware?
  • jpwuiming Level 1 (0 points)
    hi, I am also a mac user having this same problem about my airport card constantly giving me this message that it is not installed, it has been about a day or so. I previously had this problem when i first installed my mac os, but was easily fixed by reseting my PRAM, but now, not even reseting my PRAM works, let alone reinstalling my OS and starting up in safe mode, or deleting/re adding in the airport extension files. Which ended up in a total failure. I have tried most of the solutions suggested by this forum and many others to no avail >< I am using a new bought 2.66ghz 15` macbook pro, with Mac OS (10.5.7), it has only been a few months old and this is the second time the problem has arise. The only thing that i can possibly explain the sudden change might have been dues to the recent force shutdown when my macbook froze during start-up? please assist me in my problem, many thanks =d
  • adamo2200 Level 1 (0 points)
    I'm having the exact same problem; every other or third time I turn on my macbook pro (late 2008 model) I get the "airport not installed" message. Usually it's back after a restart (in rare cases two restarts).

    The problem started after I put windows on the mac with bootcamp about a month ago. I've deleted windows again, but the problem remain.

    Any help would be greatly appriciated.
  • robb-w Level 1 (0 points)

    I have been experiencing this problem for a few months too. Most of the time it starts with not finding any network after waking up. After a reboot it says "no airport card installed". And after a few more reboots it is there again. I was hoping an upgrade to 10.6 would solve the problem, but no luck so far. The problem occurred again this morning, and after 5 reboots, still no airport card.

    The problem occurs mainly when it turn into standby with the screen open, and with the charger connected.. I was planning on replacing the airport card, but since the problem appear more or less at random and more people encounter this problem, I'm leaning more towards a software problem.

    Any suggestions?
  • robb-w Level 1 (0 points)
    Funny thing though:

    OSX keeps stating "No airport-card installed". But istat gives me a read-out of the temperature of the airport-card. Does anyone know if the heat sensor is integrated on the airport card or not?
  • HudsonJohns Level 1 (120 points)
    I guess if this were me I'd try an archive/install of OS X. You won't lose anything in the way of data, applications, etc., because the OS X install process will return them just as they were ... but ... OS X itself will be reinstalled and that may correct a corrupt, missing or incomplete file.

    Also - and I stress this to every Mac user - buy a cheap USB external hard drive that is equal in space to your MBP and carbon copy your existing system over to the external hard drive. Then, should anything go wrong, you can always plug your external hard drive in and copy back your system. Carbon Copy is free. The external hard drive is the only cost but well worth it.
  • drdrei Level 1 (0 points)
    I am also having this "No AirPort card installed" problem on a brand new macbook pro 13 running OS X 10.6.1. I was expecting great reliability from this new mac purchase and had high expectations of SL. Instead, my MBP froze on me more and more often in the last couple of weeks, and now there is this network card problem. I will truly appreciate it if someone who knows a way to resolve this issue shared it with us. I am hoping it is simply a software problem.
  • Pmicou Level 1 (0 points)
    I have read everything on this site and many others, and like so many of you I think it is time for Apple to act. Meanwhile, let me give my history of the 'no airport card installed' problem, as clearly as I can, with the boring spoiler that I have found no solution:

    Everything you have read here (from pram to adding network locations to everything others have tried) I have tried.

    Because I have perfect backups and time on my hands, I decided simply to perform the squeakiest-of-all-time clean installs with my Snow Leopard install disc. This clean install resulted in no recognized airport card at all (previously there had been the basic diamond-shaped icon in the menu bar, but without the grayed-out signal lines). Now there was nothing. In System Profiler, under 'airport', the Software for airport was there. But no Airport in 'Locations', where ethernet and firewire showed up. Likewise in Prefs => Network, there was no way to add an Airport interface.

    I restored my system from Time Machine, and there was the airport icon in the menu bar with no grayed-out signal lines, back where I started. In this case, under Network => Airport Card, my card was identified. The system really does appear to know the card is there, at some level, but outside of that I can't get it to show up in Sysprefs - Network.

    My intention was to make this as simple as possible (that's why I did the ultra-clean install), but I see that I'm just saying what everyone else has been. This seems to be a widespread problem and Apple must get on the case. I realize many of the above symptoms point to a hardware malfunction, but I just don't know if I buy that when so many people are having flukey returns of their connection.

    So I'm trying to keep this issue going, and I hope someone has been following up and found a general answer.
  • denar Level 1 (0 points)
    I am having the same problem the only way I get it back is puting my macbook os x install disc 1 and push D and test the computer and then it comes back---I am tired of it!
  • moulles Level 1 (5 points)
    I solved this rather annoying problem by re-running the 10.6.1 updater.

    In my case, the problem arose after I let my battery fully discharge, then powered it back up. Despite the "airport not installed" message, when I booted from the 10.6 install disc or my bootcamp partition, the aiport card was recognized just fine. Seems there is some bug in Snow Leopard that is corrupting a kernel extension or setting file somewhere, upon sleep.
  • Swedish Tenor Level 1 (0 points)
    Last night my two week old 13" MacBook Pro got the same problem. My Vuze application had frozen, so I force-quitted it. It wouldn't restart again, so I rebooted the computer. After reboot I get the "airport card not installed" error. Despite the error, the computer is connected to the internet through the supposedly none existent airport card. I zapped the P-RAM and I ran Apple Hardware Test, but to no avail. I have also restarted the computer several times, but still the problem persists. As I am still able to use the airport card, it's not a super big problem, but it still is quite frustrating.

    I was running 10.6.1 when this happened. I updated to 10.6.2 hoping it would help, but no.

    As so many other users on this forum have tried reinstallation of the entire system, but it hasn't helped, I feel reluctant to do so at this point.
Previous 1 2 Next