5 Replies Latest reply: Nov 5, 2009 10:58 PM by rsho
geastman Level 1 (0 points)
My AppleTV started acting up. I did a factory restore and now cannot get past the language selection screen. The up and down arrows do not move the menu from English and pressing the play button does not select English and move to the next screen.

I have gone through various remote troubleshooting steps. Each click flashes the light. Unpairing and pairing works. Menu/- and Menu/+ work to reset or select video mode. The remote works properly with Front Row on my iMac. I have tried another remote with the same result.

I have powered off and waited for varying amounts of time, including overnight. Same result.

Any suggestions before I head to a Apple service center? It is still under warranty but outside the 3 month free phone support period.

Apple TV, Other OS
  • Norm Gebhard Level 1 (15 points)
    I have the same problem. did you ever get the problem solved? Did you go to the genius bar? Send back to Apple?
  • Ed Schummer Level 1 (70 points)
    I wonder if this has to do with a recent update? I'm seeing the same - stuck on start-up, no way to get past the language selection screen...
  • aplardi Level 1 (0 points)
    I'm having the same issue. I just bought mine today. I restored the settings and I'm stuck at language screen. Tried all 3 of my apple remotes.
  • mndnm Level 1 (0 points)
    Ok, this worked for me: restart the Apple TV with your remote, and while it is restarting continue to hold the menu button on your remote.
    Then when you see the language menu appear you can let go and scroll up and down.
    Let's hope this works for everyone else as well!!
  • rsho Level 1 (0 points)
    Did you (or your previous owners) previously tried to "modify" the software? You may have problems If the restore partition has an older firmware image on a newer machine. You need to replace it with the same restore image as shipped before trying the restore.

    Good luck.