5 Replies Latest reply: Jul 9, 2009 12:56 PM by ryan.lancaster
ryan.lancaster Level 1 Level 1 (0 points)
I know there are many topics on the discussion pages about AirPort Extreme not working correctly, but I thought I'd just post a new topic and get straight answers to myself.

I have a MacBook 2.0Ghz 4GB Ram on OS X 10.5

Recently I have come to use my macbook again, as I have not used it for the last few months because of not needing it for work.
I have switched it on, and tried to connect to my home wireless network, and it tells me that it cannot connect and has designed an IP address for itself and I may not be able to connect to the internet. (Which I can't)

I can't do a software update because of no internet, so is there a way to fix?
Many thanks.

MacBook White / 2.0Ghz / 4GB, Mac OS X (10.5)
  • 1. Re: AirPort Extreme - Why isn't it working?
    Soft Reset Level 4 Level 4 (1,790 points)
    Hi ryan.lancaster,

    Welcome to Apple Discussions. Some questions regarding your configuration:

    1.) How is the AirPort Extreme configured? Is there a password on the router? What sort of encryption method?

    2.) The status LED on the front of the base station, is it solid green?

    3.) Any other devices in your location able to connect over WiFi to this device?

    4.) Have you tried power cycling all the hardware? If not, what if you try a factory restore of the base station (unless by restarting/resetting it affects network connectivity to critical devices)

    5.) What if you take an Ethernet cable and run it from the back of the base station to the MacBook, does that allow you to connect?
  • 2. Re: AirPort Extreme - Why isn't it working?
    ryan.lancaster Level 1 Level 1 (0 points)
    Thanks for your reply.

    The router does have a password on it and it is WEP encrypted. On the front of the unit, the LED lights are all green as well as the modem.
    I have 2 other windows laptops which are all working fine with it, and I also have my iPhone, which is also fine.

    Last night, I re-installed OS X Leopard 10.5, downloaded the 10.5.7 combo update on my Windows laptop off the Apple website, and copied it over to my MB and updated the software. This has slightly made the problem better and now Airport Extreme connects to the router and gives me internet connection, but then disconnects after about 5-10 minutes.

    I have connected the router and Mac with an ethernet cable, and now the internet works as it should, so could this be something wrong with my Airport Extreme card?
    Please let me know what configuration details you would like me to tell you and I'll post them up here.

    I'll now try factory restoring the router, and see if that solves the problem.
  • 3. Re: AirPort Extreme - Why isn't it working?
    Soft Reset Level 4 Level 4 (1,790 points)
    Hi ryan.lancaster,

    I'll be curious to have you try using the router either with WPA/2 Personal or no encryption. From my experience, WEP and Macs, even with AirPort hardware just don't play well together sometimes.

    Give the factory restore a go, the fact that the unit connects via Ethernet and other machines work with WiFi definitely indicates that we're not dealing with a bad Base Station. You indicated that you reinstalled the OS, did you do an Archive & Install or an Erase & Install?
  • 4. Re: AirPort Extreme - Why isn't it working?
    ryan.lancaster Level 1 Level 1 (0 points)
    Hi Soft Reset,

    I've just changed the encryption to WPA2 Personal and the same thing happens.
    Last night however, I got it connected via wireless and it was great, but when I restarted my MacBook, it kept showing "Connection Timeout". It's now still doing this and I have resorted back to Ethernet to write this.

    I'm now starting to think there's compatibility issues with my router and my MacBook, but I'm not sure, as they work with 99% of routers. (Or so people say)

    I'm curious whether I should buy a second hand belkin router off eBay or something just to see if that works any better as the router I currently have was a replacement to my earlier Netgear device which broke, and this one is much older.

    You ask what kind of restore I did, I didn't back anything up using Time Machine, as I have everything backed up to an external hard drive, so I'd answer that as Erase and Install.

    Thank you.
  • 5. Re: AirPort Extreme - Why isn't it working?
    ryan.lancaster Level 1 Level 1 (0 points)
    Have just purchased a second hand Netgear WGR614v9 router, and everything is now working on my MacBook.
    Thank's for all your help!