Skip navigation

Snow Leopard means no more Appletalk

191343 Views 194 Replies Latest reply: Jun 12, 2013 1:41 PM by Grant Bennet-Alder RSS
  • dbmacdon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 6:51 AM (in response to Proffles)
    I tried to install Netatalk following instructions at http://netatalk.darwinports.com/ and at http://www.macports.org/. It seems that you have to have Darwin Ports (MacPorts) installed first and to do that you also have to install Xcode tools and X11. So, I installed Xcode tools and X11 from the Snow Leopard install disc (about 2 GB). Then I installed MacPorts 1.8.0 for Snow Leopard. Then I started the Netatalk installation through the terminal. After a number of Unix executables got downloaded, compiled and installed, finally Netatalk got fetched, but then at the very last step through this laughable error:

    ---> Fetching netatalk
    ---> Attempting to fetch netatalk-2.0.3.tar.bz2 from http://heanet.dl.sourceforge.net/netatalk
    ---> Verifying checksum(s) for netatalk
    ---> Extracting netatalk
    ---> Applying patches to netatalk
    ---> Configuring netatalk
    Error: Target org.macports.configure returned: AppleTalk has been removed from Mac OS X 10.6+
    Error: Status 1 encountered during processing.

    So, Netatalk 2.0.3, which I tried to install to get AppleTalk won't configure or compile in Snow Leopard because AppleTalk has been removed from 10.6!! It was an interesting exercise, but a waste of a couple of hours and 2 GB of disk space...

    Anyone able to install it successfully, or have any other ideas?

    Regards
    iMac core duo 20", Mac OS X (10.5.4)
  • garbanzito Calculating status...
    Currently Being Moderated
    Sep 7, 2009 9:25 AM (in response to John Galt)
    i've been using older laser printers for years; they work so well that the effort to support them seems like a good sustainability practice; and AppleTalk saves quite a bit of time in configuring a printer, plus adds two-way communication (e.g., the dialog that pops up on the computer that tells you the printer is out of paper, or the automatic sensing of configuration options such as amount of memory installed)

    from my past experience setting up the same printers on Mac OS X via IP Printing, this two-way communication has not been supported; can anyone comment definitively on whether IP Printing in Snow Leopard somehow retains the good coupling AppleTalk provided? will netatalk, aside from enabling AppleTalk printing, also add back this two-way communication? does using the printer sharing with a 10.5 machine include this functionality?
    multiple, Other OS, 4 computers, two PPC two Intel, two 10.4, two 10.5
  • Cayenne6 Calculating status...
    Currently Being Moderated
    Sep 7, 2009 9:33 AM (in response to dbmacdon)
    Fascinating error message.

    I looked on the macports support site and they already have a ticket submitted on that error and it was "fixed" only about 17 hours ago. Apparently netatalk was crashing on install in 10.6 when it was looking for a file called "appletalk.h", so they changed macports to give that error, instead of finding out why it couldn't find appletalk.h. Now, everyone using 10.5 will get this error, instead of installing netatalk.

    I'm going to take your message above and post it as a new ticket to macports.org and see if they can resolve this issue.
    G4 AGP, Mac OS X (10.4.11)
  • jrolland Calculating status...
    Currently Being Moderated
    Sep 7, 2009 12:45 PM (in response to Cayenne6)
    OK, I tried installing NetATalk from source on Snow Leopard (depends on Berkeley DB - that's easy to install from source - thank you, Oracle!) instead of from MacPorts. I get the same "error: netat/appletalk.h: No such file or directory" error, so it's not just a MacPorts thing.

    If someone who is familiar with the NetATalk project could take a look at making it so it will work on Snow Leopard (either directly from source or via MacPorts), lots of AppleTalk printer users would be very obliged.
    MacBook White 2.4 GHz Intel Core Duo, Mac OS X (10.6), netatalk
  • Cayenne6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 5:13 PM (in response to jrolland)
    You're right, it's not a MacPorts thing. It's netatalk itself.

    I perused the mailing lists that the netatalk developers use and all their discussions are about fixing file sharing (AFP) which did break with Snow Leopard. Seems a LOT of people use netatalk for file servers and time machine on cheap linux boxes.

    In fact, when I dug around the FAQ for netatalk, the operating systems it supports are the Linux variants, but limited support in OS X, specifically, file sharing only. As in, netatalk does not support printing in OS X by design. My bad for creating false hope.

    So, even though I got netatalk to work on my Linux laptop, the netatalk developer team is not working on getting printing to work with OS X. Come to think of it, it's because they never had to before, appletalk printing wasn't an issue with OS X until 10.6.

    I would think that rather than trying to get Apple to add AppleTalk back to 10.6 (not going to happen), our efforts should be in convincing the netatalk developers to add printing (atalkd) to netatalk for OS X as jrolland suggests.
    G4 AGP, Mac OS X (10.4.11)
  • Cayenne6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 7, 2009 5:31 PM (in response to Cayenne6)
    I just added a request to the sourceforge.net netatalk feature page, asking for printing support. A developer there should respond to my request and when they do, I'll post here.
    G4 AGP, Mac OS X (10.4.11)
  • Instant_1 Calculating status...
    Currently Being Moderated
    Sep 7, 2009 5:40 PM (in response to OzarkMtn)
    OzarkMtn You are a lucky man (owner of a LaserWriter Select 360).

    I have successfully installed my LWS 360 in SnowLeopard. I run it as a network printer (wireless), but you can run it wired as well. What you need is a Print Server with a parallell port connector.

    There are a few steps:

    1. Put back the ""LaserWriter Select 360"" PPD file in: HD/Library/Printers/PPD Plugins/
    (The 10.6 installer removes it)

    2. Power up the Print Server and connect to it from your web browser. (192.168.0.1 or something like that). Here you can (manually) assign an IP which will be the IP for the printer. (192.168.0.10). Here are also some other choises for the printer. OK to start the printer.

    3. Open system pref.pane "Printers and Fax". Delete the old printer and create a new for the LWS 360. PRINT!

    A small oddity with password in 10.6. It seems like WEP 64bit HEX no longer is supported. I had to change to 128 ASCII to get it work.

    I hope this will help you.
    Mac Pro, Mac OS X (10.6), Mac Pro, Mac OS X (10.5) (10.6), LaserWriter Select 360
  • Grant Bennet-Alder Level 8 Level 8 (48,140 points)
    Currently Being Moderated
    Sep 7, 2009 5:52 PM (in response to Instant_1)
    instant_1:

    That sounds like a great solution!

    What kind of printserver is that? Hewlett-Packard maybe? what model?

    When you go to set up the printer, what kind does it say it is? {LPR, IP, Jetdirect, something else?}

    Does the LaserWriter Select 360 have a selector switch? Do you have to set it to something other than 0?
    Beige G3,G3 B+W,G4/867,G4/dual 1.25 MDD, Mac OS 8.6 or Earlier, and 9.2, 10.4 and Server - LW IIg, LW 4/600, ATalk ImageWriter LQ
  • Peter Payne Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 7, 2009 6:14 PM (in response to Instant_1)
    Can anyone verify that the Farallon iPrint adapter does indeed generate an IP? I know it must, intuitively, but there's no way to see what the IP is, no test sheet with my Applewriter 4/600, and I couldn't see the print server on the network. Why is there no convenient iApp for doing this stuff, finding IPs on a network and seeing which is what?
    Macbook Pro early 2008, Mac OS X (10.5.6), 6 GB RAM, 500 GB hard drive 7200 RPM
  • Grant Bennet-Alder Level 8 Level 8 (48,140 points)
    Currently Being Moderated
    Sep 7, 2009 8:13 PM (in response to Peter Payne)
    It does not generate an IP Address. Although it is on the same \[Ethernet] highway as TCP/IP packets, it does not use their protocol or their addressing. Some Wireless Routers throw those AppleTalk packets away as invalid.
    Beige G3,G3 B+W,G4/867,G4/dual 1.25 MDD, Mac OS 8.6 or Earlier, and 9.2, 10.4 and Server - LW IIg, LW 4/600, ATalk ImageWriter LQ
  • Peter Payne Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 7, 2009 10:14 PM (in response to Grant Bennet-Alder)
    Thanks for the info. I guess I'll leave one machine set up as 10.5 and share the printer through that, using up the toner as fast as possible (of course I have several unopened boxes of toner, wouldn't you know). Probably be done by the time 10.7 rolls around.
    Macbook Pro early 2008, Mac OS X (10.5.6), 6 GB RAM, 500 GB hard drive 7200 RPM
  • dbmacdon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 8, 2009 2:31 AM (in response to Cayenne6)
    I tried another possible AppleTalk software solution - Parallels. I happen to have Mac OS X 10.5 Server in a Parallels Virtual Machine (VM). It contains AppleTalk. So, I thought I might be able to "see" my AppleTalk-only printer (Apple Laserwriter 4/600 PS) through its usual Ethernet-AsanteTalk bridge connection. Unfortunately, I've tried all the Parallels Networking options available (shared, bridged, host-only) and none will allow the 10.5 VM to see or connect to the printer. Maybe I'm doing something wrong? Any other ideas?

    Regards
    iMac core duo 20", Mac OS X (10.5.4)
  • Cayenne6 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 8, 2009 10:58 AM (in response to Cayenne6)
    The netatalk development people have already responded to my request for printer support:

    "Wont fix. If you need lecacy protocols use a legacy OS."

    So, don't look to netatalk for a fix, either.

    Looks like I won't be going to 10.6 as the replacement cost for my laser printer and toner cartridges is too high.
    G4 AGP, Mac OS X (10.4.11)
  • edharson Level 1 Level 1 (100 points)
    Currently Being Moderated
    Sep 10, 2009 1:20 PM (in response to Richard Ripley)
    Well I have the same problem, and I don’t want to dump my perfectly working LaserWriter Select 360.

    I was using this printer on my network via a Farallon EtherMac iPrint Adapter. This allowed me to use Localtalk (AppleTalk).

    Since Snow Leopard does not support AppleTalk and my printer (which does an excellent job printing) has both serial and parallel ports, I purchased a USB to Parallel (Centronics CN36 Male / IEEE1284) cable and now can print using one of the USB ports on my Mac Pro. Hope this helps.
    Dual 1.8 GHz PowerPC G5, iBook G4 1.33 GHz, Mac OS X (10.4.3)
  • JDW1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2009 7:58 PM (in response to dbmacdon)
    Wouldn't a vintage Mac OS emulator such as SheepShaver or Mini vMac work since they allow you to run older version of the OS which fully support AppleTalk?

    I would think that such emulators would also restore the ability to write to HFS (not just HFS+ which is all 10.6 supports) and even MFS volumes.

    http://sheepshaver.cebix.net/
    http://minivmac.sourceforge.net/

    Sorry for not providing the testing myself, but I have not yet upgraded to 10.6.
    2009 iMac 24" 3.06GHz, Mac OS X (10.5.7), G4 Cube 1.3GHz (10.4.11)
1 2 3 4 5 6 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.