Previous 1 3 4 5 6 7 Next 194 Replies Latest reply: Jun 12, 2013 1:41 PM by Grant Bennet-Alder Go to original post
  • JerrytheK Level 1 Level 1 (10 points)
    Hi, just followed DavLab's directions, get the print screen, but I then get a 'busy, will try again in 10 sec' error message.

    Any thought?

    TiA
  • Frank Reed Level 1 Level 1 (0 points)
    I have found that a lot of folks are missing what Apple did in OSX 10.6. They got rid of AppleTalk, but did not get rid of the functionality of old LaserWriters. Using the LPD protocol, old printers still work just fine. The secret is being able to talk to the old LaserWriter and set its ethernet address to something that a router or switch will work with. The default address on my LaserWriter 16/600 PS was 0.0.0.0 which worked well under AppleTalk. Remember, AppleTalk did all the network interfacing automatically and hence the large number of lines of code. If I use 0.0.0.0 in the OSX 10.6 add printer routine, it would partially work, but I always get a "printer paused" message. So Apple effectively has made us do the network interfacing manually by dumping AppleTalk.

    It became clear to me that 0.0.0.0 was a real address, but my network would not fully recognize it. I have read in threads where they have had success in using it. My situation is most likely a specific hardware issue. So I decided to change the address to one similar to the ones being assigned by my router. The only way I could talk to my old trusty printer was to go back to the Apple Printer Utility-PPC under mac classic (OS 9.2.2). I have an iMac PPC running OSX10.4.11 on my network which prints to the LaserWriter. I set the LaserWriter address to 10.0.1.10. My router assigns the addresses and my new iMac running OSX 10.6 has the address 10.0.1.2. Once I put this new address in the OSX 10.6 'add printer routine and used LPD', the network now recognizes the LaserWriter and it is fully functional just like it used to be under AppleTalk.

    Hope this helps!
  • JerrytheK Level 1 Level 1 (10 points)
    Frank, thanks for the info. I'm working on getting my hands on OS 9 so I can get the Laser Writer IP address and reset it if necessary.

    What kind of router do you have?

    I'm running an Airport Extreme and was wondering if I needed any sort of specific IP address for the printer.
  • Grant Bennet-Alder Level 9 Level 9 (53,085 points)
    Frank Reed-

    You are quite right about YOUR printer, which has built-in LPR/LPD protocol. But for the owners of the 13 or so LaserWriter models that do NOT have LPR/LPD built in, they are seeing their perfectly good printers go obsolete.

    Peggy, queen of the AppleWorks forum, reports that she has solved this problem for herself by dedicating an old Mac Mini to being a Print Server. Once it was set up and wired into her home Router, she could disconnect the display and keyboard and just let it sit there, dedicated to its task.
  • illnoise Level 1 Level 1 (0 points)
    So no one's tried a Parallel-to-USB adaptor? I've found a couple comments online that it's worked, but can't find any specifics, and it seems like not all Parallel-to-USB adaptors work the same way.

    Aside from that, or a print server, I think I'm SOL with my Pro600 (no LPR/LPD). The only other option I've found is an old router a friend gave me with a parallel printer connection on it. It took me a couple days of digging around at work to find the right cable, but I found it today and I'm going to give it a try. We'll see, but I have low hopes. Even if the router has an IP address, I don't know if I'll be able to find it, or if the printer can use that address...

    Sorry if I sound daft here, I just don't want to brick this printer and I don't really know much about networking and such.

    Message was edited by: illnoise

    Message was edited by: illnoise
  • JerrytheK Level 1 Level 1 (10 points)
    Had the discussed problem of not being able to use a Laserwriter 16/600 PS after upgrading to Snow Leopard.

    My solution (based on the advice here) was to install 10.4 Tiger on a FireWire drive using an iMac G5 as the platform.

    Tiger's the last version of OS X that supports Classic (i.e., OS 9)

    I then further installed the "Power Mac G5 Additional Software & Hardware Test" software.

    I then booted off the FireWire Drive and fired up Classic.

    You then need to run the program "Apple Printer Utility", which does NOT install with the Additional Software above, but is downloadable from apple.com.

    I then ran the Apple Printer Utility, selected the Laserwriter, and that tells you what the IP address is.

    Using the Printer Utility, I tried to set the IP address to 10.0.1.10 as recommended in a previous post, but apparently that was in use and the Utility assigned 10.0.1.103.

    When I entered that IP address in the 10.6 Printer Setup Utility (again, as described above) all was good and the Laserwriter came back to life under 10.6

    BTW, going back to OS 9 was like trying to speak a language I learned long ago in high school. Doable, put not very fluent.
  • Frank Reed Level 1 Level 1 (0 points)
    Glad to see your are back online with the printer. I didn't mention it in the previous post that I too used Tiger on a G5 iMac. I keep that configuration to run all the old OS 9 programs. I guess if were still using an old LaserWriter printer, we should have a copy kicking around! Anyway, glad my post helped someone. This has gotten so much coverage that it is hard to get the info in the right spot.
  • hilofoz Level 1 Level 1 (65 points)
    The idea of using a shared Appletalk printer seems fine, and it works, but it means having an extra machine on all the time. I don’t think that is the best solution, even though it is a solution, and certainly better than nothing.

    Maybe someone like Belkin should manufacture a hardware dongle or Apple should make software emulator to do the same thing.
  • edharson Level 1 Level 1 (100 points)
    I was using my perfectly working LaserWriter Select 360 on my network via a Farallon EtherMac iPrint Adapter. This allowed me to use Localtalk (AppleTalk).

    Since Snow Leopard does not support AppleTalk and my printer has both serial and parallel ports, I purchased a USB to Parallel (Centronics CN36 Male / IEEE1284) cable and now can print using one of the USB ports on my Mac Pro. Hope this helps.

    Dual 1.8 GHz PowerPC G5, iBook G4 1.33 GHz Mac OS X (10.4.3)
  • OzarkMtn Level 1 Level 1 (75 points)
    I have the same printer setup as you. Would you mind telling me where you purchased the " USB to Parallel (Centronics CN36 Male / IEEE1284) cable"?

    Thanks,

    Scott
  • hilofoz Level 1 Level 1 (65 points)
    I suppose that now I have to ‘Think Different’!

    I remembered purchasing a parallel port USB printer adaptor cable, which I bought at Jaycar in Sydney, Australia for $50, to test my high-end Xerox printer (it ended up that the motherboard had to be replaced on it), so I found it in one of my cable boxes. I then hooked up my printer to my Snow Leopard Macbook Pro, and it works absolutely fine so far.

    I have also tried printer sharing using AppleTalk on my Mac Pro computer. This also works perfectly.

    The only thing I don’t get is when I look a the printer queue, it will say printer offline, which I don’t understand, as it still works, whatever. I have printed a TextEdit, Illustrator and Photoshop files, and all seems to be well with it. Also, I have used my old printer driver which has all the printer feature setups, so the drivers should not be a problem.

    The next thing I have to think about is the way that I will have to network these printers. I need to get another cable for my QMS laser printer. Note that all the high-end printers should have parallel ports. The printer software also has to be configured for the parallel port to be switched on. You would need to check your manuals for this. In the case of my QMS, I will need to look online for the manual as it was a free gift and put out on the street for someone to take! Recycling lives, OK.

    Do I put the networked printers into a USB hub and attach it to one computers, and printer share, or do I see if I can split the USB cables and insert them in each computer? For printer sharing, two computers have to be on, and that is the one with the USB parallel port. It has now become a wiring issue.
  • greenjewel Level 1 Level 1 (0 points)
    I"ve been following this and trying to solve this too, specifially the links above about using Apple Laserwriter Utility in Classic Mode to change the IP address of the Printer (I too had the 'paused printer' when I put the address to 0.0.0.0).

    I Installed 10.4 on a different drive, but my version of OS 9 (iMac) wasn't recognised as a startup disc so I tried the SheepShaver route. I found a pre-extracted ROM file but my OS 9 was not recognised by that either. So then I found my way to System 7.5.3, the one in 19 parts (one .smi and 18 .part), but I simply cannot get them to join up.

    Does anybody here know how it can be done in OS X, ie without Classic? I've tried umpteen different apps and am finally losing the will to live. All this for Appletalk.

    Why oh why oh why won't Apple make old systems available for download. Even if we had to use registrations/serial numbers - why not?

    Thanks,

    Debbie
  • JerrytheK Level 1 Level 1 (10 points)
    Do you have a machine that will run Classic?

    If so, I can copy disks and send them to you?
  • Grant Bennet-Alder Level 9 Level 9 (53,085 points)
    For LPR/LPD Printers, there is a primitive configuration system built into the printer that can respond to telnet commands. It sends you menu screens, with the choices numbered, and you select the right number to make your configuration choices.

    It should be written up in the back of the printer manual, but may be under "using the printer with UNIX systems".
Previous 1 3 4 5 6 7 Next