2 Replies Latest reply: Jul 8, 2009 9:09 AM by clebbyclaire
clebbyclaire Level 1 Level 1 (0 points)
I recently got a new 2nd gen ipod touch (it hasn't got the latest software). It recognizes wifi networks and will connect to them? (there is a a tick next to the network name). However when I try to use safari it says "not connected to the internet". I've tried in public wifi hotspots and at my friends house, unfortunately I dont have wireless internet at home.

ipod touch 2nd gen, Other OS
  • 1. Re: wifi doesn't work for iPod touch
    luvlabs Level 4 Level 4 (3,610 points)
    A number of free WiFi spots have a secondary login required. Open Safari, if the page doesn't come up, either tap the refresh or tap a bookmarked page. Follow the directions on the page and you should be fine.

    At your friends house, you may have encountered an encrypted network. You need to work with your friend on that one.

    Next time you try to connect, tap Settings > WiFi and if you have a network within range and it has a check mark, tap the blue > next to the name. You should see your IP address, subnet mask, router IP address, DNS addresses. If you see an IP address that starts with 169, then there are some additional things to consider.
  • 2. Re: wifi doesn't work for iPod touch
    clebbyclaire Level 1 Level 1 (0 points)
    Thanks for the reply.

    I tried refreshing the page or going to another one. Despite the wifi signal icon showing as strong, it still said it wasn't connected to the internet. I've used my laptop in the same wifi hotspot fine before. I'll have to check the ip address. What would I have to do if it does start with 169?