Skip navigation
This discussion is archived

How do I delete a sparsebundle if "bands" is always in use?

8362 Views 17 Replies Latest reply: Aug 22, 2009 10:43 AM by aviksaroy RSS
1 2 Previous Next
drv123 Calculating status...
Currently Being Moderated
Jul 9, 2009 6:45 PM
Every time I try to delete the freakin' file, it says it is in use.
various, Mac OS X (10.5.7)
  • Bob Timmons Level 9 Level 9 (75,470 points)
    One way to delete a xxxxx.sparsebundle file is to click it to highlight it, then go to the gear icon above and choose Move to Trash.

    Be careful as the file will be deleted instantly and you will not be able to retrieve it.
    MacBook Pro, iMac, Mac OS X (10.5.7), Time Capsule, AirPort Express, iPhone
  • Bob Timmons Level 9 Level 9 (75,470 points)
    Sounds like you have not disconnected the Time Capsule.

    Open your hard drive and look for the TC icon under SHARED. Click on the icon and look for the "Disconnect" tab at the upper right of the TC window.
    MacBook Pro, iMac, Mac OS X (10.5.7), Time Capsule, AirPort Express, iPhone
  • Bob Timmons Level 9 Level 9 (75,470 points)
    Meant to add that after you Disconnect, you will need to Reconnect again to display your delete options.

    If still having trouble, try pulling the power from the TC and restarting as your description indicates that something may be running in the background. So far, I can't duplicate your issue, but I'll keep poking around.
    MacBook Pro, iMac, Mac OS X (10.5.7), Time Capsule, AirPort Express, iPhone
  • Bob Timmons Level 9 Level 9 (75,470 points)
    Sorry, I cannot duplicate the "bands in use" message, so I don't know if the following suggestions will help or not. You may have already tried this, so apologies in advance if that is the case.

    Try resetting Time Machine as follows:

    Hard Drive > Library > Preferences. Delete the "com.Apple.TimeMachine.plist file"
    and restart your computer.

    Open System Preferences and click on Time Machine to set up Time Machine again, but for now only set up the computer that has the sparsebundle file you wish to delete. You can set up other computers later.

    See if the reset will allow you to access your Time Capsule and the sparsebundle file you want to delete. Once you locate the sparsebundle file to be deleted, click it to highlight it (but do not open the file). Then try the gear icon above to see if that will now allow you to delete the sparsebundle file.
    MacBook Pro, iMac, Mac OS X (10.5.7), Time Capsule, AirPort Express, iPhone
  • Bob Timmons Level 9 Level 9 (75,470 points)
    The sparsebundle format uses many small files, instead of one very large file, to more efficiently manage disk capacity. Each of these files, or "bands", is 8 MB in size; a large disk image will have thousands of bands. "Bands in use" implies that files are either being actively backed up at the time or the Time Capsule is rearranging things by deleting the oldest backups to make room for new backups.

    How to stop the process? I don't know. At this point, I think I would call Apple support for assistance. I suspect some files are corrupted and hope that the "fix" is not erasing the disk and reformatting.
    MacBook Pro, iMac, Mac OS X (10.5.7), Time Capsule, AirPort Express, iPhone
  • ahmed.atiya1 Level 1 Level 1 (45 points)
    A much simpler way of doing this is to get a program called "Trash It!" its freeware, and it has yet to fail me. Any time a program won't delete, simply drag it on the Trash It! program icon, you're prompted for your password, and it's as good as gone...
    MacBook Pro Unibody 2.66GHZ, Mac OS X (10.5.7), 6MB L2 Cache, 4GB DDR3 RAM, 512MB 9600M GT + 256MB 9400M
  • PeterNSteinmetz Calculating status...
    Having mostly the same problem. A sparse bundle on the time capsule that I need to delete to try and get time machine working.

    sudo -rf NAMEOFBUNDLE

    yields
    rm: NAMEOFBUNDLE//bands: invalid argument
    rm: NAMEOFBUNDLE/: Directory not empty

    I'm very puzzled by this. I removed the corresponding .ID file in the same directory as the bundle. The computer whose time machine backup this was now has TimeMachine off with no disk selected and is off.

    Is the command Apple is using any different?

    I cannot get that bands file to disappear, even after cd'ing into the sparse bundle directory itself.

    Any other suggestions on how to delete this thing?

    thanks,
    Peter
    iMac G5 isight, Mac OS X (10.5.8)
  • Gregory Lynn Level 1 Level 1 (135 points)
    First time it seemed like it worked, but then the Finder crashed and I had to relaunch it and the system. Same here, bands is always in use. Disconnecting users makes no difference. Restarting my Mac makes no difference. Restarting Time Capsule made no difference. So I copied what I cared about from the disk and just quick erased it and redid backs from all computers in the house. Was not worth spending more time on. The images should delete even if corrupted, perhaps a bug that can be fixed soon?
    Intel Core 2 Duo, Mac OS X (10.5.8)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.