11 Replies Latest reply: Nov 4, 2009 4:49 AM by sneather2
vhiggins Level 1 Level 1 (0 points)
my wireless router has a wep key which is the only code (as far as i know) for connecting to my network. however my macbook recognises the network but asks for a wpa password which i dont have and when i try to enter the wep key it wont connect. is there anyway to alter the settings so that my mac will accept my wep key?

macbook, Mac OS X (10.5)
  • JoeyR Level 6 Level 6 (8,275 points)
    By default, OS X detects the type of security being used by the network. If it says that it is WPA, either you are connecting to a different network or your network is actually using a WPA key. In general WEP is just a tiny step up from no security at all. The industry standard for strong wireless security has been WPA and more recently, WPA2. All of these settings can generally be accessed via a web interface to your router. Your user manual should have simple instructions. If it came with PC only software... you shouldn't need to use it. If you don't have your manual or you're not sure what to do... if you could let us know the make and model of your router, we might be able to help.
  • vhiggins Level 1 Level 1 (0 points)
    my router is inventel, model: DV4210-WU
    the encryption key on the router is a code of 26 letters and numbers, i have found from my network manager that this key is wpa. thanks for your help!
  • JoeyR Level 6 Level 6 (8,275 points)
    Great... a 26 character alpha-numeric WPA key should be very secure.
  • vhiggins Level 1 Level 1 (0 points)
    my mac still wont accept it though...??? if my laptop recognises that the network is available, does that mean the problem is with the mac? i can get onto the network on my pc using the wpa encryption key
  • JoeyR Level 6 Level 6 (8,275 points)
    OK... so you have entered the key on your PC and it is working correct? On your Mac... when you click on the wireless icon on the top right in your menu bar, do you see your network in the list? Does it show that is connected? Just showing up in the list means that it is available, but not necessarily connected. If it is not connected, you should be able to select your network from the drop-down list and it should ask for the key. Have you gone through those steps and your key just isn't working? That's a pretty long key so just be sure it is typed correctly. Also, keys are case sensitive so you need to be sure to use capital and lower case letters the same as they appear in the key. Also, be sure that "0" (zero) and "O" (oh) are not mixed up.
  • vhiggins Level 1 Level 1 (0 points)
    yes, the key works for my PC which is currently connected to the network. on my mac i click on the wireless icon and the network that my computer is connected to is shown on a list of 3 networks. i dont think it shows that it is connected? how would i know? after i select it from the drop down list a box comes up with 'the network "WANADOO-B957" requires a WPA password' and there is a box for me to enter a password. i have tried both lower and upper case. both '0' and 'O'. i've tried it several times and have copied it numerous times directly from my computer to ensure it is the correct key. any ideas?
  • vhiggins Level 1 Level 1 (0 points)
    also, it doesnt say that the password is wrong. it says 'connection failed' but this message appears even when i put in a different password. i have tried being closer to the router but this doesnt help either
  • ecu9697 Level 1 Level 1 (0 points)
    I am having the same problem. Even the iPhone that syncs with my Macbook is having connectivity problems while my husband's and his HP are connecting just fine.
  • deemkaa Level 1 Level 1 (0 points)
    have you solved this issue ?
  • Paea Level 1 Level 1 (10 points)
    Try to Option+click on the wireless icon thingy in the system tray. Choose the other type of encryption (Hex probably). Windows and Mac default to different types of encryption, basically. So you have to "line them up" manually.
  • sneather2 Level 1 Level 1 (0 points)
    Just in case you have not figured this out... put a $ sign in front of the encryption code on your mac.