Previous 1 2 Next 15 Replies Latest reply: Jul 15, 2009 4:03 PM by ~Bee
Ted Stampfer Level 1 Level 1 (0 points)
I have been using Safari 3.2.3 on a G4 Powerbook running OS 10.4.11. For no apparent reason I can no longer open many links, which appear in web pages, by clicking them. These seem to be primarily those that offer free application downloads, Nor will they open if I copy and paste them in the Address Field. In both cases the status bar starts to move across the address but then shoots to the end and finally retreats to the beginning. I have found no way to open any of these links, which means I could not download Safari 3.2.3 to reload it. I also could not download Firefox. I did download Safari 3.2.3, using Netscape that was already in my applications folder, but reloading it did not solve the problem. Running the original Software and Restore disc that came with the computer didn’t help either.

I would very much appreciate any help in getting back the full functionality of Safari.

Thank you

Ted Stampfer

1.5 GHz G4 Powerbook, Mac OS X (10.4.11)
  • sitspotsit Level 3 Level 3 (785 points)
    You don't need to start reinstalling software; there's nothing wrong with Safari.

    Did you Repair Disk Permissions before and after installing? If not, do that now with Disk Utility.
    Did you try removing the Safari preferences file and restarting Safari?
    Did you try "resetting" Safari, or deleting any other Safari-related files?

    What have you done, aside from trying to reinstall something that you don't have to?
  • Ted Stampfer Level 1 Level 1 (0 points)
    Thank you for replying to my help request. I had already verified Disk Permissions, reset Safari, and trashed anything that looked as if might be the culprit. I did not remove the Safari preferences file and still cannot find it. Not sure where to look but in the preferences folder in Library, and it is not there. Where can I find it?

    Thanks again for your suggestions and I apologize for taking so long to answer.

    Ted
  • sitspotsit Level 3 Level 3 (785 points)
    The preferences file for Safari is indeed in the Preferences folder, named com.apple.Safari.plist. You need to remove that and then restart Safari and setup your preferences again.

    If you can't find it visually, do a Spotlight search to find that file.
  • Ted Stampfer Level 1 Level 1 (0 points)
    The Safari preference file was where you indicated. I had not checked the com.apple.. listings. I threw it out and restarted, checked that the Disk Permissions were still good and reset Safari. Unfortunately, the problem persists. Many links, particularly to free software, are not completed. Maybe I just shouldn’t be so cheap.

    Any other ideas or do I simply download with Netscape those items that Safari doesn’t handle.

    Thanks again

    Ted
  • sitspotsit Level 3 Level 3 (785 points)
    Try changing your DNS settings:

    Open System Preferences>Network and put these two DNS servers in so they are first in the list (assuming you can't delete what is already in there):

    208.67.222.222
    208.67.220.220

    click Apply Now and quit System Preferences. Restart Safari and see if that solves the problem.
  • Ted Stampfer Level 1 Level 1 (0 points)
    I dropped the two DNS server addresses in the TCP/IP “DNS Servers” box in Network. There were no addresses there originally. After restart there is no change. My test is to try and download Firefox, Safari, Macaroni free 35 day trial, and Housecall. None of them downloaded.

    Although it was wasted effort I ran both Applejack and Disk Warrior before sending the original inquiry.

    Ted
  • sitspotsit Level 3 Level 3 (785 points)
    Go to ~/Library/Caches/com.apple.Safari and delete the contents of that folder, then use the Get Info panel to Lock the folder.

    Go to ~/Library/Caches/Metadata/Safari and delete the contents of that folder, then use the Get Info panel to Lock the folder.

    Go to ~/Library/Safari and delete these files (don't empty the Trash yet):

    Cookies.plist
    Downloads.plist
    History.plist
    LastSession.plist
    WebpageIcons.db

    Restart Safari and see if your problem is solved. If so, then you can empty the Trash.
  • Ted Stampfer Level 1 Level 1 (0 points)
    I deleted all the mentioned files, restarted, and still had the same problem. To make sure everything was deleted I looked in each of the folders and found that history.plist, lastsession.plist, and webpageicons.db were back in library/safari. I deleted them again, restarted safari, and they were back; I still can’t download many files.

    Would reinstalling OS, 10.4.11 solve the problem? I hate the thought of doing it, particularly a clean install. I think I remember way back in OS 9, or maybe 8 or earlier, there was another, not quite so severe, option. Was that what is now called “archive and install”? Are all the bugs worked out Leopard?
  • sitspotsit Level 3 Level 3 (785 points)
    Would reinstalling OS, 10.4.11 solve the problem?


    No. There's nothing wrong with Safari 4, so don't waste your time with that. Instead, create a new user account and test Safari 4 there to see if the same problem happens.
  • Klaus1 Level 8 Level 8 (46,765 points)
    Just a thought: To use Safari 4.0.2 on Tiger requires the install of Security update 2009-001 and 002. Have you done that?

    The Archive and Install method is still ongoing and very useful as it preserves all your own settings etc.

    How to Archive & Install:

    http://docs.info.apple.com/article.html?artnum=107120

    But before embarking on that try all the previous suggestions first.

    Running the 10.4.11 COMBO updater again would not hurt.
  • ~Bee Level 7 Level 7 (31,160 points)
    Hi Ted --
    Welcome to Apple Discussions!

    Did you by any change load on any "Internet Enhancers" recently?
    Anything that's supposed to make surfing speedier, better . . .
    or that's supposed to help downloading??? There's one called
    SpeedDownload, that if you decide not to buy it, and don't uninstall
    it correctly, it restricts or stops any downloads. Just a thought. . .
  • Ted Stampfer Level 1 Level 1 (0 points)
    I want to thank sitspotsit, Klaus 1, and ~Bee for all your help, particularly sitspotsit who hung in there forever. Before I had a chance to see what would happen with Safari 4, ~Bee mentioned “Internet Enhancers:, specifically SpeedDownload. I had downloaded this a few weeks ago but it did not do what I had hoped, and I thought I had gotten rid of it. I searched on “speeddo” and found all sorts of files and folders. Trashed all of these, rebooted, and I now seem to be able to download anything, maybe even some I shouldn’t.

    Thank you all for your help

    Ted
  • ~Bee Level 7 Level 7 (31,160 points)
    Hi Ted --
    It sounded like SD.
    You also might want to hunt for files with the name
    Yazoft, the maker.

    Usually, when people decide not to use it, they try to trash it.
    Yazoft includes an Uninstaller with their package. People should
    use their uninstaller to be sure to get rid of all the files.
    But it sounds like you've done pretty well. (Yazoft will send another
    uninstaller if you contact them via email. Or reinstall and then uninstall

    All the best.

    Message was edited by: ~Bee
  • keats2010 Level 2 Level 2 (285 points)
    Hi Ted & Bee, great to see the problem sorted out, and just adding that for anyone following this thread, IMHO i believe SpeedDownload to be a great and stable program, when paid for and registered and find it actually more reliable than Safari's Download, especially in reliably restarting downloads. I know nobody has knocked it and can definitley understand the conflicts it can cause as a trial and not uninstalled properly, but a very good program when paid for version installed.
    LOL sound like a salesman for it instead of a customer!!
Previous 1 2 Next