8 Replies Latest reply: Oct 7, 2009 7:35 PM by tman1000
jrez007 Level 1 Level 1 (0 points)
I have a new 3GS iPhone and can connect to my wireless network at home, but get no internet on Safari on the iPhone. My Linksys wireless router shows the iPhone's ip address, all the settings on the iPhone seem correct. All other wireless devices can connect and use the internet. I have tried everything, resetting the router, forgetting the network on the iPhone and then re-setting it. Does anyone have an ideas? Again, I "get" the wireless icon on my homescreen, the home network is found and "checked" on the iPhone, but no connectivity to websites. Please help!>!>!>!>

Windows Vista
  • DaVBMan Level 6 Level 6 (9,265 points)
    Have you tried updating the firmware to your router?
  • jrez007 Level 1 Level 1 (0 points)
    I thought that only your service provider can do that. Am I wrong?
  • RocketJSquirrel Level 1 Level 1 (30 points)
    If you have network connectivity but can't resolve web addresses, maybe your DNS server is not set properly in the iPhone.

    If you are using DNS forwarding on your router, you can use the router's LAN address as the DNS server. Otherwise, you'll have to enter your ISP-provided DNS server address.
  • jrez007 Level 1 Level 1 (0 points)
    DNS is not the problem. I put in an actual ip address and still can not connect to the internet. A summary of what I've done

    1. Reset (hard and soft)both router and iPhone.
    2. Changed setting to static on iPhone and still doesn't work.
    3. Used only one DNS from router and still doesn't work.
    4. Disabled security for wifi and still doesn't work.
    5. Changed "channel" wifi is operating on and still doesn't work

    The iPhone "sees" the network fine. It connects to the network with no trouble. I can even ping the iPhone from my computer and I get a response. All other devices (blueberry, laptop, etc.) connect to wifi and Internet with no problems. Does anyone have any further ideas? I'm using a linksys cable modem router wcg200
  • J-F Level 1 Level 1 (115 points)
    Exact same problem here on a Linksys WRT150N. iPhone 3GS is connected to router, has an IP adress from the network but cannot connect to internet. If I connect to an Apple extreme router everything works fine.
  • RocketJSquirrel Level 1 Level 1 (30 points)
    Hmm, starting to sound like a Linksys issue. I peeked over here on the Linksys forum:

    http://forums.linksysbycisco.com/linksys/board/message?board.id=Wireless_Routers &message.id=105636&query.id=14016#M105636

    and found a guy who said (emphasis mine)

    <quote>
    I have a similar problem in that *I set up my Linksys WRT54G router with a static IP address*, which has two DNS addresses. I'm also using WPA2-AES. *If I switch my router back over to DHCP, my Iphone 3G and my original Iphone can both connect to the router and access the Internet. But, as soon as I switch the router back over to my static IP address, both Iphones can connect to the router, but neither can access the Internet.* I've given Linksys many opportunities to solve this problem; especially since I'm not the only one having this problem. But, I've finally thrown in the towel an moved on by purchasing a NETGEAR - RangeMax Next Wireless-N Router for $89.00. I plugged it in, popped in the CD, followed the setup instructions, and I was up and running in 10 minutes. And yes, both of my Iphones work just fine.
    </quote>

    Hope this helps.
  • f4zer Level 1 Level 1 (0 points)
    the same problem with my updated iphone 3g 3.1, there are 2 routers(netgear) in my place. all devices connected to them have static ips pared with mac adresses.. my macbook works properly but iphone is just connected but there is no internet.... 2 weeks ago the same routers where working but with dhcp, iphone was ok...
    tried everything.... after changing dhcp to static, i just cant use the wifi on my iphone(both 3.0 and 3.1)..
    PLZ HELP
  • tman1000 Level 1 Level 1 (0 points)
    I have the same problem as you guys have described with Linksys routers, but I have an airport Extreme. Everything was fine until I switched to bridge mode on my Westell modem...static ip on the extreme, browsing and all network functions are perfect on my Imac and MacBook Pro, but my IPhone shows that it connects to my network, but cannot browse or receive email when on it. Even after restarts of the phone I get the same result. I even brought my dad's 3GS into the house, and he had the same problem. We both connect to the network, but nothing happens. If I power cycle the router, it will connect and also browse and receive mail! But I have to power cycle the router EVERY time I connect to the network or it won't work.

    Feels like a bug...there is not a hardware issue with the phone because I connect to other wifi hotspots no problem and they work fine.

    Anyone have any ideas?