Previous 1 2 3 Next 43 Replies Latest reply: Sep 10, 2009 10:18 AM by Scott Player Go to original post
  • iBlackLotus Level 1 Level 1

    Ok the problem is PURE hardware origin,
    moreover NOT some kind of BIOS or Power Management Unit mess,
    it's just a small trigger inside Headphones Jack.

    LOOK on this image i created of a mac book pro side
    (whatever the other jacks on other macs are the same):

    Click to enlarge (from ImageShack, don't worry it's safe):

    1) Headphones Analogical OUTPUT trigger.
    2) LED for Digital (Optical) OUTPUT.
    3) Digital output trigger sphere.
    4) just a paperclip.

    The problem origin is from the headphone_set pin itself.

    The system has 3 states of Sound output:
    -internal speaker,
    -analogical headphones output,
    -and in the end Digital output

    when you listening to internal audio speakers BOTH triggers (1 and 3 on image) are pulled out (toward the center axis of headphone jack hole).

    now you plug your headphones inside: first the trigger (1) nearly at 1/3 of depth is plugged down and the system goes to state 2- analogical headphones.
    as you push headphones pin deeper inside hole it reaches the second trigger (3) at 3/4 of depth (and on left side) of digital output.

    This makes the system go to stage 3-Digital Output (if the jack you plugged is Optical receiver), if not, it still Starts up the LED (2), but the output remains on stage 2-analogical.

    the problem of that MOST of yours internal speakers don't work anymore

    *IS THE TRIGGER (3)*

    it's seems like a small sphere pushed out with force of a small sling, which weakening process is up since you plugging and unplugging the headphone jack.

    so the problem is:
    When you pull OUT the headphone set pin, the Trigger (1) disables going natural position (Unlocking the first lock to Internal speakers functionality)
    BUT the trigger (3) seems to be still pulled inside and stuck there (maybe cuz of sling), and preventing the Second Lock of internal speakers to open.

    +*That's why if you go on Sound Setting Panel you still see the Digital Output and the "RED LIGHT" from the headphones jack. And most important, System internal speakers MUTED.*+


    I used a paperclip (like (4) ) and tickled the trigger (3) so to make it come out again (unlocking the second lock on internal speaker) and System sound is Back again.

    *Solution is Rough !!!* REMEMBER this WON'T make the trigger (3) internal sling that pulls out the small sphere stronger back as it was brand new.

    just be cool, life is short smile more.


    Message was edited by: iBlackLotus
  • BlueX Level 1 Level 1
    Very informative post, but seeing as this only happens on Windows and not Mac OS X, I think it might be a drivers issue or software related

    I tried using a toothpick but it didn't work, also tried inserting and removing headphones from the jack about 30 times and still nothing
  • iBlackLotus Level 1 Level 1
    I had this stuff under windows also, and by the way the moment i fixed it i WAS actually on my boot camp windows partition.

    The problem was on OSX also.

    Does the red light LED goes on/off when you tickle with trigger (3) ? if so IT'S for sure the problem i described. If not (always ON) it means one of the next possibilities:

    1) the trigger (3) is truly depth sank and doesnt seem in intention to come out (the stuck is serious)

    2) there's really a Driver mess that can possibly be resolved in some way, but i cant help you here.

    Ceer up mate, there's still mac partition to make you happy, that's all the mac user soulbounded have hands layed on.
  • BlueX Level 1 Level 1
    Manually installed the drivers for 64 bit windows but the Apple keybpard functions F1-F12 don't work, Sound is finally able to come out of the speakers but it's still as low as XP, and the red light is still there
  • francoisvlogg Level 1 Level 1
    I intalled the sound drivers again - the Realtek r2.28 as advised here, and no difference at all.
  • Sascha H-K Level 2 Level 2
    what macbook pro do you have exactly ?

    did you install r2.28 twice ?
  • BlueX Level 1 Level 1
    Should I take this into an Apple Store or will they tell me Windows doesn't count?

    Because I've also been getting those clicks and beeps issues on Mac
  • BlueX Level 1 Level 1
    Okay something weird happened.

    Restarted and the red light was gone!

    But it didn't last for long as it flicks on and off whenever I test the speakers which are still incredibly low volume

    Installed r2.28 but it didn't seem like it did much

    Function keys still do not work

    Not sure what else to do now
  • BlueX Level 1 Level 1
    Fix found:

    Thanks to cmosquera for this fix.

    This will fix the volume on the computer. If you also did the audio enhancement described above undo it.

    1. Create a folder on the root of your c:\ drive, call it "CirrusDriverFix".

    2. Install 7-Zip in your Vista or W7.

    3. Put the Mac OSX Install DVD that came bundled with your Mid 2009 MBP in your DVD drive then right click on the BootCamp\Drivers\Cirrus\CirrusAudioVistaxx.exe (xx=32 for 32 bit and 64 for 64-bit) file and choose "7-Zip > Extract Files..." Enter c:\CirrusDriverFix to extract the files.

    4. Once the files have been extracted go to the c:\CirrusDriverFix folder and delete the original cs420x.inf file and replace it with the one attached to make sure the you rename it to cs420x.inf

    5. Go into your device manager, right click on the Cirrus Logic under "Sound, video and game controllers" then choose Uninstall and make sure to check the box "Delete the driver software for this device."

    6. Click on Start > type "cmd" then right click on the cmd.exe that shows up and click "Run as administrator".

    7. type in CD "\CirrusDriverFix"

    8. type in dpinst /F and then go through the install, it should "force" the install.

    9. Enjoy your sound.

    10. Thank ChristianZ and everyone else except Apple, Cirrus Logic, and Soft Reset

    Still getting the red light and broken function keys but whatever because we got working sound
  • BlueX Level 1 Level 1

    Fixed every issue I've had so far EXCEPT the red light but that really doesn't bother me because I have working sound, drivers, and boot camp files installed and working on a Windows 64-bit Boot Camp partition on my MacBook Pro!

    In case anyone is wondering how to install Boot Camp on x64, you need to replace the BootCamp.msi files with the ones in this post:

    It's located in Boot Camp/Drivers/Apple

    Once you run that, everything should be working

    Only problem that still exists now is the red light issue but that doesn't seem to be too big an issue right now
  • videoterry Level 1 Level 1

    Took a little futzing before I was able to jiggle the sensor3 button into submission, but that paperclip ltimately did the trick. We'll see how long it stays fixed- I figure it will likely go goofy again before long since I use phones/external speakers a lot and am repeatedly sticking a plug in there.
    The jack is probably pretty worn.

  • tool Level 2 Level 2
    Just to clear the record....everybody on here seems to be having issues with this red light thing and everybody is claiming that it's only BootCamp/Windows that is causing the issue, and that it is NOT a Mac OS X issue...

    I beg to differ...I received my brand new 17" MacBook Pro Unibody (Mid 2009) a couple weeks ago, and i DO NOT use Windows, i have no reason to want to use Windows, or BootCamp, etc...

    However, this happened to me one time when i plugged in the headphones and when i unplugged it the light came on. When i plugged them back in again, it was still on...but doing it a few times made it go away.

    I only noticed this to happen on one occasion, and it is clearly NOT JUST a Windows/Boot Camp issue.
  • ajw522 Level 1 Level 1
    I was at the Apple Genius Bar today and asked the same question - this is normal operating conditions when using Windows. I do not know why it does this only in Windows and not in Mac, but from what the Apple Genius' tell me, this is completely normal, so don't worry.

    Now as to the low volume issue, I can't help you with that. I suggest that you make an appointment with an Apple Genius at an Apple Store near you by logging on to as I believe they will be able to help you, since they offer free technical support - just bring your laptop and show them.

    Summary: Red light is normal operation, yet I do not know what the volume issue is about. I have the same problem - will have to work on it.
  • Scott Player Level 1 Level 1
    Under no circumstances should you stick "anything" except the appropriate connector into ANY port. If it is a bug (and it only happens in Vista you will note, so I think it must be), then be patient, and more than likely either Apple or Microsoft will do the right thing and fix it. The chance that you will damage your computer is simply not worth dodgy work arounds, and voiding your warranty. Don't do it!
Previous 1 2 3 Next