8 Replies Latest reply: Sep 24, 2009 3:30 AM by Tom Gewecke
coboyle Level 1 Level 1 (0 points)
Hello I would really like some help with this. Basically 2 nights ago I changed my permissions to require login on wake up. It has been working fine the past 2 days. Today I wake up And go to wake up my macbookpro and it is taking really long. The screen and keyboard brightness buttons aren't working and the volume buttons aren't either. Finally my brightness increases by 1 so I can at least see the screen. I try to login but it won't let me. It shakes which I think means my password is wrong. My password hasn't changed. I know my password.

Anyway. I call a friend and he walks me through bootin into cmnd +s and I do an admin account reset. Everythin is typing fine.in English letters. It then reboots and I go through the leopard welcome screen and registration screens but don't feel like inputting my info so I skip them. I set my region to USA and my lanuage to English. When it is time to enter my admin acct name and shirt name and everything it starts typing in weird symbols like @£# and the trademark and registered symbols. I am guessing this is why it said my password was wrong because I was typng in weird symbols and just didn't know it. It was typing almost like if I was dong alt codes or something.

Does anyone else have a solution for this? I bought my comp at best buy with their warranty so I have to bring it to get checked out if I can't solve it here because it is over a year old for apple care.

Any help is appreciated. Let me know if you need more info. My computer is currently switched off and I am typing this with my iPhone.

Cheers
chris.

Can anyone help with this situation

15" MacBook Pro, Mac OS X (10.5.7), 2.5 ghz old aluminum model
  • coboyle Level 1 Level 1 (0 points)
    Also, I would like to add: I currently have iAnti Virus installed and up to date so I would hope that rules out getting a virus while the computer was asleep.

    Here is a photo of my problem.
    http://img329.imageshack.us/img329/8109/photoj.jpg

    Apple support couldn't help me. Since it is out of warranty.
  • Tom Gewecke Level 9 Level 9 (75,370 points)
    Also, I would like to add: I currently have iAnti Virus installed and up to date so I would hope that rules out getting a virus while the computer was asleep.


    Since there aren't any viruses, that kind of stuff is more likely to cause you problems than to solve any.

    Here is a photo of my problem.
    http://img329.imageshack.us/img329/8109/photoj.jpg


    It looks like it is behaving as if your Option/Alt key is stuck down. Do you have another keyboard you could try to use?
  • coboyle Level 1 Level 1 (0 points)
    Alright I have managed to get past the login screen, I was really lucky, I tried rebooting the comp back and forth and finally it let me type in English letters.

    I created a new admin account, and still see my old one, but the **** symbols are back again and I can't type anything without it being an ALT symbol. I plugged in an extra keyboard and had it identified. I set it to English and it is still typing the symbols even with an external Keyboard.

    Is there a setting somewhere that got switched on? Because honest to god, it was working fine when I put the computer to sleep. All of my applications are typing in the symbols. I can't login anywhere because it's typing the symbols.

    Please help. I have the leopard restore disks, but they didnt do anything because I already reregistered my account. The only thing I can think of is to completely wipe my hard drive and do a fresh install, but please don't make me do that.
  • coboyle Level 1 Level 1 (0 points)
    Noone can figure this out huh? The apple guys and the best buy guys cant either..

    Cool, what do I do now?
  • TekserveNYC Level 1 Level 1 (40 points)
    Hey. Alright, I think the best thing for you to do is an Archive & Install. Mind you, this shouldn't wipe out any of your documents or settings, but you may have to reinstall some programs and drivers. Photoshop in particular will need to be reinstalled, if you use it. The page http://www.tekserve.com/service/mac-faq/upgrade-reinstall/mac-os-x-upgrade-reins tall.php gives step-by-step instructions for reinstalling the operating system. Be sure to take a look at step 8b, as it describes what an Archive & Install will do to your system. If it's at all possible, I recommend backing up your data to an external drive or blank DVDs first.

    If you don't want to do a reinstall just yet, you can try repairing permissions (http://www.tekserve.com/service/mac-faq/annoyances/repair-disk-permissions.php) and repairing your disk (http://www.tekserve.com/service/mac-faq/annoyances/repair-disk.php) first. Unfortunately I don't really think either of those options will fix this problem.

    Best of luck!
    --------
    Jeremy A.
    Tekserve Intern

    As an intern at Tekserve, I may receive financial compensation for my recommendations and links.
  • nerowolfe Level 6 Level 6 (13,070 points)
    coboyle wrote:
    Also, I would like to add: I currently have iAnti Virus installed and up to date so I would hope that rules out getting a virus while the computer was asleep.


    Since there are no viruses for Macs, you can't catch one awake or asleep or any other way.
    Most Leopard A/V software creates more problems than it does not solve.
  • kirraaax3 Level 1 Level 1 (0 points)
    This same thing happened to me! Since this is an old topic you may have already figured out a solution, but what I did was go to my System Preferences, clicked International, then clicked Input Menu. There was a whole big list of different languages, and I learned that for some reason or another my language kept changing to Greek Polytonic. All I did was un-check that language and any other language that was checked besides US and everything switched back to English.
  • Tom Gewecke Level 9 Level 9 (75,370 points)
    The picture provided by the poster indicates he is stuck in the Option/alt level of the US layout rather than in some other layout.