3 Replies Latest reply: Jul 20, 2009 6:15 AM by V.K.
Radada Level 1 (10 points)
Hi there,

I've got an external HD (Western Digital) that used to work fine with 2 partitions : Time Machine and Dl Temp.
For some reasons, I can't see the Time Machine drive anymore. The DL temp is mounted onto the desktop, but Time Machine is not. If I open the Disk Utility, I sometimes see the other partition as an unmounted partition and sometimes, I don't even see it in the Disk Utility.

The thing is : impossible to do anything with that : it seems that the system know that te-here is another partition, tries to mount it, but while it does not succed in the operation, the process get idle and block all other things.
For instance, it blocks the computer Shutdown (when I manually unplug the HD, the computer shut down fine...)
I tried to format/erase/repartition it, but I never succed since the system can't unmount the DL temp.
It tried to log as root : same ****.
I tried to force unmount it with the terminal (umount -f /Volumes/"DL Temp"), but the process freezes, and it never unmount it.
I can't even try to format it under a windows OS, since both partitions are "Mac OS journalisé" (i don't know the translation for that one ^^. Maybe "logged"?).
Do you have any idea how to force unmount the HD so that I can't format it?


iMac 24' 2,16GHz CodeDuo2 GeForce 7300 GT 2Gh DDR, Mac OS X (10.5.6)
  • V.K. Level 9 (56,110 points)
    forcing an unmount is probably not what you should be looking for here. try reformatting the drive while booted from the leopard install DVD.
  • Radada Level 1 (10 points)
    Yep, one of the numerous things I've already done. Thanks for the hint though
    It says "ressource busy", no matter how long you leave the HD. I can only see the root element, but none of the 2 partitions here...
    As I said, it's like the system knew that there were 2 partitions, it tries to get info from them, and gets stuck for some reasons.
    That's why I wanted to force an unmount command, so that I can try it from my session...
    Any other idea (than force unmount) are welcome too btw : )
  • V.K. Level 9 (56,110 points)
    the command you tried is the correct command to force a disk unmount. it didn't work because something is wrong with the drive and I'm not sure if anything esle will help. you can try this one

    diskutil unmount force /volumes/"disk name"

    you might also try unmounting by device number instead of the volume name.

    first run


    to see the device numbers for all your volumes. a device number will look something like this disk2s2. then run

    diskutil unmount force devicenumber

    But I really don't know if this will work any better than what you tried.