Previous 1 2 3 4 5 6 7 Next 99 Replies Latest reply: Jan 24, 2015 1:51 PM by ericnoel Go to original post
  • Maks Zbogar Level 1 (5 points)
    pascalim wrote:
    hey guys, I already filed a bug report. An engineer got in touch with me and here's the steps I was to do:

    - Open terminal and enter "codesign -v /Applications/"

    If the output of this command is anything but "Valid on disk", uninstall iTunes and reinstall it. This fixed my problem.

    Thank you very much!
    This fixed my problem too! I have to mention that I have tried everything else posted on discussions and nothing else worked permanently.
  • olli.vdl Level 1 (20 points)
    bitblasters wrote:
    Well I am seeing this problems as well. It also happens with another app I have. This started once I had to go get another DSL modem because my other one went out. Now I get this same message when ITunes starts up and also Ch-Ching, but when I try to connect with my iPhone to iTunes with from the iPhone or Ch-Ching from my iPhone, they do not see that my iPhone is connected. Qwest is of no help here at all, they have no clue what I am talking about of course. This all worked fine until I put this new modem on and now it does not work. Does any one have any ideas on this?

    It makes absolutely no sense to me, that a change of modem would cause this. It might have coincided with another action that you are not having in mind, but this problem happens even if your computer would have no modem at all...

    Flemming Rasmussen wrote:
    It doesn't work for me with the terminal command. But that's probably because i've changed the iTunes icon with my own:

    The CleanMyMac suggestion doesn't do the trick either.

    CleanMyMac causes this trouble, it doesn't in anyway help you out of it...


    Any alteration of the application, being either esthetical or spacesaving-wise will change the checksum of the application.

    The checksum of an application is actually the result of an algorithmic process run onto the whole set of files that are embedded in the application (a folder with the extension app). The checksum end up in a signature code of the original application.

    That signature gets processed upon the release of the public application: the original iTunes as it is fitted on the original .dmg that you download at

    _The signature code_

    Resides within the application and gets checked by the firewall.

    The firewall verifies the authenticity of the actual existing totality of files that make up with the signature: the same checksum gets processed by and should result in an exact match with the checksum performed by the developers of the app.


    This way Apple applications pass trough the firewall without having to interact with the user. A set of firewall rules get automatically applied, and the signature verification ensures the security of the process: only unaltered (unhacked) applications made internally at Apple can pass trough the firewall sytem in that way.

    Any other program (non-Apple) needs to interact with the user to get permissions to pass the firewall.


    Any of us having typed the Terminal code above, or better

    codesign -vvv /Applications/

    will see altered stuff listed by terminal.

    If this error shows, you have a choice: trust iTunes as it is, and tell it every time you are prompted for it. Or replace the thing with an exact copy of Apple.

    I find it a bit exagerated that one cannot easily force the firewall to accept iTunes in the state you want it to be, to pass without prompting for it everytime you start it.

    Finally I wonder if there's any proper reference to bypass the signature stuff by regenerating it. I doubt that would be easy to do... It would totally put in question the whole security idea behind it: someone can put in another iTunes core program into iTunes and swap the signature.
  • dekket Level 1 (5 points)
    A lot of us use Candybar to change icons on folders and in the dock. But Candybar can also change icons on applications. I changed the icon of, and that's when my problems started.

    If this is what you've done, all you can really do in order to be sure this crap doesn't happen; Reset the icon change
  • aspinall_david27 Level 1 (0 points)
    Tried most, if not all, of the solutions in this thread - and, in my case, have found what the problem is... the iPhone Remote app. With it connected, I consistently get the "incoming network" message - with it NOT connected, I don't... the Mac Remote DOES work without showing the message.
  • netGuru Level 1 (15 points)
    This was driving me nuts for months...iMac running Snow Leopard with the latest iTunes...forgetting remotes did the trick for me...

  • Viper 3 Level 1 (0 points)
    That worked for me, however came back when turning the remote back on (never use my iphone for the remote much so I just kept it off). I also had to turn off sharing on my local network in the settings.

    Thanks for the solution.
  • graabein Level 1 (0 points)
    pascalim wrote:
    hey guys, I already filed a bug report. An engineer got in touch with me and here's the steps I was to do:

    - Open terminal and enter "codesign -v /Applications/"

    If the output of this command is anything but "Valid on disk", uninstall iTunes and reinstall it. This fixed my problem.

    Thanks for posting this. I had the same problem. When I ran the codesign command on my 10.6.5 system with iTunes 10.1, it responded:

    /Applications/ a sealed resource is missing or invalid

    Downloading iTunes from Apple and reinstalling it fixed this. Makes you wonder how this could happen in the first place though, especially since this happened to me over a year after you posted the fix, and of course several versions of Mac OS and iTunes later, and I had not changed iTunes in any way (no fancy icons or anything like that).
  • JordaanBUD Level 1 (0 points)
    last action worked perfectly for me, thanks bro!
  • Level 1 (10 points)

    Thank you.

    My problem fixed.

    A quick note to those concerned about losing their itunes data - if you have re-installed itunes, hold down the option key when you click the itunes icon, this will ask you to select your itunes library, which you will find if you navigate through your music folder to the itunes folder, hey presto your library is as it was before you uninstalled itunes.
  • Seamaster73 Level 1 (5 points)
    Thanks, MacPaw, I couldn't figure out why this problem had returned, but it's clearly CleanMyMac doing its job — having reinstalled iTunes and unchecked this box in CleanMyMac preferences per your advice I'm fixed.
  • dmilazzo Level 1 (5 points)
    OK, I'm running Snow Leopard 10.6.6, and iTunes 10.1.1, both are the current versions as of 1-17-2011. First understand that I've stripped down the size of iTunes using Xslimmer, but presumably other apps mentioned here that modify iTunes by removing unnecessary binaries, languages, etc would have the same effect -- which is to make the firewall think that iTunes is no longer the "signed" version.

    That said, the problem discussed in this thread (asking for permission every time i Launch iTunes) only happens for me when iTunes sharing is turned on in iTunes prefs. Once I turn off sharing, no more prompts to accept incoming connections !!!!! Of course if you share your library even occasionally, this is a pain.

    Clearly this is a bug, because even though we've modified iTunes by stripping it down, the Firewall function in theory should work with the current (modified) version of the app once you allow it manually. That is, when I click ALLOW it should recognize the current modified state of iTunes and therefore allow it passage. Since I've modified iTunes I can understand if this didn't work automatically (the firewall by default automatically allows signed apps without you having to specify each one), but what I CANNOT swallow is that even after manually creating an ALLOW rule for the modified iTunes that it still won't let it pass.

    FIX THIS APPLE !!!! If I create and allow an exception, it should WORK !!!!

    My point of this post is to let people know that, at least in my experience, the problem only crops up when incoming connections are requested (which in day to day use only seems to happen when iTunes Library Sharing is activated).
  • dtravis7 Level 1 (0 points)
    pascalim wrote:
    hey guys, I already filed a bug report. An engineer got in touch with me and here's the steps I was to do:

    - Open terminal and enter "codesign -v /Applications/"

    If the output of this command is anything but "Valid on disk", uninstall iTunes and reinstall it. This fixed my problem.

    Worked perfectly for me also. Thanks so much!
  • sapphir8 Level 2 (160 points)
    Uninstalling and reinstalling iTunes worked perfectly. However I am bit confused on how it got corrupted in the first place....
  • rhymon78 Level 1 (0 points)
    Hey, I also have been experiencing this issue with itunes asking me to allow or deny etc. I read all of the recent posts and started thinking about when it started happening, and it was around the time I 'turned on home sharing'. I thought hmmm, lets try turning it off.......and hey presto! the problem is sorted. I have quit and restarted itunes several times to see if it starts happening again and so far so good! try that people, see what happens.
  • @TheLNarayan Level 1 (0 points)
    Been trying all kinds of things for months. Uninstalling, re-installing, removing .plist files, and finally today, I turned off home sharing and voila, no more message. I restarted iTunes 3 times and still no message and also ran the codesign -v /Applications/ in terminal afterwards and am still missing a sealed resource. Hopefully this works for other people.