Previous 1 3 4 5 6 7 Next 99 Replies Latest reply: Jan 24, 2015 1:51 PM by ericnoel Go to original post
  • ashbcgu Level 1 Level 1

    I had the same problem which appeared when I bought an iPhone and synced it for the first time, which required an update to the latest version of iTunes.

     

    The first sync  seems to have automatically enabled "Share my library on my local network" in the Sharing tab of iTunes Preferences. The Sync app has also caused a number of other apps to slow down or get buggy that have nothing to do with the IPhone (legit, robust, professional apps like Adobe CS and Avid).

     

    At any rate, I disabled wireless sync, deselected the library sharing option, and now iTunes launches dialog-free and my pro apps are behaving normally again.

     

    Of course, now I can't share my library on my local network or sync wirelessly, which are supposed to be key value propositions of these products.

     

    iPhone/iOS/OSX FAIL.

  • askmrmac Level 1 Level 1

    Easiest Fix??

    I ran into this problem updating a dusty old 32.bit Hackintosh OSX 10.6.7, updating from iTunes 10.1.1 to iTunes 10.6.3.  Googled the error message, and found this thread, but I think I found the easiest fix, and I will share:

     

    Close your problematic copy of iTunes;

    System Preferences > Security > Firewall > Advanced  (unlock and authentication probably required);

    Delete the iTunes reference reference using the minus - sign method;

    Add/Navigate to your new installed/updated copy of iTunes using the plus + sign method;

     

    Repair permission and restart your Mac:

    New version of iTunes should work now without pesky repeating authorization request

     

    It looks like previous version of iTunes was referenced in Firewall > Advanced,

    and everytime new install/updated iTunes was launched, accepting the incoming connections message would not correctly reference new iTunes, but still reference old version number as a bug...

     

    Worked for me right away, simply, hope your problem is as easily fixable

  • Charles Mckenna1 Level 1 Level 1

    askmrmac's solution worked for me.

    Thanks

  • Charles Mckenna1 Level 1 Level 1

    Sorry.  I posted to quickly.  It worke for only one restart.  I have no solution

  • Property Level 1 Level 1

    I tried several of the solutions suggested but none worked. I finally solved the problem by going to iTunes / Preferences / Devices /, then unticking the box that says "Allow iTunes audio control from remote speakers." The firewall dialog box stopped appearing after that.

  • koreyfromhattiesburg Level 1 Level 1

    http://www.maclife.com/article/gallery/how_get_around_your_firewall_itunes

     

    FINALLY! Found something that worked for me. I'd note though that it says to "move to desktop" but instead you just copy the file out and delete whats in the preferences folder.

     

    I also had to delete "com.apple.alf.plist.lockfile" and "com.apple.alf.plist~orig" to make it work. Deleting just "com.apple.alf" only worked for one time before the problem came back.

  • kdmotion Level 1 Level 1

    worked! thank you!

  • kashick Level 1 Level 1

    +1

     

    This worked for me - thanks!

  • themarkofbooks Level 1 Level 1

    I had this issue as well and PortableGenius' suggestion fixed it.

  • ericnoel Level 1 Level 1

    I'm surprised that the original poster said the answer fixed his that he did, it's quite possible there are multiple different issues that can cause that message to appear every time iTunes launches.

     

    For me personally the accepted answer did NOT work. 

     

    I ended up searching the inter webs and found this post:

    http://blog.teamleadnet.com/2012/10/fixing-do-you-want-application.html

     

    following these directions solved it for me, though I had to run codesign twice to get it to show two different files that it didn't like.

    I also deleted the files using the finder so that they would be in the trash in case deleting them caused a lot of chaos, which it didn't. 

     

    After deleting two files that codesign reported:

     

    /Applications/iTunes.app/Contents/Resources/Recovery.ipsw

     

    and on the second run after deleting Recovery.ipsw:

     

    /Applications/iTunes.app/Contents/Resources alias

     

    After deleting both of these iTunes launched just fine.

     

    I'm sure others will have very different experience as to what files are being reported.

     

    That all said, I would guess that following the advice some others gave about just deleting iTunes and re-installing it would probably work well too, but I didn't want to do that because I was nervous about losing some customized media library settings that I had. So if you are advanced user and comfortable with opening the command line the above link is very helpful.

     

    Shame on APPLE for not making this user friendly.  This should be something that takes care of itself or the average user could resolve with a helpful user interface.

Previous 1 3 4 5 6 7 Next