Previous 1 2 3 Next 99 Replies Latest reply: Jan 24, 2015 1:51 PM by ericnoel
Glenn Carter Level 4 (3,360 points)
Hi all. For some time now, everytime I launch iTunes, I am presented with an alert box asking

+"Do you want the application '' to accept incoming network connections?"+

The options it gives me are "Deny" and "Allow". This appears everytime I launch iTunes despite the fact that the Firewall settings in Security Preferences are set for iTunes to "Allow incoming connections". By the way, "Block all incoming connections" is not checked.

I have deleted various preference lists without resolving this issue. Updating to the latest version of iTunes has not helped (8.2.1). Anyone with some suggestions would be helpful even if you think I may have tried it already. Cheers!

MacBook Pro 2.4GHz (Early 2008), Mac OS X (10.5.7), MacBook (unibody), MacBook (Late 2006), Time Capsule, AppleTV, AEBS, 2 iPhones
  • pascalim Level 1 (10 points)
    Wow, I thought I was the only one one who was getting this problem. Everything was fine for me until 2 days ago, I always had "Set access for specific services and applications" selected and had added iTunes and other apps to the list. But now every time any network app(adium, skype..) launches, leopard keeps bugging me about accept or deny WHEN those apps were already added. Any one else getting this annoying problem?
  • pascalim Level 1 (10 points)
    Fixed it. Here's what I did:
    - "sudo chmod 640 /private/var/log/secure.log" from Terminal (had permissions issues on this log file)
    - Trash /Library/Preferences/ (supposed to be the firewall configuration file)
    - Set to "Allow All.." in Firewall prefs
    - Reboot
    - Set back to "Set access..." in Firewall prefs

    I think it's a bug with log rotation scripts. Hope this helps yours.
  • Hunter Ware Level 1 (25 points)
    This worked perfectly for me. Thank you!
  • Glenn Carter Level 4 (3,360 points)
    Thanks pascalim. Though it didn't require all the steps you took, your post did point me to the errant .plist in question and I resolved it with the following:

    In /Library/Preferences/ in found 2 copies of the (created today) (created May 29,2009)

    May 29th was about the time I began experiencing this issue with iTunes repeatedly asking me if I want to allow incoming connections.

    I trashed both copies and then rebooted the Mac. Naturally a new copy of was created and now the Firewall reverted to OFF.

    Launched iTunes and was now NOT asked if I wanted to permit iTunes to accept incoming connections. At this point I quit iTunes.

    Went back into Security Prefs and turned the Firewall back ON. Relaunched iTunes and was again NOT asked if I wanted to permit iTunes to accept incoming connections.

    So it appears that simply trashing the and rebooting is sufficient to clear this issue. I had a feeling it was a .plist issue - I simply didn't know which one it was. Thanks again.
  • Glenn Carter Level 4 (3,360 points)
    Unfortunately, my joy did not last. Though it appeared to have resolved the issue simply deleting the .plist in question was not sufficient to permanently resolve it. After another reboot, the problem came back.

    I went back and performed all the steps you describe in your post above (including the Terminal command) and it still did not prevent iTunes from asking if I wanted to permit incoming connections.

    so now I am back to square one. Thanks anyways. Any other suggestions would be appreciated.
  • Glenn Carter Level 4 (3,360 points)
    ends up performing an Archive & Install of the OS and that cleared up the issue for me. Thanks for the input anyways. Cheers!
  • pascalim Level 1 (10 points)
    Same thing happened to me too, I think it's just something with the new iTunes 8.2.1. I did a clean reinstall and for the past 2 days everything was fine, now the permission window is popping back everytime I launch iTunes. Annoying but good thing is it's only with iTunes, hope this gets fixed soon.
  • morayshire Level 1 (5 points)
    Hello, I've just started to get this very same problem with itunes too. I was having problems with Adobe Flash - continually stopping to load up while playing back - so I did a clean install to sort a few other problems too.
    iTunes now keeps asking allow or deny but does not give you the option to always allow.
  • Glenn Carter Level 4 (3,360 points)
    I have discovered why this is occurring for some users. Do you have an iPod or iPhone paired to iTunes as a remote? Even if you don't try the following:

    Launch iTunes and click "Allow" when you see the alert box.
    Open iTunes Preferences.
    Click on "Devices".
    Uncheck "Look for iPhone and iPod touch Remotes".
    Then click "Forget All Remotes".
    Close iTunes Preferences.
    Quit iTunes.

    Now relaunch iTunes and see if you are asked to allow incoming network connections again. If it has stopped, and you must use a remote, then try re-pairing the remote again and see if the alert appears again.

    It appears that for other it is allowing iTunes to share music over the network and others it is allowing control of iTunes from remote speakers. So it may be any activity related to iTunes over the network that triggers this. Nevertheless, try the above with what ever setting is effecting you and see if it clears it up.

    If it does reappear after reactiviating your preferred setting, then you need to report it via the following bug report page with as much detail as possible:

    If it continues to remain as issue for you, ultimately, we may need to live with it until iTunes is updated or not use remotes until then. Hope this helps for some.

    Message was edited by: Glenn Carter
  • morayshire Level 1 (5 points)
    Yes, I'll give that a try. I have fired of a bug report to Apple so we'll just need to wait and see. No doubt an update will be out soon to stop the Pre!
  • morayshire Level 1 (5 points)
    Eh, hello everybody... Just tried that last suggestion to remove all remotes and, well... it worked
    Hope that's not tempting fail!
  • pascalim Level 1 (10 points)
    hey guys, I already filed a bug report. An engineer got in touch with me and here's the steps I was to do:

    - Open terminal and enter "codesign -v /Applications/"

    If the output of this command is anything but "Valid on disk", uninstall iTunes and reinstall it. This fixed my problem.
  • pascalim Level 1 (10 points)
    From the posts before, you guys can see I was trying random stuffs and it worked for abit. I'd advise you guys, to still check if the is valid on disk. That'll spare you hours of headache lol.
  • morayshire Level 1 (5 points)
    Well, removing the remote as suggested works but with one caveat - if you try to add an iPod or iPhone back as a remote, the trouble starts again.
    So, it must be a bug.
Previous 1 2 3 Next