5 Replies Latest reply: Aug 27, 2009 8:33 PM by juno_arizona
Jacki Level 2 (225 points)

I'm new to iPhone (2 weeks now and love it so far!) - I'm trying to set up my main email as IMAP instead of POP to keep the mail synced when I access on my iPhone or desktop... That's what IMAP does, right?!

Anyway, I've set up a test IMAP account and sent a message to it. The iPhone (and my desktop) both "receive" the message. On the iPhone when I tried to "Delete" the message, I received an error saying "The message could not be moved to the mailbox Trash". Any idea why?!! It's not going to do me much good if I can't delete mail from my phone!


- Jacki

Mac Pro 8-Core Desktop, Mac OS X (10.5.6)
  • Barry Porter1 Level 2 (335 points)
    what setting for deleted Mailbox shows on the iPhone in Settings:Mail,Contacts,Calendars: (test account name): Account Info: Advanced: Deleted mailbox ? Should have in "On the Server" - Deleted Messages with a check next to it.
  • Jacki Level 2 (225 points)
    That was it - thanks so much!
  • juno_arizona Level 1 (0 points)
    i'm having the same problem but i don't have the option of selecting "On the Server".

    i click "Deleted Mailbox" in advanced settings and the "On My iPhone", "Trash" i checked. below that is "On the Server" and below that "Inbox" but these boxes are shaded out. i can't select anything on this screen.
    any suggestions?
  • JGAtlanta Level 1 (0 points)
    Do you have an IMAP capable email account? If you have a major ISP like AT&T or Comcast, they haven't typically supported IMAP to date. Gmail does and if you have a private domain, most hosting providers support it.

    If you have an IMAP capable email account, then setup the account, then go into mail inbox and hit the refresh button once. The go back to settings > mail, contacts > calendar and then click on your new IMAP account. Scroll down to the bottom and go into advanced. At the top will be an area titled "Mailbox Behaviors" with a Drafts Mailbox, a Sent Mailbox and a Deleted Items mailbox. Click on each and select the "On the Server" folder that corresponds with each one. For example, for Drafts, click on the Drafts folder on the server. Sent may be mapped to Sent Items, Sent Messages, etc. Hope that helps
  • juno_arizona Level 1 (0 points)
    here's what worked for me.

    in the advanced settings, i had to add the text "inbox" (without quotes) to the imap prefix.