Previous 1 2 Next 22 Replies Latest reply: Nov 2, 2009 10:26 AM by Raydon-
cloudco Level 1 Level 1 (0 points)
I just got my new iPhone3Gs,
docked it to the docking station I used with my iPhone3G,
Got the Charging Not Supported With This Accessory message.
Took it out of the dock attached it directly to the USB connection, got the same message,
get the same message if I use my iPhone 3G USB cord or the one that came with the iPhone 3Gs.
(though they look exactly the same)
Anyone have this happen?
I am using a USB hub, but did that with the iPhone 3G also and always got good charging.
Jill in Oregon

iPhone 3Gs, iPhone OS 3.0
  • w7ox Level 4 Level 4 (2,385 points)
    Lose the usb hub for charging the 3GS. See if that solves the problem.

    This message has been reported before.

    Any Apple USB cable for any iPhone should work with the 3GS (I'm using 3-4, including the one which came with my original 2G iPhone).

    Phil
  • cloudco Level 1 Level 1 (0 points)
    Since I plugged my iPhone into the USB port on my keyboard, I have not gotten the message
    Jill In Oregon
  • w7ox Level 4 Level 4 (2,385 points)
    Good. And if you get the message again, switch from the keyboard usb port to a main port: I've read those kbd usb ports can be underpowered and cause similar issues (none on my laptop!)

    Phil
  • theking1964 Level 1 Level 1 (0 points)
    Do not charge from front USB Ports use the ones in the back of pc dirrectly attached to MotherBoard as these are more potent.I was charging in front case USB ports and was getting message(Charging is not supported with this accessory) after careful trials and troubleshooting connected to back USB ports and is now working fully.Had no issues with my 8 gig IPhone3G,only with my 16 gig IPhone3GS
  • LeftyLeon Level 1 Level 1 (0 points)
    Contrary to the post being solved, my iPhone 3Gs has been doing the same thing just today. The phone has NOT been plugged in while giving me this message. I'll be surfing the internet and the message "Charging Not Supported With This Accessory" will randomly appear for no reason. It has appeared a total of 10 times within the hour. This may be a bigger issue. I did however use a new charging station last night gave no messages while it was charging that it was incompatible. It worked fine this morning then half way through the day it starts giving me the message.
  • rakslice Level 1 Level 1 (0 points)
    Do not charge from front USB Ports use the ones in the back of pc dirrectly attached to MotherBoard as these are more potent.


    That's pretty silly. Why would they be "more potent"? The voltage is the same and the same current spec applies...
  • ChrisJ4203 Level 8 Level 8 (40,440 points)
    It is possible there could be some lint or dirt in the charging port of the phone. Check that. Otherwise, it could be a software related issue that may require you to either reset and/or restore the phone. Use canned air to gently blow out that port.
  • ChrisJ4203 Level 8 Level 8 (40,440 points)
    I may not agree that could be more "potent", however many of the front USB slots on computers are not v2.0 and can cause problems for the iPhone.
  • w7ox Level 4 Level 4 (2,385 points)
    rakslice wrote:
    That's pretty silly. Why would they be "more potent"? The voltage is the same and the same current spec applies...


    Not all usb ports are capable of handling the same current.

    Phil
  • iNotWorkingAnymore Level 1 Level 1 (10 points)
    Is it just me or has anyone else noticed that Apple have added as of the 3.0 release that refuses to charge the iPhone on most accessories. I bought the new 3GS and it won't charge on any of my accessories anymore that worked perfectly with the old 1st gen iPhone I have. I upgraded my 1st gen iPhone to 3.0 and it no longer charges on anything either.

    I'm pretty outraged. Is Apple for real? They expect everyone to go out and buy new car stereos / boat stereos / charging bases / ipod stereos?

    I'm going to try to send my iPhone back and buy something else if I can't find a fix for this. Apple are screwed if they continue to treat their customers like this.
  • Lawrence Finch Level 7 Level 7 (32,245 points)
    The original iPhone supported the obsolete "firewire" 12 V charging. It was already deprecated as of about v3 of the iPod, but Apple continued to support it for a few extra years. As of the 3G they dropped support for a standard that had actually been retired almost 4 years earlier, possibly because they needed the space of the separate charger chip required.

    However, you can get an adapter that will allow charging on "obsolete" platforms. Check the online Apple store.
  • RussS-Texas Level 1 Level 1 (0 points)
    I have had a similar experience, and I do NOT think this is either answered or solved. Until 5 days ago, when I plugged my 3GS into the USB cable connected to my iMac it would sync and charge as expected. After “upgrading” to the latest iPhone software version (3.0.1), I get “Charging is not supported with this accessory” EVERY time I plug in to the iMac connected USB cable. It still syncs, but I have verified that it does NOT charge.

    Are there more seeing this behavior? I expect so.
  • Lawrence Finch Level 7 Level 7 (32,245 points)
    I have not seen it. Does it charge with the AC charger? Are you using the same port on the back of your iMac (not the port on the keyboard)? Are you connecting directly to the iMac, and not to a hub? (unpowered hubs cannot charge the phone).

    If you still get the message when connected directly to a rear port, with all other USB devices except keyboard and mouse disconnected, try a restore.
  • RussS-Texas Level 1 Level 1 (0 points)
    Thanks for the tips Lawrence.

    So, it does work when directly connected (and not through a usb hub), but the question remains as to why it worked consistently prior to the upgrade to 3.0.1, and not at all now. It is one of those niggly things that just ought not happen.

    I had always thought, "Wow, I'm sure glad that I've not seen that usb hub problem!" Maybe this is just Apple's way of bringing back into the common user experience fold. ;^)

    Thanks, again.
Previous 1 2 Next