11 Replies Latest reply: Jan 4, 2010 1:42 PM by Bazmanian
crowfan00 Level 1 Level 1 (10 points)
I'm having an incredibly frustrating problem with the Remote app and I'm wondering if anyone knows what to do.

The app has worked fine in the past. I've paired it to my iTunes library successfully and controlled it.

Recently, it has stopped working. When I try to re-pair it with iTunes, one of two things will happen:

1 - I will enter the passcode and iTunes will accept it, and then on the iPhone, I just get the spinning icon and then it times out. Most times when this happens, the library name on the iPhone is blank, even though I have a name set in iTunes. In the past, when this worked right, it had the right name; or

2 - I will enter the passcode in iTunes and it will get stuck on "Verifying Remote Passcode" in iTunes. Then it times out and I'm left with no connection.

So far, in attempting to solve the problem, I've:

+ installed the latest version of iTunes
+ deleted and reinstalled the Remote app on the iPhone
+ rebooted the iPhone and my iMac, and also reset the iPhone (hold down both buttons until the Apple logo appears).
+ changed the iMac's firewall settings to "set access to specific services and applications," added iTunes to the list, and set it to allow incoming connections
+ used the "Forget all remotes" option in the iTunes settings and then tried to pair again.

I've searched google and these message boards and found plenty of others with the same problem, but no real solution (some of the things I did above came from suggestions I saw in these other threads, but none of it worked for me).

The iTunes library and the iPhone are on the same network and in iTunes, the "Look for iPhone and iPod Touch Remotes" option is checked.

Any ideas? Thanks!

iMac, Mac OS X (10.5.7), iPhone 3G (16GB), OS 3.0
  • flair photography Level 1 Level 1 (0 points)
    i have the exact same problem. I too have done all those steps you listed and con not get them to re-pair. I spent an hour on the phone with apple care, an hour with qwest, and even made an appointment at my local genius bar but to no avail.

    On my home network, i can not get any of our families 4 iphones to pair with any of our 3 apple computers. I know it is a network problem, but i dot know enough about "opening and closing ports" to figure it out. None of our phones will pair with anything so i took my computer to the genius bar with my phone and as soon as i was on their network, everything paired perfectly?!?!?! There MUST be a network setting somewhere that is preventing our phones from communicating with out apple computers!!!! Please Help!!!! Please Help!!!! Please Help
  • crowfan00 Level 1 Level 1 (10 points)
    I actually solved the problem tonight. I rebooted my router/modem (I have Verizon Fios so they're the same unit) and that solved the problem.

    I didn't do it before because I had signed into the router and looked at the DHCP table and everything looked OK. So I didn't think it would help. But I tried it anyway, and it worked. So something must have been messed up behind the scenes someewhere.

    So if you haven't tried rebooting your router or modem (or both), I'd try that. Hopefully it will solve the problem. It can't hurt to try.

    Good luck!
  • ravingmad Level 1 Level 1 (0 points)
    I solved the problem soon after posting this. I noticed that my iPhone was on my guest network rather than the main one (I have a Time Capsule) so I just switched the phone to the main network and it worked. Try rebooting your modem/router and if you do have a Time Capsule ten make sure both iPhone and computer are on the same network. That's the problem and should solve it.
  • flair photography Level 1 Level 1 (0 points)
    i only have 1 network so that cant be my issue. As soon as i put my iphone and computer on a different network, they pair flawlessly. As soon as they are back on my network they wont "see" each other. Pairing worked a few days ago and as soon as i installed my airport express, none of our famliy iphones will pair with any of our 3 computers...... any ideas
  • crowfan00 Level 1 Level 1 (10 points)
    Is it possible that when you added the Airport Express that it is creating another network instead of joining or extending your existing network? That would mean you would have two networks and that could be causing this issue.

    Did you try rebooting your router and/or modem?
  • uncdwm Level 1 Level 1 (0 points)
    I'm having the same issue and see that this is not answered...

    I have the current iTunes 9.0, iPhone 3.0 (haven't upgraded to 3.1.2 yet b/c I'd lose the tethering)

    When I open the remote app it gives me a passcode, in iTunes the remote DOES display under devices but when I enter in the passcode it either does nothing after 20 seconds or it says incorrect passcode.

    I've opened the TCP/UDP ports, firewall is completely disabled, etc. It must be seeing the phone if the remote device pops up correctly in iTunes - it just isn't verifying the passcode?
  • Ben Hinc Level 1 Level 1 (15 points)
    I really can't believe this question has not been answered yet. I'm having the exact same problem others have described. I posted on my blog regarding this issue with screen shots of the error I've been getting: http://ben.kwinix.com/blog/2009/11/20/oh-apple-what-does-this-mean/

    My network is more complicated than most: I have an Airport Extreme running a 5 GHz 'N' network and a Netgear routher running a standard 'G' network. The Airport is the primary device and acts as the DHCP server; the Netgear is set up as an extender. I use the Airport to connect my iMac, MacBook, and Apple TV and the Netgear to connect my iPhone and any other 'G' devices that come into the house. All devices when connected to either router are provided an IP address by the Airport in the "10.0.1.x" format. Also, all devices say that the "router" is 10.0.1.1, which is the Airport.

    When attempting to connect to any device on the network (either iTunes library or the Apple TV) with the Remote app from the iPhone, I typically get an error regarding a firewall or network settings. Everything is fully updated - latest versions of firmware, OSes, etc.

    I've followed the steps outlined in an Apple support article (http://support.apple.com/kb/TS1741) without success. Someone out there has to have an answer!
  • Ben Hinc Level 1 Level 1 (15 points)
    I should also mention that I thought the "pairing" issue might have to do with the dual networks. Since my Airport is a 5 GHz 'N' only, my iPhone can only connect to the Netgear. So I set my MacBook to connect to the Netgear as well so both are connected to the same router even though the DCHP is still provided by the Airport. No change - the passcode still doesn't verify.

    My thinking now is that it's some obscure setting in the Airport Utility but I have no idea what it could be. I've been through every screen and I can't figure it out.
  • Ben Hinc Level 1 Level 1 (15 points)
    Replying to myself again...

    I just want to confirm that - indeed - rebooting everything (in this case both routers) fixed the problem. Weird, I know, but everything seems to be working fine now.
  • xiaogwu Level 1 Level 1 (0 points)
    Hey everyone, I was having this issue too but I think I finally figured it out. So the symptoms were as follows: You start the iPhone Itunes Remote app and it shows up in itunes. You select the iphone and you enter the 4 digits to pair. That works fine but then the itunes library doesn't appear and the spinning wheel just keeps spinning until it times out.

    It turns out the way I fixed this was that the wireless router(Netgear WGT624 v3) my iphone was connecting to had UPnP disabled. Once I turned UPnP on, my itunes library showed up with no issues in the itunes remote iphone app.
  • Bazmanian Level 1 Level 1 (0 points)
    We have 3 wireless access points throughout the house all connected to a central Sonicwall router/firewall which handles DHCP.

    Uninstalling & Reinstalling the Remote app did not work.
    I rebooted my Macbook & iPhone to no avail also.

    Rebooting the Sonicwall did the trick, and I did not have to reboot any of the AirPorts...

    Likewise I can now connect to any AirPort and remote control iTunes...
    Definitely a network glitch but nothing to do here with wireless connectivity...