11 Replies Latest reply: Aug 22, 2009 9:22 PM by elko
mcf23 Level 1 Level 1 (0 points)
I have a 4-year-old iBook G4 that has recently started acting up. When I try to connect to the internet with wireless internet, the Airport shows that it has a strong signal and lists the name of the correct, password-free network that I have had no problems joining. However, when I open the browser, it reads "You are not connected to the Internet". This happens with both Firefox and Safari and with various wireless networks. When I select Network Diagnostics, I get the green light for both the Airport and the Airport Settings, but the ISP is yellow-lighted and the Internet and Server show red lights.

I finally decided that I would give up on wireless and try with my modem, but got a similar results (green light for Modem and Modem Settings, yellow for ISP, red for Internet and Server). The internet connection reads "connecting..." for a few minutes, but there is not the ususal dial tone, and then it reads "disconnecting..." until I restart the computer. When I try Network Diagnostics on the modem, it says there is no dial tone (although the settings have not been changed from their previous state, which worked without any problems AND all of the other computers in the house have no problems connecting via modem through the same jack with the same phone cord).

If anyone can shed light on my internet connection problem, I would be eternally grateful!

iBook G4, Mac OS X (10.4.11)
  • 1. Re: iBook G4 internet connection problems
    elko Level 2 Level 2 (265 points)
    have you repaired permissions?
    (apps>utilities>disk utility)

    if that doesn't work, try logging out of your account, and rebooting (not just rebooting)

    if that doesn't work, try to connect with another user account on the same computer. If you don't have one, create one.

    Which iBook?
  • 2. Re: iBook G4 internet connection problems
    mcf23 Level 1 Level 1 (0 points)
    Thanks for all of the suggestions! I repaired the permissions, logged out of my account, and created a new account and nothing worked.

    I have a iBook G4 (Mac OS X Version 10.4.11) with 1.42 GHz PowerPC G4. (Is that what you meant by "which iBook"?)
  • 3. Re: iBook G4 internet connection problems
    elko Level 2 Level 2 (265 points)
    Yeah that's what I meant by which ibook. That model has been discussed many times about it's airport card/connection.
    Personally if it were me, I'd buy an external USB dongle and use that to connect wirelessly to the internet. It's slightly inconvenient having it sticking out of the side of your laptop, but not as frustrating as not being able to get online, or going through the process of trying to fix it. I don't know if anyone has ever found a fix for that or not. Call Belkin and ask them which model they have to work with your OS and machine, the OS is important to know. One that works with Panther does not work with Tiger. I don't work for them, I just have had an excellent history with them and my macs.
    good luck!
  • 4. Re: iBook G4 internet connection problems
    mcf23 Level 1 Level 1 (0 points)
    Thanks! I'll try that! (I do have one more question, though-- why does the Airport affect the Internal Modem??)
  • 5. Re: iBook G4 internet connection problems
    elko Level 2 Level 2 (265 points)
    I don't know of any connection with the dial up modem and the airport wireless card. The 1.42 has wireless issues and why you can't connect with dial up service is a different problem.
    Let's separate the two issues for the sake of clarity. WIRELESS vs DIALUP.

    You say all the other computers can connect with the same phone cord, do you mean they are all connecting using DIAL UP? If so, I'll have to think about this one for awhile, it's been so long since I even worked with dial up that I don't remember how/if more than one computer can even share a dial up connection.

    Can you give more specific details about the dial up issue, +not the airport wireless issue.+ +The wireless is the one I suggest a wireless dongle for, assuming you have a wireless router, or your high speed internet connection uses a combo DSLrouter/modem.(sbc global does).+

    Just to be clear, a dial up modem is not the same as a DSL or Cable modem, correct? They are for completely different methods of getting internet service, What you are questioning is the dial up service which requires a specific type of modem that you have (built in). It is supposed to dial a local phone number of your internet provider to get a conncetion to access the internet. It is also the same modem that you would fax with. You do not need an ISP to fax, that modem is dual purpose. You DO need to have dial up service from an ISP to get to the internet, if you choose to use dial up. your dial up service with the same internet provider as your wireless service? Is the account log in Because you are getting yellow light, you are not getting a signal from your dialup ISP. Are you sure you have one? Who are they. The green light on the modem works because the modem works and you can send and receive faxes, as long as you have a regular telephone line plugged in to the computer. Only one computer can use a phone line for a single dial up connection at a time. You could more phone lines if you wanted to use more dial up connections.

    Maybe it's best to start over with a new thread dealing with "how can you connect to the internet using an internal modem" and then give specifics about what you are trying to do, what isn't working and what errors you are getting. Give the name of your ISP also, that might help in understanding.
    And of course explain WHY in the world you want to connect through dial up anyway Unless you have no other choice...
  • 6. Re: iBook G4 internet connection problems
    mcf23 Level 1 Level 1 (0 points)
    At home, I use dial-up (NOT DSL or Cable or Ethernet-- I live in rural VT and have no other options) and have an internet service provider and have an internal modem in my ibook. I know that I have the dial-up number, username, and password correct (and that the service has been paid for and works on our other computers), and I know that the phone jack and the phone cord that I use to connect to the internet work (because I have tested them with other computers we have in the house). My sister's laptop and our desktop have no problems connecting to the internet using the same information I am using. MY ibook did not have any issues connecting either until about a week ago. I hadn't changed any of the settings on my computer or done anything different than I usually do-- it simply stopped functioning.

    As I wrote before, when I use Network Diagnostics , I get a green light for Modem and Modem Settings, yellow for ISP, red for Internet and Server. The internet connection reads "connecting..." for a few minutes, but there is not the ususal dial tone, and then it reads "disconnecting..." until I restart the computer. I figured that maybe it was just my modem, so I went to two places where I can get wireless access to the internet, but my wireless does not work either, despite showing that the Airport is working and all of the wireless reception bars are lit up.

    Therefore, I think there is something wrong with internet connection in general--but I can't figure out what could be causing BOTH the internal modem and the airport connections to be failing...
  • 7. Re: iBook G4 internet connection problems
    elko Level 2 Level 2 (265 points)
    Okay, I understand now. And I agree, I can't imagine why they both are not working, especially if you did a repair permissions. Did you recently do a software update for quicktime, iTunes or security fix? I've had troubles before after some of those updates but not lately, I'm just thinking of what, how or why. I don't know enough to tell you what to look for in the log files. Are all the other modems for the other computers internal also? Know anyone you could borrow an external from and try it to see if yours is faulty? Maybe you should do a disk repair with the #1 CD for your OS, if for no other reason than to rule it out as the problem. I'm sorry I can't think of anything else to try right now. If one of the other computers are running the same OS as you, you could boot up in target disk mode with firewire and run the disk repair that way.
    I'm really reaching here....
    Does this happen whether you are plugged in to AC or whether you are on battery power? Have you tried it when NO other computer is using the internet connection? Maybe it is timing out because of heavy usage at the same time?
    sorry, I'm not much help here.
  • 8. Re: iBook G4 internet connection problems
    Lyssa Level 6 Level 6 (15,515 points)
    The main thought that comes to my mind here--since you're having troubles with wireless as well as the internal modem--is that the network card in the computer is failing. Is there anywhere you could go that you could try an Ethernet connection to see if that works?

    If you try that and still have no luck getting online, I'd say it's very likely that you have a hardware issue on your hands. If you have the original install discs, you can run the Apple Hardware Test (insert Install Disc 1 and hold down the alt/option key while booting, then choose the AHT option) and see if that pulls up any errors. Make sure you run the extended test!

    If the tests come back without errors, you could try an Archive & Install of the operating system to eliminate a software hiccup--this wouldn't remove any of your personal data or applications, and if you want instructions, feel free to ask!

    Hope that helps a bit.

    ~Lyssa
  • 9. Re: iBook G4 internet connection problems
    scandarello Level 1 Level 1 (0 points)
    Did you resolve modem problem? Have same.. seems that the time it takes before dialling out is too long, and results in the dial-tone timing out. Then requires that I remove line plug from iBook to reset the phone.
    Grateful any help. tks

    Pete
  • 10. Re: iBook G4 internet connection problems
    mcf23 Level 1 Level 1 (0 points)
    Thanks to everyone for all of the suggestions!

    Unfortunately, I have run all of the tests and reinstalled the original software on my hard drive, but to no avail. The problem persists, whether it is plugged in or not (and it is always the only computer online, because we have dial-up).

    I guess there is one detail that I had left out: When I go through the Network Setup Assistant, it can detect my modem, but says that my modem cannot detect a dial tone. (I know the cord works and that the jack works.) Is it possible that the slot I put the phone cord in on the side of my computer is no longer functioning? Is there any way I could test that?
  • 11. Re: iBook G4 internet connection problems
    elko Level 2 Level 2 (265 points)
    very important detail, and definitely possible!
    but I don't know how to test it, sorry.