Previous 1 5 6 7 8 9 Next 133 Replies Latest reply: Aug 8, 2010 9:42 AM by SimpleServe Go to original post
  • smogmonster Level 1 Level 1 (0 points)
    I'm having the same problem as everyone else here. Went though Apple and did all they suggested and still no Wi-Fi. So as a last resort did the freezer method, it worked, for 10 minutes then back to no Wi-Fi again. Many people here have said that this is an ongoing problem, why hasn't Apple fixed it?? This is very frustrating, the only good thing is I'm seem not to be alone. If I find an answer that works for me I will pass it along.
  • thinkricky Level 1 Level 1 (0 points)
    I too have the same problems as everyone else. 8GB iPhone 3G.

    I have not tried the "freezer trick" yet. I'm looking forward to trying it.

    IF the freezer trick is the only way to solve the problem then obviously its a temperature issue. Can we put a heatsink compound anywhere in the phone to absorb some of the heat and put this wifi problem behind us?

    Let me know if anyone has tried or knows where to put the compound and I'll try!!!
  • Greatballsafire Level 1 Level 1 (0 points)
    The answer:

    Toggle on/off the airpot setting on the phone.

    Then try to connect to wifi.

    If it still doesn't work, then reset your network settings, and try again.

    This worked on two new devices, both having exactly the problem described in this forum.
  • IcecdRainbow Level 1 Level 1 (0 points)
    I'll try this once again but the last time (before updating to ios4) it didn't really help but I 'll check again
  • Desmond Harte Level 1 Level 1 (5 points)
    I've been having issues here with an iPhone 4. Some observations;

    Firstly, I have noted that some routers or access points demand the password uses upper case letters only, but others seem to only work if you use lower case letters. This is odd since the same access points or routers are perfectly happy with either or a mix of both if I use my Macbook. It's only when using the iPhone that they get picky about whether upper or lower case is used.

    Secondly, I found that the getting any wifi connection through my router at home was as much an act of random kindness on the part of the phone as anything else. Sometimes I could get an IP address, but at other times I couldn't even get that. This meant that one minute it would work and a few minutes later it would fail completely. I seem to have resolved it today by changing the channel the router was using rather than letting it automatically select one itself. I used channel 11, but I assume others work or don't to greater or lesser degrees. As soon as I did this I have had consistent and uninterrupted wifi on the phone.
  • erinblythe Level 1 Level 1 (0 points)
    I am also having problems connecting to Wi-Fi since updating my iPhone 3G to iOS 4.

    My network is listed in my phone Network settings with a full signal. When I choose it, I am asked for my password. I enter the correct password, then get the message "Failed to join network". I know the password is correct as I can connect from my laptop to the network and my roommate can connect to it from her Blackberry without a problem using the password.

    I have toggled Wi-Fi & Enable 3G settings on & off, hard restarted the phone, reset the phone's network settings, removed and put back the sim card, reset my cable modem, restarted the time capsule, etc. several times and in different orders to no avail. I also tried creating a DHCP reservation for the phone in Time Capsule's Internet Settings and manually inputting these settings under Static in the phone's network settings. I still show full signal but can not connect. At a loss for what to try next. Very frustrating!
  • dmalpartida Level 1 Level 1 (0 points)
    I'm getting this very same problem with my ipod touch (iOS 3.1). I can connect normally when I disable the router's password, but once WPA is on my ipod cannot connect any more. I'm sure that the password is right because I can connect normally with my notebook and my roommate connect as well with his iPhone 3G.
  • filid Level 1 Level 1 (0 points)
    There is another thread here about having no wifi in iOS4 on updated iPhone 3G/3GS: iOS4 on 3GS - No WiFi http://discussions.apple.com/thread.jspa?threadID=2456329&start=60&tstart=0.

    My findings are to be found at: http://www.klammeraffe.org/~brandy/iOS4WLAN.html
  • JeremyfromTexas Level 1 Level 1 (0 points)
    The Freezer Trick works. At least temporarily. Try it.
  • DarkFang420 Level 1 Level 1 (0 points)
    Since I upgraded to iOS4 I've had a wierd issue. The network favors my cellphone data over my wireless, though it will use the wifi when i remove the sim or when i intentionally block the cell signal. Hope 4.1 is on the way.
  • UncleBrian Level 1 Level 1 (0 points)
    I have an iPhone 3GS and have been having the same problems connecting to my home wireless network (on an Airport Extreme base station).

    What's interesting (and perplexing) is that, not only does my phone not connect to my wireless network, *but my Tivo now also won't connect to the wireless network*... _BUT they both DO connect to a nearby wireless network on a linksys with no security._

    I've done just about all of the same resets of everything (more than once). I've changed the security from WPA2 to WPA to WEP and back. I even tried taking security off.... still no connections for either the phone or the Tivo.
  • UncleBrian Level 1 Level 1 (0 points)
    ...and now, about two days later without trying any other fixes, BOTH the iPhone and the Tivo are back on my home wireless network. I wish I knew what "I did" to fix it....
  • amanda bartholomew Level 1 Level 1 (0 points)
    I am having the same exact problem with my iphone 3G. My husbands iphone and my laptop both will connect to my home wifi but i am unable to join network. I have reset my settings as directed and now i am getting a "setup" wifi connection that is asking me to renew lease. I did this. but then tried to join my network at work and still cannon join network. ANY SUGGESTIONS?
    Please help.
  • SimpleServe Level 1 Level 1 (0 points)
    First, follow the Apple trouble shooting guide http://support.apple.com/kb/ts1559

    If it says you need to see the service FAQ it's because you have a hardware problem. If you're under warranty take it to Apple and have them replace it. If you're out of warranty you can buy a new phone or fix it yourself with the Oven Trick http://www.iphonetiquicia.com/iphone-wifi-oven-trick/
Previous 1 5 6 7 8 9 Next