1 2 3 4 Previous Next 52 Replies Latest reply: Oct 23, 2009 8:02 PM by pazoe
H.R.H. Level 1 Level 1 (15 points)
every one of my apps won't work! i will tap on it and then i will imeadetly get the home screen again! please help me! i have tried deleting all apps then snycing it through my computer but it still doesn't work!

Dell, Windows XP
  • 1. Re: Apps wont work on my iphone
    samush98 Level 1 Level 1 (0 points)
    Same here... just happened in the past few days. Other than native apps, every app doesn't load in spite of resetting, reloading ...
  • 2. Re: Apps wont work on my iphone
    H.R.H. Level 1 Level 1 (15 points)
    Exactly! so i have restored my iphone and then tried to make it work again! and that well failed miserably...
  • 3. Re: Apps wont work on my iphone
    iphone3ger Level 3 Level 3 (630 points)
    sounds strange but the fix might be:

    on the iphone itself open the app store and download a free app that you don't already have... let it download and install and see if they all work
  • 4. Re: Apps wont work on my iphone
    H.R.H. Level 1 Level 1 (15 points)
    Well now my new downloaded app is malfunctioning..... thanks for the help though!

    Message was edited by: H.R.H.
  • 5. Re: Apps wont work on my iphone
    iphone3ger Level 3 Level 3 (630 points)
    very odd...

    just curious have you restarted the device? (hold power key until slide to power off appears, then slide to power off)

    if the power cycle doesn't do it

    goto Settings -> Store -> Sign Out then try the free app trick again.
  • 6. Re: Apps wont work on my iphone
    H.R.H. Level 1 Level 1 (15 points)
    No luck...
  • 7. Re: Apps wont work on my iphone
    jeffmoses Level 1 Level 1 (0 points)
    I have the same problem.

    I've tried every suggested fix I could find on the forums and google, and also a suggestion I got when visiting the Mac Store. Nothing solves the problem permanently, but I have found a quick fix to get applications to open:

    1. Download a new application. It opens for a split-second and then closes.
    2. In iPhones, deauthorize your computer, then reauthorize it.
    3. Connect and sync your iPhone to iTunes.
    4. Now, trying the application, it works!

    HOWEVER, new applications I download have the same problem, and I have to repeat the method above to get them to open, EVERY TIME I download new applications. So, every time I want to use a new application, I need my laptop and a working internet connection. Very annoying!

    Methods I've tried that have failed:
    -Restoring my iPhone (I tried this today, and now have 3.0.1 running)
    -Deleting applications and reinstalling them
    -Rebooting the phone
    -After downloading a new app, running other applications that work
    -Making sure my iPhone and Macbook use the same account on iTunes

    Anybody out there know a fix for this?
  • 8. Re: Apps wont work on my iphone
    jeffmoses Level 1 Level 1 (0 points)
    I just got off the phone with an Apple assistant, who fixed my problem. Maybe this will work for you too!

    He told me to reset network settings:
    Settings>General>Reset>Reset Network Settings

    After the reset (which took one minute), new applications I downloaded onto my iPhone worked right away.
  • 9. Re: Apps wont work on my iphone
    Navy21 Level 1 Level 1 (0 points)
    I reset my Iphone, deleted the games that did not work, downloaded them again and they are working fine now.
  • 10. Re: Apps wont work on my iphone- Had to delete all apps, etc
    AlanK 01267 Level 1 Level 1 (0 points)
    When I tried the rest network settings, it did NOT resolve the problem. All the apps I had installed still failed.

    I deleted all of my apps, installed and tested each. They are all working again.

    My problem began AFTER I turned synch ON with the music files in my PC (XP, ServicePak 2). Perhaps the Itunes put something on the Iphone which interferred with my Apps. Changed hidden settings?

    Its all very strange; Ive had my new Iphone 3G phone for 2 weeks and still learning.
  • 11. Re: Apps wont work on my iphone
    arm000 Level 1 Level 1 (0 points)
    My phone started having the same problem after downloading update 3.0.1. None of the suggestions here have fixed it. I haven't tried resetting to factory defaults and redownloading all apps yet, I am definately not looking forward to that
  • 12. Re: Apps wont work on my iphone
    jstarfiret Level 1 Level 1 (0 points)
    I'm having the same probs with my wife's phone.
    Mine is all synced and working fine, but when I did the same thing with her on our shared macbook itunes library, now her app store apps (not her pre-installed ones) just flash on then disappear when tapped.
    I reset network settings, then
    I tried deleting them all and redownloading them, but there's no difference.
    Those fixes seemed to work for a couple people above (thanks for the ideas!), but not so for me.
    Others?
  • 13. Re: Apps wont work on my iphone
    Jay3331 Level 1 Level 1 (0 points)
    FRUSTRATING!!!! I am having the same issue. None of the Apps I have downloaded to my iPhone are working. Came on suddenly - none of the fixes in the discussions are working. This is obviously a widespread issue many are having and it seems Apple has no real response yet. Any ideas???
  • 14. Re: Apps wont work on my iphone
    Serendipity85 Level 1 Level 1 (0 points)
    Same Issue here - since I downloaded update 3.0.1 none of my apps will open, they immediately crash and whenever i try to download new apps its just says "waiting" for ages. I've tried factory reset, network reset, deleting all content from iphone, deleting all apps, still not working. Really annoying!!!! Any help would be much appreciated!!
1 2 3 4 Previous Next