Previous 1 2 3 4 Next 52 Replies Latest reply: Oct 23, 2009 8:02 PM by pazoe Go to original post
  • Jay3331 Level 1 Level 1 (0 points)
    OK, I FINALLY got my apps to work again. Not sure why it worked this time, but...

    This is what I did:
    Deleted all apps I had previously loaded of my phone first.
    Then went into iTunes and deleted all apps and moved to Trash.
    Went back into App Store and downloaded each one by one. I stopped after each download just to make certain it worked.

    I hope this helps. The iPhone is less valuable without the apps.

    Good luck!
  • Level 6 Level 6 (11,035 points)
    My wife had this issue on her iPhone 3G. I have not had it on my 3GS, but have not upgraded to 3.0.1 yet on it (may skip that for now based upon this...). Following the advice of the other users here is what I did:

    1. Manually delete all non-native apps from the phone.
    2. Went into Settings>General>Network>Restore Network Settings and chose to restore.
    3. Purchased a Free App on the phone from the app store
    4. Launched the free app and it worked.
    5. Synced the phone back to our iMac via USB as usual, and put some of the old apps back on.
    6. Launched the free app I installed on the phone after restore - works
    7. Launched the old apps I synced back to the phone - all working.

    Hopefully this will work for others until Apple fixes the bug...
  • Serendipity85 Level 1 Level 1 (0 points)
    Hey thanks for the suggestion but still hasnt worked, not sure if it makes a difference that i've got an original iphone? Im going crazy here!
  • KP-FOTO Level 1 Level 1 (0 points)
    I have tryed everything and every ideas in this threat, and nothing worked for me!
    Thanks for alle the ideas.

    Please Apple, fix this!!!!!!

    I've got over 100 applikations on my iphone, i really wouldent like to reinstall all of them one by one.
  • Serendipity85 Level 1 Level 1 (0 points)
    I was on the phone with apple tech support yesterday for 51 minutes and the guy on the phone denied it was anything to do with the 3.0.1 upgrade although my iphone was totally fine before the upgrade from 3.0 to 3.0.1!!

    come on apple this isnt fair on all the people who've spent good money on the iphones and apps!!
  • jstarfiret Level 1 Level 1 (0 points)
    I spend almost an hour on the phone with the apple guy, too.
    He talked me through doing all the fixes listed in this thread, and then was slightly suprised each time each one did nothing.
    Finally he talked me through saving the apps and my pix to image capture on my macbook, then deleting and reinstalling the software on the iphone as if it were brand new. So then I had to go back and put the pix and the contacts and the apps back on the "new" phone.

    Took a while, but it's working fine now.

    After i prodded him, he speculated that it was "something in the iphone's software," and did not agree that it might have to do with the 3.0.1 update-ness.

    blerg.
  • S.K Level 1 Level 1 (0 points)
    I experienced this issue already several time both with OS v2 and now v3 tending to prove this has not been introduced nor fixed by latest OS release.

    I consider this as the major frustration with the i-phone sofar! This is really a pain in the neck!

    -Restarting the device never helped.
    -This time, I "only" re-installed (actually updated) one of the app and this was sufficient to "re-enable" all of them. Sounds like the best workaround for me for the time being. (else you need to go further in the re-install process and I reckon this is REALLY painful when you have plenty of application).

    Something gets probably corrupted at some point in the application database and issuing a modification to it (like an app update) seems to bring it thanksfully right again...but until when?
  • BShrope Level 1 Level 1 (0 points)
    OKAY GOOD NEWS for people stuggling to find a way that works for them!!! After much frustration I finally found a way that worked for me. My case was particularly bad because none of the options that were working for others would work for me. Here is what I did step by step to get third party apps working again. it requires downloading fresh copies of apps in itunes so write them all down and make sure you get all of them back. They are free if you've paid for them once already... it's a pain in the butt, but it works in the worst cases...

    make sure you have latetest itunes and latest iphone OS 3.0.1 (ironic knowing that 3.0.1 was what triggered the problem in the first place for me, but none the less in the interest of thoroughness...)

    1. sync your phone for a back up and sync All your apps onto the phone then disconnect it.

    2. delete each and every app manually from the phone to get rid of all the hidden firmware. It's important to put them all on the phone and then delete them manually as this removes ALL the hidden firmware for all the apps that might get in the way. I read that the firmware for the apps can still be on the phone when the apps are simply unsynced so you have to put them on the phone in order to totally delete them from the phone... stupid I know...

    3. do a HARD RESET of the phone by holding the sleep and home buttons until you see the apple logo and it reboots. leave it disconnected from the computer.

    4. in iTunes, in the app window highlight all apps and totally delete all of them moving the files to the trash when prompted. DO NOT LEAVE THEM IN THE APPLICATIONS FOLDER, make sure you write down all the names or somehting so you can find them all again in the app store.

    5. Deauthorize your computer in the store account window, close and restart itunes, and proceed to step 6, and if at the end of this procedure it doesnt work repeat entire procedure with step 5a. instead of this step...

    5a. in the itunes menu bar under "store" click view account put in your password and then on the account summary page click "remove all computer authorizations". (this is what I HAD TO DO) You can only do this if you have all your five authorizations in use and you haven't used this option within the last year. You can only see/use this button once per year AND ALL your five authorizations are currently in use. I had 4 already in use and had to authorize another machine to fill up my five to get the button to show up. You can use friends computers it doesn't matter because all auths will be removed next step anyways... The point of this is that when you remove them all I think a file gets deleted/discarded on an apple server that was probably corrupted in some way. You find this button on the account summary page to the right of where it says how many computers you have authorized. Once all authorizations are removed reauthorize the itunes computer/library you are syncing your phone with. You can reauth your other machines later when your done. Reauthing them won't screw up the new file on the apple server. The single criteria between success and failure for me was removing all the auths as this didn't work the first time around when I reauthed just the one current computer. So I can't help but suspect that there is a file that gets screwed up somehow on their servers...

    6. IN ITUNES... With a freshly authorized computer and an empty application folder, download all your apps again (a pain in the butt I know)

    7. sync apps to the phone and they should work!!!

    summary of steps
    delete ALL app data from itunes and the phone
    remove computer authorizations from itunes store account. (just the one your using or all of them depending on the state of your file on the apple server)
    reauth computer and redownload apps in itunes and then sync them over.

    It seems that the back up file for the phone has nothing to do with the problem for me at least which is good because you won't lose all your texts, notes, call history, blah blah blah. It seems to be more about computer aauthorization files stored on the apple servers, I think it's magnified by the phone OS updates but the back up file is good, so no need to worry about losing personal data!!! Maybe some of these steps aren't necessary but I'm not sure so I thought it best to tell everyone exactly what I did. Sorry if this all seems convoluted... good luck!
  • Medixine Level 1 Level 1 (0 points)
    Right... the answer to this is to restore the phone back to factory settings and start the iphone in itunes as a new iphone. this means losing txts you'd have otherwise kept etc but its worth it to have a phone that works. Next I individually deleted and reinstalled every iphone application in Itunes on the computer and only after that did I re-sync my phone to itunes. My applications did not do what all of you are experiencing. I was told by apple support that sometimes the software gets corrupted somehow and so the back up to the phone which is taken contains the corrupted app software hence its reticence to work in the new OS. But never fear this has worked for me and if it worked for me, then its gonna work for anybody!!
  • iamelixir Level 1 Level 1 (5 points)
    Does everyone find this ok? that we actually have to delete all of our applications and re-download them all again? that is simply not an acceptable fix. furthermore, Apple needs to acknowledge that there is a real problem here that needs to be addressed and resolved.

    I have tried absolutely everything on the forums.. the only "fix" that works for me is to delete the application and re-download then sync it via iTunes. restored applications in any other form do not work.

    Today for example my workmate was about to upgrade before I warned him not to but he did it anyway on a iPhone 3G from OS 3.0 to 3.0.1 and same problem. luckily he had only 6 applications and no data to worry about. on the other hand, I upgraded my iPhone 3GS from 3.0 to 3.0.1 and now I have almost 100 applications that do not work, all packed with data I cannot lose ~ there is no way I am downloading over 1GB of applications again and losing all my data from each one.

    Apple please acknowledge and do something ~ I have talked this piece of hardware up, made lots of people go buy one and sold my windows mobile but I'm seriously thinking that was a bad choice when looking for support and this is all I can find. I was told "it just works" by the Apple salesman but that is simply not the case for me or anyone else in this and the many other threads dealing with this problem.
  • b r e n t Level 1 Level 1 (0 points)
    same problem here, none of the apps I've downloaded work after the 3.0.1 upgrade. Help me Steve Jobs, wherever you are...
  • Rgordon83 Level 1 Level 1 (0 points)
    Apple,
    please acknowledge and FIX this issue or you will end up with another "united broke my guitar" type video. I'm pretty frustrated by NONE of my apps working. I'm also a pretty good song writer...
  • S.K Level 1 Level 1 (0 points)
    All workaround provided in here are indeed not acceptable and can barely be implemented when you are not connected to a Mac or PC.

    By definition, this is a 'high-priority' problem that requires an urgent fix because it simply prevents normal device (i-phone) operation when your are out of any synch scope.

    I let you imagine if you buy an expensive navigation software (>70USD) and simply cannot start it when you need to quickly drive to the nearest hospital. That could be an interesting case bringing another type of frustration....

    Apple can you please acknowledge and fix the issue?
  • Serendipity85 Level 1 Level 1 (0 points)
    I have spent over 2 hours on separate calls to apple tech support and got *_NO WHERE!_*

    I've done all of the suggestions on the forums (which i appreciate people posting) ive un-installed itunes, complete factory reset on my iphone, which means i've lost everything on it, and still i cant log into itunes, i cant download or open apps on my iphone and apple are STILL insisting its got nothing to do with the 3.0.1 upgrade.

    Come on apple, this has gone far enough - please sort it out!
  • Frank L. Level 1 Level 1 (90 points)
    I have (had) the same problem. I tried everything in the forums until this, which worked for me:

    - Uncheck all apps in iTunes and sync the iPhone
    - De-authorize my computer in iTunes
    - Restart computer & iPhone (hold down home + sleep buttons for 10 sec)
    - Re-authorize my computer in iTunes
    - Check all apps in iTunes and sync the iPhone

    Good luck!!

    (All the purchased songs that still have DRM on them (128 kbps) also won't play -- no fix for that yet.)