14 Replies Latest reply: Sep 7, 2009 1:41 AM by desire68
willits479 Level 1 Level 1 (0 points)
yesterday I downloaded the 3.0 update for the ipod touch and i think i have the first generation itouch. when im on the internet on my itouch i will have connection for about 30 seconds and then a screen will come up saying that my itouch is "unable to reach the internet" even when im sitting in the room with the wireless router. i know its not a bad router because the laptop downstairs always has a strong wireless connnection. This is really annyoing so if anyone knows a way to fix this then please let me know cause im ready to throw my itouch out the window

custom, Windows Vista, none
  • cahouse Level 1 Level 1 (0 points)
    i am having the same problem. also my itouch will not allow my password for my router. the password on the router is only 7 character long but the itouch wants an 8 character password and therefor will not let me connect. i have rebooted everything trying to get this to work but no luck. i had to restore my itouch after i tried to do an update but at least now i have my itouch back just no internet. i know router is good...i'm on it.
  • F Shippey Level 7 Level 7 (21,500 points)
    i know its not a bad router because the laptop downstairs always has a strong wireless connnection


    Good signal strength isn't all there is to it. A router isn't a simple accessory like a telephone - I wish it were! There are a lot of settings 'hidden under the hood' that affect performance. Restarting a router sometimes helps; updating the router firmware often helps (especially with older Linksys routers).
  • luvlabs Level 4 Level 4 (3,610 points)
    The touch wants the same network password as your other devices. You control the character length. Don't confuse your router password with your network password.

    If you are running WEP encryption, you are better off to switch to WPA-psk or WPA2-psk. If you are stuck with WEP, your password length is limited to 5 characters (48 bit) or 13 characters (128 bit). You can use the hex key generated by your router in place of those passwords.
  • luvlabs Level 4 Level 4 (3,610 points)
    3.0 is a little touchy with network setups. Please follow F.Shippey's advice and update your router firmware before you try anything else. Once you have that done and your network is running, try this on your touch:

    1. Reset your network settings - tap Settings > General > Reset > Reset Network settings.
    2. Log back on to your network using Settings > WiFi > Other network and typing in your network name, telling it your security settings, and reentering your password.
    3. After you are connected, tap Settings > WiFi > and then tap the blue > next to your network name. Look at your IP settings - your IP address should be 192.168.x.x. If it is an address that starts with 164.x.x.x, you are not logged into your network and your router has not issued you an IP address.

    Write back to us if you still have problems. Please let us know your router make/model, encryption method, and any other security settings on your network.
  • huskerkkc Level 1 Level 1 (0 points)
    I am having trouble connecting to my wireless as well. I have a 3com router, which is no longer supported (obsolete); however, it works just fine for my home PC, and 3 family laptops. I cannot log on with my new ipod (16 gig-2nd generation). I have confirmed the password. I had a friend with a first-generation itouch come over. He was able to connect with the password. We changed the password. Again, it worked with all other computers/itouches except mine. I reset everything. still no luck. I just got it less than 30 days ago. Next thing to try? I hate to buy a new router for this. Do I have other options?
  • Hulmerist Level 1 Level 1 (0 points)
    Wi-Fi problem here too,
    I can only get a stable connection if I sit right next to the router. I have a brand new Netgear wnr2000. I have reset the network settings on the touch and also restored it completely several times, I've also updated the firmware on the router. As well as my 1st gen 16Gb Touch I have an 8Gb 1st gen on 1.1.5 and guess what?? yup that's right, no wi-fi problems whatsoever, when I search for a wireless network the 1.1.5 Touch picks up around 6 or 7 of my neighbour's networks but the 3.0 Touch only picks up my own and that's usually on 1 bar and loses connection after a minute, on the 1.1.5 I can reliably connect from anywhere in the house, I can even sit in the garden and still get a decent connection, but on 3.0 any further than ten feet and it's down to 1 bar and a lost connection after a short while. I'm fed up , been on to online service, reported the wi-fi issue, they're sending me the packing to return it for repair (or is it replacement?). I'm also on my third set of earphones. Rant over.
  • luvlabs Level 4 Level 4 (3,610 points)
    Please note: You are thread jacking, that is you are posting a new question which is only slightly related to the original posters question. Please try to post new problems as new in the future.

    Are you running OS 3.0 on your new iPod? If you are, about the only things that will work for you is to either replace the router or go to a fixed IP system. If you are still on 2.2.1, you might be able to fix it.

    I'm assuming you are running WEP encryption. The touch is hinky with WEP encryption and requires you to take certain steps - 5 character passwords for 48 bit encryption or 13 character passwords for 128 bit. You can use your current password if you use the hex code generated by the router in place of the password when you log on.

    My recommendation is to update your router ($40 US) and switch to WPA-psk or WPA2-psk encryption as they are far more secure and easier to implement.
  • luvlabs Level 4 Level 4 (3,610 points)
    Please note: You are thread jacking, that is you are posting a new question which is only slightly related to the original poster's question. Please try to post new problems as new in the future.

    Some people experience what you have with 3.0 and WiFi, most others do not. There are things that you can try which, for the most part, work and clear this up. Since you are returning the unit, there is no sense in covering them. You can get the gist of these fixes in earlier posts in this thread.
  • willits479 Level 1 Level 1 (0 points)
    ok thanks for all of yalls advice hopefully after i try a couple of these things it will work.
    thanks again
  • huskerkkc Level 1 Level 1 (0 points)
    I ended up calling tech support, which is free within the first 90 days for a single issue. I already had a case number, so they were quickly up to speed. He walked me through several things that I had already tried but was probably necessary to show we'd done it correctly; none worked. Finally did a restore to factory settings, which still did not work. He ended up recommending I mail it in and a new one will be sent to me. With other devices working, it is not the router, although that may need to be replaced sometime. After determining that I will get a NEW itouch (not a repaired one), I agreed. It is still within the first 45 days. Thanks for other replies. I am hopeful that I just had a defective one and that the new one wil start right up!
  • luvlabs Level 4 Level 4 (3,610 points)
    If you ever decide to upgrade your iPod to OS 3.0, get the new router.
  • Warszawa Level 1 Level 1 (5 points)
    luvlabs, why you keep pushing "get the new router" idea so much? Two or three years old router is too old for you and in your opinion it have to be replaced. If every piece of the equipment connects to the Wi-Fi network but an i-Pod Touch after upgrading to 3.0 doesn't, you are getting to the same advice routine. Sorry but there is very little logic in some of your postings. And please stop assuming that there is only few of us effected by 3.0 "update". Thanks.
  • luvlabs Level 4 Level 4 (3,610 points)
    Warzawa,

    When a poster states that his/her router is no longer in production, it is a pretty safe assumption that firmware updates are not available. 2-3 year old routers are likely to be fine - if the firmware has been updated. Linksys 54G routers certainly fall into this class. Old firmware - crappy performance; new firmware - normal performance.

    There are a certain percentage of touch users with 3.0 that have problems. I have never said otherwise. I wish I knew the reason (and so do you) for these problems. As to the same advice routine, the facts tend to prove that logical, easy to follow, troubleshooting steps can fix most of the problems. Sorry you don't agree, but then again, I don't see you trying to help anyone either.
  • desire68 Level 1 Level 1 (0 points)
    Hi Guys.

    I was having this very problem. I had upgraded my ipod touch to 3.0 and i have the d-link Dl-524. All was well for a few weeks and then without any warning i lost wireless connection to the touch. After reading a few comments on here i simply unplugged the router and waited for one minute. After plugging the router back in the connection returned and all was fine again. So cheers for the help until next time lol!!

    Mike