Skip navigation
This discussion is archived

Repairing permissions after 10.5.8 update extreme oops maybe???

45534 Views 106 Replies Latest reply: Oct 6, 2009 7:54 PM by mascotca RSS
  • Hedi ® Level 1 Level 1 (20 points)
    Going to give it a try: applying the combo update twice with no permissions repair... #crossed fingers#
    iMac G5 20", iMac 24" Alu, PowerBook G4 12", MacBook Pro, Dell Latitude E5500, Mac OS X (10.5.8), iPod 5G, iPhone 1G, LaCie D2 DVD/DL, Imation Appolo
  • Hedi ® Level 1 Level 1 (20 points)
    MMMmmm niiiice
    All the bad permissions gone, just a few are remaining, all are QuickTime related...
    iMac G5 20", iMac 24" Alu, PowerBook G4 12", MacBook Pro, Dell Latitude E5500, Mac OS X (10.5.6), iPod 5G, iPhone 1G, LaCie D2 DVD/DL, Imation Appolo
  • mert Level 3 Level 3 (880 points)
    Richard Outerbridge wrote:
    mert says he reported this as a bug back on 09-Aug-2009.


    No word from Apple yet regarding bug report (not really expecting anything yet - some bugs I've submitted don't receive a response for months).
  • Eric Rosenwald Level 1 Level 1 (0 points)
    I became aware of this problem before I had to do a clean install (for another reason.) So, I did a clean install from the discs, used software update to do the automatic combo update from I think it was 10.5.1 to 10.5.8. I checked the permissions, and had the usual -- lots of quicktime stuff, audio, video, front row, etc. Nothing unusual. I didn't repair permissions per all of your advice. Now I'm running software update again -- it has an Aug 12 security update, quicktime, safari, etc. updates. If I still have perm problems after this, after I've run any possible updates that come up in software update, should I run the combo updater twice like you guys say? Or should I download and install the combo update now? Does it matter?
    3.0 GHz 8-core Intel Mac Pro, Mac OS X (10.5.1)
  • macwiz1220 Level 4 Level 4 (1,940 points)
    Run combo twice in a row, don't do anything in between, only if you have the weird permissions issues discussed in the thread.
     17" MBP5,2 (Early 2009), 2.93GHz, 4GB RAM, 320GB 7200RPM HD, Glossy , Mac OS X (10.5.8),  PowerBook G4 12'', 512MB DDR2 RAM, 1.5GHz PowerPC G4+ iPhone 3G 16GB Black
  • Eric Rosenwald Level 1 Level 1 (0 points)
    I don't know if this information helps anyone, but I thought I'd let people know how this is going for me.

    I started with a clean install of 10.1. I used software update to get me to 10.5.8, along with ALL of the other updates (airport utility, quicktime, java, iphoto, etc.) I had the same permissions issues that people here had: airport utility, lots of quicktime, front row, etc. So I downloaded just the 10.5.8 combined update, leaving me with no permissions errors. Then, I downloaded a new set of updates that software update recommended (more iphoto, java...) After I restarted, SAME permissions issues, again! Now, I'm going ahead and doing just the 10.5.8 combined update again, to see what happens.

    It seems that I'll get to a point where I have no permissions problems, then when I do any of the housekeeping type updates by themselves (airport itunes, iphoto, java), it goes back to the same problem and I have to install the combined update by itself. Let's see if this third time works!
    3.0 GHz 8-core Intel Mac Pro, Mac OS X (10.5.1)
  • netnothing Level 1 Level 1 (55 points)
    Are you sure you are seeing the same permissions issues in this thread?

    The only permissions issues that are of concern are the ones that were introduced with the 10.5.8 combo update (the ones that want to set permissions to ?----------).

    If you have any of the following permissions issues:
    http://support.apple.com/kb/TS1448

    You don't have to worry about those. Everyone has those and they aren't going away.

    -Kevin
    Mac Pro 2.66, MacBook 2.4, Mac OS X (10.5.8)
  • Eric Rosenwald Level 1 Level 1 (0 points)
    Ohhh... OK sorry. Most are on the list you gave me. However, I have a few that look similar, /Frameworks/CoreVideo, some similar AirPort Utility ones, CoreMedialOServicesPrivate.Framework....

    Not ALL are on the list, but they look familiar. Still, probably no problem right? (since apple can't track down EVERY instance?)
    3.0 GHz 8-core Intel Mac Pro, Mac OS X (10.5.1)
  • CarloCarlo Level 1 Level 1 (10 points)
    Hello,
    after I re-appplied the combo update twice I know get lots of items whose permission are like this one item

    Permissions differ on "System/Library/KerberosPlugins/KerberosDatabasePlugins/kldap.bundle/Contents/_ CodeSignature/CodeResources", should be - - - - - - - - - - , they are -rw-r--r--

    (I had to put a space between the "-" because otherwise it would turn a continous line in composing here)

    No more "question" mark but I wonder if this can be safely ignored.
    BTW, it is an OSX 10.5.8 server.
    Thank you for your help!
    Carlo
    Powerbook 12
  • CarloCarlo Level 1 Level 1 (10 points)
    Sorry ignore my previous message, I repaired permission once more and now everything's fine, only those items with "wrong" permissions that Apple says can be ignored.
    Cheers
    Carlo
    Powerbook 12
  • Stadt Calculating status...
    Hi,
    I had done 1x verify and received similar multi-errors. I repaired, still pages and pages of problems in a re-verify. HelpDesk had me reboot, hold shift at the BONG to come into safe mode. Did another verification and all the errors were magically gone. Rebooted back to regular use, re-verify, and the errors were still all gone. Didn't have to buy Snow Leopard as the guy from MacWorld suggested (tight budgets you know...). Hopefully it sticks - I'm using an iMac.
    B.G.
    P.S. simply reloading combos doesn't work well for all of us. Using Hughes satellite we have such limited download that it took me three nights trying an automatic download program purchased for the reason, that didn't work... and then finally getting up at 4AM to get it done. Huge updates are really a nuisance.
    Power PC G3 iBook, Mac OS X (10.5.8)
  • Eric Rosenwald Level 1 Level 1 (0 points)
    I tried the safe mode fix (I didn't even know there WAS a safe mode with OS10!), and it didn't work. I'm figuring it must be the fact that we're running on very different hardware. Thanks for the tip though!

    Anyone know if the problem has gone away with an update to snow leopard?
    3.0 GHz 8-core Intel Mac Pro, Mac OS X (10.5.1)
  • keats2010 Level 2 Level 2 (285 points)
    Not sure about Snow Leopard but I would definately be upgrading to 10.5.8 if your profile reads correctly as you are very well out of date if you have 10.5.1

    Cheers
    Powerbook 17", Mac OS X (10.5.7), wireless modem 1GB memory G4 120GB hard drive Safari 4
  • Eric Rosenwald Level 1 Level 1 (0 points)
    Ah... Yeah, I'll fix that right now. I do have 10.5.8. I plan on upgrading to 10.6 soon, so hopefully that will work! FYI I have similar disk permission errors relating to my printer's software. Who knows. From what everyone has said, it isn't a problem. That fact is still hard to stomach for a lot of us out there that want our computers to flawlessly run in perfect condition without the slightest hiccup, or indication of a problem... Oh well.
    3.0 GHz 8-core Intel Mac Pro, Mac OS X (10.5.1)
  • Hedi ® Level 1 Level 1 (20 points)
    Snow fixes the prob
    iMac G5 20", iMac 24" Alu, PowerBook G4 12", MacBook Pro, Dell Latitude E5500, Mac OS X (10.6), iPod 5G, iPhone 1G, LaCie D2 DVD/DL, Imation Appolo
1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.