11 Replies Latest reply: Aug 26, 2010 10:28 AM by webstr
badtz Level 2 Level 2
Is there any way to make the sidebar more simplified when subscribing to multiple calendars from your google account?

The sidebar looks horrendous when you start adding in secondary calendars (delegates) ...... very redundant.

Any way to clean this up?

Or will Snow Leopard abolish this ugliness?

G5 + MBP, Mac OS X (10.5.7)
Reply by JLHM on Sep 30, 2009 8:05 AM Helpful
The sidebar looks horrendous when you start adding in secondary calendars (delegates) ...... very
redundant. Any way to clean this up?


I agree, it looks awful. My search to look for info on this topic was "ical google calendar sync is ugly".

God knows why the secondary (delegate) calendars are added doubly as they are, what a mess!

The best I've found to escape this ugliness is to add the secondary calendars individually, which I learned how to do from here: http://email.about.com/od/googlecalendartips/qt/SetUp_Google_Calendar_iCalSync.htm

*+Here are the instructions modified for Snow Leopard:+*

Select iCal | Preferences. Go to the Accounts tab. Click Add beneath the Accounts list. In the 'Account Type' drop box, choose CalDAV, not 'Automatic' setup that will make it look like poop.

Enter your Google account and password. In the 'Server address' field input "https://www.google.com/calendar/dav/", then open Google Calendar in your browser to get the Calendar ID of the desired calendar --> from the main Google Calendar page click Settings | Calendars tab | Click the desired calendar's name and under Calendar Address (at the bottom), select and copy the long email address following 'Calendar ID' that ends in @group.calendar.google.com. Go back to your iCal Accounts Preferences and paste this long address at the end of the ../calendar/dav/ in the 'Server address' field, then append "/user/" at the very end.

The final string under Server address will look similar to "https://www.google.com/ calendar/ dav/345lsf00sfsasf9mf4knak3i23qa4d9sp1bgc@group.calendar.google.com/user".

Click 'Create' and then close the Accounts Preferences window.

It should look a bit more friendly now... I wish both the primary and secondary Google calendars would all be grouped under one heading in the source pane though. Hopefully this and the redundant calendar listing gets fixed in future updates.

John

All replies

  • ATILANO Level 2 Level 2
    Unfortunately, there is no FREE way to do it. If you use something like BusyCal or BusySync, it will look a lot cleaner. Like you, I'm hoping Snow Leopard will fix this; but I doubt it will happen.
  • Flawless Knockoff Level 1 Level 1
    I'm stuck with this problem as well. And it seems like Snow Leopard has not corrected this. Help!!!
  • JLHM Level 1 Level 1
    The sidebar looks horrendous when you start adding in secondary calendars (delegates) ...... very
    redundant. Any way to clean this up?


    I agree, it looks awful. My search to look for info on this topic was "ical google calendar sync is ugly".

    God knows why the secondary (delegate) calendars are added doubly as they are, what a mess!

    The best I've found to escape this ugliness is to add the secondary calendars individually, which I learned how to do from here: http://email.about.com/od/googlecalendartips/qt/SetUp_Google_Calendar_iCalSync.htm

    *+Here are the instructions modified for Snow Leopard:+*

    Select iCal | Preferences. Go to the Accounts tab. Click Add beneath the Accounts list. In the 'Account Type' drop box, choose CalDAV, not 'Automatic' setup that will make it look like poop.

    Enter your Google account and password. In the 'Server address' field input "https://www.google.com/calendar/dav/", then open Google Calendar in your browser to get the Calendar ID of the desired calendar --> from the main Google Calendar page click Settings | Calendars tab | Click the desired calendar's name and under Calendar Address (at the bottom), select and copy the long email address following 'Calendar ID' that ends in @group.calendar.google.com. Go back to your iCal Accounts Preferences and paste this long address at the end of the ../calendar/dav/ in the 'Server address' field, then append "/user/" at the very end.

    The final string under Server address will look similar to "https://www.google.com/ calendar/ dav/345lsf00sfsasf9mf4knak3i23qa4d9sp1bgc@group.calendar.google.com/user".

    Click 'Create' and then close the Accounts Preferences window.

    It should look a bit more friendly now... I wish both the primary and secondary Google calendars would all be grouped under one heading in the source pane though. Hopefully this and the redundant calendar listing gets fixed in future updates.

    John
  • badtz Level 2 Level 2
    JLHM, I'm going to give that a shot, sounds promising! Thanks for coming back to the forums and posting up a solution!!! I hope it suffices :P
  • Garafraxa Level 1 Level 1
    Aside from being ugly, the "delegates" list is causing me problems syncing to my iPod.

    iTunes will only sync events from the main calendar to my iPod. All calendars are selected for syncing, only events from the "mother" account end up on the iPod, nothing from the delegates. iCal itself looks fine (aside from the Accounts/Delegation window).

    Can anyone confirm if the fix above will solve my iPod sync issue?
  • hallmansm Level 1 Level 1
    Agreed. The multiple hierarchies for delegate calendars (via Google Calendar) look ghastly, and I have a relatively simple calendar setup. I really feel sorry for anyone who has several calendars from multiple places.

    Come on Apple, clean this up. I should see all my delegate calendars under my primary calendar they are associated with; and not this horrible redundant sub-folder looking structure, and not completely separate from the main calendars hierarchy. (Or at least allow people the choice, let us drag and drop things where we want them to appear)
  • Belisario Moretti Level 1 Level 1
    Maybe Mozilla Sunbird Calendar does it better !
  • MegaJasonAdam Level 1 Level 1
    Add me to the list of people who would like to see this solved in an update. C'mon Apple!
  • John F. Whitehead Level 2 Level 2
    It's not Apple's fault or bug to fix.

    It works fine & looks good if you use CalDAV on Yahoo! or another server.

    Google just does it "differently."
  • Reallynotnick Level 1 Level 1
    I just wanted to bring this back up because it is driving me absolutely insane.
  • webstr Level 1 Level 1
    Try this: http://blog.controlgroup.com/2009/06/30/fusing-google-calendars-with-ical/

    I cleaned up my calendars and they look a LOT better now. Unfortunately they are all still separate.