6 Replies Latest reply: Oct 7, 2009 10:16 PM by MyMaria
Derryl S Level 2 (195 points)
I have about a ten apps that have internet connections for their operation. Each time a particular app starts up after a boot/reboot of OS, I get the message "Do you want the application XYZ to accept incoming network connections. Settings can be changed in the Firewall pane of Security Preferences."

Every time I click ALLOW and the next time it happens again. The apps are listed in the Firewall as allowing incoming connections. The set access for specific services and applications button is active.

Of the ten apps only Fetch, BBEdit, CDpedia, and DVDpedia seem to behave this way?

How can I get those apps to stop asking if ok to allow? This seems to have begun a few OS versions ago.

G4 1.8 Ghz dual Quicksilver, Mac OS X (10.5.8), 1.12 GB ram, 1.33 TB storage on 2 internal, 2 external firewire
  • Aariq Level 1 (0 points)
    I also have this problem with Word and a few others.

    I looked at /Library/preferences/com.apple.alf.plist as another thread suggested-- there were indeed two of them, but deleting them and re-configuring the firewall preferences did NOT fix the problem. Word still asks for permission to accept incoming network connections EVERY TIME I start the app.
  • Aariq Level 1 (0 points)
    I fixed the problem with Word at least by adding Microsoft Autoupdate to the list in the firewall preference pane.
  • Aariq Level 1 (0 points)
    Nevermind! I thought it had worked, but today Word asked about incoming connections AGAIN.
  • Aariq Level 1 (0 points)
    This time I think I fixed it. I used Activity Monitor to figure out what else was being opened when I opened Word and found something called mdworker. Adding mdworker to the firewall list seems to fix the problem for Word--haven't tried opening excel yet. Anyone know what mdworker is? Can I safely tell it to always block incoming connections to it?
  • KJK555 Level 4 (2,895 points)
    http://osxdaily.com/2009/09/14/mdworker-what-is-mdworker/

    It's part of spotlight. Spotlight is most likely trying to index web pages,
    if you don't need that function, turn it off webpage indexing in
    System Preferences > Spotlight > Search Results.

    Kj ♘
  • MyMaria Level 1 (0 points)
    Hi! How do you add the mdworker to the firewall? Sorry for the noob question. I can't seem to do it. Any steps? TIA! I've been getting this same Microsoft prompt since I updated to Snow Leopard a few weeks ago.