Skip navigation
This discussion is archived

Cant stop emails from downloading iPhone 3G

17735 Views 88 Replies Latest reply: Jan 25, 2010 1:56 PM by Roberto66 RSS
  • Allan Sampson Level 10 Level 10 (122,145 points)
    Currently Being Moderated
    Aug 31, 2009 12:41 PM (in response to HighLife420)
    My people skills are just fine - my number of posts is over a 6 year period of time, and typical of your type to bring up. Is that the best you can do? I run out of patience real quick when I have to repeat the same thing over and over and over again and someone still doesn't get it.

    Reading comprehension, punctuation, and grammar are certainly not your strengths.

    Best of luck.

    BTW, I am outside with my iPhone that doesn't check my email accounts for new messages when I view a contact's info only.

    Message was edited by: Allan Sampson
     MacBook Pro 15" Intel Core 2 Duo/2.53GHz/4GB RAM/500GB HD, Mac OS X (10.5.8),  iPod w/Video 30GB,  iPhone 3G 16GB
  • 311Atlas Calculating status...
    Currently Being Moderated
    Sep 2, 2009 1:47 PM (in response to HighLife420)
    I have used 3 iphones ; 2g , 3g and now using a 3gs . Have used these three phones with the last three operating systems (3gs only used with 3.0.1) and all my iphones downloaded my emails when configured to download manually. so this problem is happening on many Iphones not just afew. By the way , there is an option in both outlook and outlook express to not to download emails when the software is opened.
    iPhone OS 3.0.1
  • tonytone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2009 2:54 PM (in response to HighLife420)
    I guess the $64,000 question that OP is looking (hoping?) to have answered is...why (not "how"--OP has already figured that part out, at least as far as his phone is concerned) does the mail process (daemon?) fire up even though OP did not initiate it directly (i.e., open the Mail app)? I know exactly what OP is going through--every once in a while I discover that the mail process is running (via Memory Info app) on my phone even though I had not (yet) even opened the Mail app; heck--one time I heard the familiar ding sound (along with the message indicator badge) indicating that new mail had just been retrieved...shortly after I had just rebooted the phone and had yet to open a single app. Yes my phone is jailbroken and I have accepted the notion that it probably had something to do with my mail app/process firing up seemingly all on its own; personally I'm just curious as to exactly what could have caused the mail process/daemon to fire up just like that, w/o any direct involvement on my part.
    13" Unibody MacBook Pro 2.26 GHz, mid-2009, Mac OS X (10.5.8)
  • DaSaynt Calculating status...
    Currently Being Moderated
    Sep 2, 2009 8:19 PM (in response to HighLife420)
    Yeah, so I forget who mentioned it, but it was the only suggested fix to this bug given in the thread so far, and it was to delete the current Mail account that had been carried over from the previous (2.2.1) version to the latest version (I'm running 3.0) then recreate the account and see what happens.

    I deleted my GMail account from Mail. Rebooted the phone. Recreated the account. Then under Settings > Fetch New Data > Push is off > Fetch is Manually > Advanced > My GMail Account > Select Schedule is Manual.

    Mail wasn't running at that time. I had to do some directions and opened Maps. Then I hear the stupid you've got mail sound. ***!

    So that potential fix didn't work. Not sure what else to do but wait for a fix...

    I'd also like to reiterate that Mail did not run when it was not supposed to on 2.2.1. I noticed this bug the day I upgraded to 3.0.
    3G, iPhone OS 3.0
  • iMacReg Calculating status...
    Currently Being Moderated
    Sep 2, 2009 8:17 PM (in response to tonytone)
    My phone fetches email with out me opening any program at all. It will do it randomly even when it's just sitting there. The problem started since 3.0. I have the same setup as before 3.0 and never had any issues before.

    So what some of you are saying is to uninstall the (email) accounts, reboot and then reinstall? I will give it a shot. If anyone else has more suggestions please send my way. Thanks.
    iMac G4 1.25GHz 17inch 1GB RAM, Mac OS X (10.4.11)
  • 311Atlas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2009 10:59 PM (in response to HighLife420)
    I think I have found a SOLUTION .
    just configure your mail settings as below ;

    under Settings > Mail, Contacts, Calenders > Fetch New Data set to PUSH OFF> Fetch is set to MANUALLY > Advanced > My GMail Account > Select Schedule is FETCH.

    on the last step , it was set to MANUALLY and I changed it to FETCH and it stopped downloading emails at random times.

    I hope this solves your problem too .

    Message was edited by: 311Atlas
    3GS 32GB, iPhone OS 3.0.1
  • iphone3ger Level 3 Level 3 (630 points)
    Currently Being Moderated
    Sep 2, 2009 11:08 PM (in response to 311Atlas)
    here is the solution i have submitted to apple:



    seriously if you are having the bug make sure you submit feedback at http://apple.com/feedback/iphone.html so they realize it is happening to quite a few of us.

    be well.
    Asus Mutt Win XP Pro / Macbook Unibody MacOSX
  • tonytone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2009 10:40 PM (in response to 311Atlas)
    311Atlas wrote:
    I think I have found a SOLUTION .
    just configure your mail settings as below ;

    under Settings > Mail, Contacts, Calenders > Fetch New Data set to PUSH OFF> Fetch is set to MANUALLY > Advanced > My GMail Account > Select Schedule is FETCH.

    on the last step , it was set to MANUALLY and I changed it to FETCH and it stopped downloading emails at random times.

    I hope this solves your problem too .

    Message was edited by: 311Atlas

    The above suggestion/solution didn't work in my case; in fact, I have discovered (at least one way) how to get the Mail daemon/process to fire up on my iPhone w/o my actually tapping on the Mail app icon or having push/fetch previously enabled:

    1) Make sure that Mail push is off, and fetch is either disabled or set to Manual;

    2) Ensure that the Mail app/process/daemon is not currently running in the background before performing the following steps; this can be done by doing a hard reboot or utilizing a third-party memory utility that will allow you to kill processes;

    3) Tap the Phone icon, then tap the "Recents" icon (if not already on the "Recents" screen);

    4) In order to continue further with this step, the "Recents" list must be populated with at least one recent call entry (it doesn't matter if it was answered or missed); if there is at least one such recent call listed, then tap the ">" for that call to see the detailed info screen. At that point you can just tap the Home button to exit the Phone app screen.

    5) Depending on when I last checked for email, I discovered sooner or later that I had new mail waiting--even though I hadn't even tapped the Mail app icon and my Mail fetch/push settings were still set to disabled/off. Actually, after I had performed step #4 I immediately ran my memory app tool and discovered that the Mail process was running.

    For those of you who have experienced the Mail bug and/or are curious to see if it can be reproduced on your phone in the manner just described--the above steps should ideally be attempted on an unjailbroken phone so that if the bug does occur, then jailbreak can be eliminated as a possible source of conflict.

    I am not saying that this bug can be reproduced on every iPhone, but I can reproduce it at will on mine as long as I follow the exact procedures outlined in this post. FYI--I'm using an iPhone 3G running 3.0 OS...
    13" Unibody MacBook Pro 2.26 GHz, mid-2009, Mac OS X (10.5.8)
  • DaSaynt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 5, 2009 7:32 AM (in response to 311Atlas)
    311Atlas wrote:
    I think I have found a SOLUTION .
    just configure your mail settings as below ;

    under Settings > Mail, Contacts, Calenders > Fetch New Data set to PUSH OFF> Fetch is set to MANUALLY > Advanced > My GMail Account > Select Schedule is FETCH.

    on the last step , it was set to MANUALLY and I changed it to FETCH and it stopped downloading emails at random times.

    I hope this solves your problem too .

    Message was edited by: 311Atlas


    I did this and for about an hour I thought you had nailed it, but naw homie, doesn't work. Mail still runs at random. Especially in response to opening Maps on my phone.

    I have come to one conclusion though. Apple wants this bug to remain. They want Mail to run at random, in turn slowing down the OS on iPhone 3G models, so you'll say, "Oh man, this 3G is just too slow now! I must allow ATT to (|)-rape me again and upgrade to an iPhone 3GS!"
    iPhone 3G, iPhone OS 3.0
  • iMacReg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2009 3:45 PM (in response to DaSaynt)
    I've got some news.

    My unwanted fetch is fixed.

    What I did is delete my email account and reinstall it using the choices offered (in my case Yahoo) by the iPhone instead of installing it manually like I did the first time. That might have been the problem. Maybe I was missing something in the setup that created the problem in the first place. Not sure but now it's been a week and it hasn't fetched on it's own like it did before. Only when I open Mail.

    Just wanted to share this. Hope it helps others out there.
    iMac G4 1.25GHz 17inch 1GB RAM, Mac OS X (10.4.11)
  • Level 6 Level 6 (11,035 points)
    Currently Being Moderated
    Sep 15, 2009 10:51 AM (in response to Allan Sampson)
    This is happening for me as well.

    Push is off etc. Yet randomly , Mail pulls down my emails.

    It's been stated this is not common yet it appears to be at least somewhat common.

    The inconvenience is in having to manually delete as many as hundreds of emails - and in knowing my phone has a mind of its own.

    Hope this inconvenience (all be it minor) is sorted out soon.
    Centris 650
  • Level 6 Level 6 (11,035 points)
    Currently Being Moderated
    Sep 15, 2009 11:02 AM (in response to HighLife420)
    LMAO

    +1
    Radius 8100
  • tonytone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2009 2:30 PM (in response to Merged Content 1)
    Update on my last post about recreating the mail fetch bug--turns out I can recreate it in a manner similar to that described by going into Phone -> Recent:

    1) First make sure that Mail is not running at all (either in the foreground or in the background);

    2) Open Contacts app (either from the Home page--aka Springboard, or from within the Phone app);

    3) Select any contact to view its details;

    4) Exit Contacts app;

    5) If you have an app that can list running processes, you'll discover that the Mail process is now running.

    So, _at least on my phone_ I can force the Mail app to perform a manual fetch either by opening the Contacts app and viewing a contact, or by viewing the info regarding any of my recent calls listed in "Recent" in the Phone app--all without my actually having ever opened the Mail app directly (i.e., tap on the "Mail" icon) and with Mail push/fetch settings set to disabled/manual.

    It is not critical that Mail is not running prior to performing the above steps--it is only so that you can see for yourself that the steps taken do indeed start the Mail daemon/process if it's not already running. If it's already running, you could still tell if the steps do indeed cause Mail to fetch new messages on its own just by hearing the "new mail" gong sound...assuming of course you do have new mail waiting to be retrieved from whatever server you're retrieving your email from.
    13" Unibody MacBook Pro 2.26 GHz, mid-2009, Mac OS X (10.5.8)
  • tonytone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 17, 2009 2:51 PM (in response to iMacReg)
    iMacReg wrote:
    I've got some news.

    My unwanted fetch is fixed.

    What I did is delete my email account and reinstall it using the choices offered (in my case Yahoo) by the iPhone instead of installing it manually like I did the first time. That might have been the problem. Maybe I was missing something in the setup that created the problem in the first place. Not sure but now it's been a week and it hasn't fetched on it's own like it did before. Only when I open Mail.

    Just wanted to share this. Hope it helps others out there.

    It didn't work for me--just for grins I deleted the one email account I had configured on my iPhone so that now there weren't any email accounts configured at all, then tried to recreate the bug. Sure enough the Mail process was running...which would be considered somewhat odd given that I had just ensured that there were no email accounts configured on my phone! Again, all of this is on 3.0 OS, plus I'm only labeling it as a "bug" for lack of knowing what else to call it...not unless other folks claim that it's happening on their non-jailbroken phones, in which case one cannot completely rule out (something within) the 3.0 OS itself as a possible culprit--especially considering that the two methods I described in trying to reproduce the bug involve using apps (Contacts and Phone) that are native to the OS itself (i.e., they are not iTunes App Store apps).
    13" Unibody MacBook Pro 2.26 GHz, mid-2009, Mac OS X (10.5.8)
  • winstonwolf Calculating status...
    Currently Being Moderated
    Sep 17, 2009 9:14 PM (in response to tonytone)
    I have the exact same problem, mail refreshes randomly, usually when looking at contacts, checking voicemail, searching maps. Happened on my 3G both before and after os updates and now on my 3GS. Neither one is jailbroken, 3GS is a week old. I have a gmail, yahoo and hotmail account on the phone and all push/fetch settings are off.

    Message was edited by: winstonwolf
    3G, 3GS, iPhone OS 3.0.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.