7 Replies Latest reply: Aug 18, 2009 2:23 PM by mrwinter
MJ12 Level 1 (0 points)
Okay first I was trying to do a regular disk utility repair. couldn't get it done from disk utility. then I tried using startup disk and holding down C to start disk, it wouldn't load. so I went to single user mode and did fsck. now everything says my stuff is repaired/cleaned up but it will not reboot. I've tried safe mode, doesn't work, tried "exit" in single user mode as well as "reboot" in single user mode. I need to get to a regular command line that doesn't have the "root" open so I can do the (sudo nvram boot=args"-x") command. I don't have another Mac to get on Terminal remotely, nor do I know what logging on via another computer using SSH is, so I'm pretty helpless. Can somebody help me?!

MacBook, Mac OS X (10.5.8)
  • Learning Annex Certified Level 1 (50 points)
    Single user mode is a regular command line interface.
  • Camelot Level 8 (46,655 points)
    I need to get to a regular command line that doesn't have the "root" open so I can do the (sudo nvram boot=args"-x") command


    I don't know if the boot args is going to solve your problem, but the rest of this statement makes no sense.

    sudo elevates a normal user account to have temporary root-level privileges. If you're already root you can just eschew sudo and you have the exact same thing.

    Therefore, these commands are directly equivalent:

    user: $sudo nvram boot=args"-x"


    root: nvram boot=args"-x"


    If that doesn't fix your problem, please describe the symptoms behind "won't load". What do you get?
  • MJ12 Level 1 (0 points)
    Sorry for the stupid questions, you can see I have no idea what I am doing. I tried just the nvram boot-args"-x" and you're right, it didn't solve anything. When I say the disk won't load I mean the only thing that happens no matter what I try is: I turn on the power, then whether I have the startup disk in and hold the C key, hold the shift key to start in safe mode, or go through single user mode and try "exit" or "reboot", I get the white screen with the gray apple and the little machine wheel turning. Nothing else happens after that, the computer never gets to the sign in, the wheel just keeps turning and that's all.
  • doug pennington Level 3 (815 points)
    If it was me I give these a shot. #1 Start it and immediately hold down option key. It will then give you a graphic of which Volumes(or if inserted, install DVD) to start from. Choose one.
    #2 Force OSX startup. Hod down X at startup.

    Message was edited by: doug pennington
  • Learning Annex Certified Level 1 (50 points)
    If your computer will not boot from any available drive then you probably have a problem that cannot be fixed from Terminal.
  • MJ12 Level 1 (0 points)
    nope sorry none of this worked
  • mrwinter Level 1 (0 points)
    Are you trying to boot from a DVD which is in your boot drive? Or the hard disk which is in your computer?
    What happens when you hold down the Option key while you boot?Do you get a list of available boot drives?
    If not, you'll need to find a disk that WILL boot your computer (not all boot disks are the same - some won't work in some models...)