Previous 1 2 Next 24 Replies Latest reply: Oct 29, 2009 1:04 PM by dearlt
dearlt Level 1 Level 1 (10 points)
If you like to set a default zoom level for safari so you don't have to hit Ctrl+ (or Ctrl-) every time you start Safari and open a new tab, here's how you can do that. This should work on Safari for mac, too:

1) create a file named defaultzoom.css (or any name you like, just make sure it has a css extension.)

2) copy and paste in the following:

body {
zoom: 130%;

change 130 to whatever number suits you. >100 means zoom in, <100 means zoom out. Don't forget the % percent sign!

3) in safari, go to Preferences > Advanced. Under style sheet, select Other... and point to the file you created.

4) you may need to restart safari for the change to take effect.

Voila. Hope that helps someone.

Windows Vista
  • tlou37 Level 1 Level 1 (10 points)
    Thank you!!!! The new zoom in Safari 4 is excellent now that it retains the page formatting but have had no luck finding a way to set the default zoom until now. Great little tip. Thanks again.
  • phased Level 1 Level 1 (0 points)
    hi there,

    i'm having trouble implementing your css. this is my first time creating css. i'm on mac os.
    i used textedit to create a .txt file, then altered to an .css via 'get info' in finder (no option to save directly as .css in textedit).
    i have closed and reopened safari to no result.

    can anyone shed some light on the matter? as a new mac user i'm really enjoying safari but it's killing me not being able to set the default zoom to 120%.

    in textedit, i have literally copied:

    body {
    zoom: 120%;

    that's correct, right?
  • dearlt Level 1 Level 1 (10 points)
    did you remember to tell safari to use your css? (see my original post)

    could be that this trick does not work on mac. however, the other person who replied seems to be using a mac and got it to work.
  • Drusus Level 1 Level 1 (90 points)
    Works brilliantly here on my MacBook Pro.

    I needed this becaus for some odd reason, since i updated to safari 4.0.3, Ctrl+ has ceased to work within Safari, but works just fine in other programs. But I can still zoom out in safari using Ctrl-

    Crazy eh?

    Also, I found using Textedit on my Mac, I could just ask it to save as defaultzoom.css by just adding the css extension in place of the txt that comes up. It does warn you that its an unusual extension, but does allow you to proceed if you want.

    Thanks again
  • phased Level 1 Level 1 (0 points)
    "Also, I found using Textedit on my Mac, I could just ask it to save as defaultzoom.css by just adding the css extension in place of the txt that comes up. It does warn you that its an unusual extension, but does allow you to proceed if you want."

    Brilliant. When I did this, it worked.

    Thanks, so much. Was very hesitant to move away from Safari but being unable to set the default zoom meant I almost had to. Thanks, once more.
  • Mayo247 Level 1 Level 1 (0 points)
    Thanks dearlt for you post, and thanks for a perfect subject. I was able to find your post in two clicks and implenetent your solution with ease. I have been clicking Ctrl + on every page I been opening for a year and just knew others had issues with this.

    Thanks again.
  • gabvoie Level 1 Level 1 (0 points)
    Very useful mod but I can't seem to get it to work. When trying to use Drusus tried in Textedit I get the following message:

    "You cannot save this document with extension “.css” at the end of the name. The required extension is “.rtf”."

    It gives me the option to use both css and rtf extensions, cancel or use .rtg

    Following the initial instructions of dearit, I am unable to get this to work.
  • Drusus Level 1 Level 1 (90 points)
    I'm guessing that you probably have Textedit set as a Rich Text format as your default setting. Your document must be in Plain Text format.

    Wen you have the document open that you wish to save as css extension, go to got to the menu named "Format" you will see the option to "Make Plain Text" then give the document the appropriate name and add .css (that's dot css).

    A Warning will come up stating that txt is the standard extension, but you will be given the option of txt or css

    That's all their is to it.

    Hope that sorts you out.
  • gabvoie Level 1 Level 1 (0 points)

    It now works. Thanks for your help.
  • oscarguit Level 1 Level 1 (5 points)
    Very good tip, but it seems to have some problems.
    I was just trying it and i found that in Gmail you have to use horizontal scrolling to see the logout link, because the page layout does not adjust to the screen size. On the other hand, if you start with a 0 zoom level and then you use Ctrl+, the behavior is correct.
    Could you confirm if the problem is general or limited to my config/computer?
  • dearlt Level 1 Level 1 (10 points)
    Yes you are right!

    This CSS zooming is a crude hack. I think it basically treats a web page like a pdf document where you just enlarges everything.

    When you zoom manually, safari does a smarter sort of zoom where it enlarges but tries to keep widths of the elements the same size, reflowing text where needed and scrolling only when necessary.

    If the web page has a fixed size that is smaller than your browser window, like this forum, css zoom works ok. But with a page like gmail, which has no width constraint, you get into trouble.

    Hmm, wait, I just checked out wiki, which also uses up all available screen real estate, but does NOT have this problem.

    Notice in gmail, even if you zoom way out below what should be 100%, the login is still off the screen. The font gets real small but the width of the page stays the same. The css zoom basically "sticks" and isn't completely reversible.

    Bottom line: you have to decide which is more annoying: having to hit Ctrl+ for every tab you open, or running into some problematic pages.

    On Windows, I use autohotkey (a kdb and mouse macro scripting program) to switch off the CSS on the fly when I need to. I think Mac has similar capability built in, right? If I were really clever, I guess I could program autohotkey to send a few ctrl+ whenever it detects a new window or tab in safari, but I'm not there yet.

    Bottom bottom line: Apple needs to add this feature. It's a pretty basic accessibility feature. Doesn't Apple have like an accessibility guru/advocate?
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    I did all of the above -

    Made file with textedit (copy paste)
    Changed the ending to .css
    in Safari-preferenes-Advanced-SheetStyles-defaultzoom(the file I created and saved to My documents)

    Nothing happens !
    I even changed one time to 200% just to see - nothing happens.

    Please Help

    I have been crawling on my knees for months in the Defaultless Zoom Safai desert :C
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    PROBLEM SOLVED !! UnFu%#ing Believable

    It was due to the rich text font in text edit.

    It MUST be copied from here into Textedit which is already in Plain Text format.

    You have created a miracle - Finally Safari has this Normal option

    Thank you Thank you Thank you
  • pulgui Level 1 Level 1 (0 points)
    Great. Thanks a lot. I were looking for a long time. Really runs!!!
Previous 1 2 Next