7 Replies Latest reply: Aug 19, 2009 2:12 AM by JImbo109
Maria L Level 1 Level 1 (0 points)
Lately some attachments I have received on my iPhone show up as winmail.dat files which will not open on my iPhone. However when I log onto my PC the exact same attachments show up correctly as the jpeg files that were sent. Does anyone know why my iPhone for some strange reason decides to show them as winmail.dat files which I cannot open? Can't understand how the PC shows jpeg but the iPhone shows something different??

Dell Inspiron 530, Windows XP, iPhone using Mobile.Me
  • Steph@mac Level 1 Level 1 (95 points)
    Hi there

    the issue is coming from the people that send you the email with the attachment. Basically -and almost as usual with Microsoft- the sender is using a Microsoft Email client (Entourage/Outlook) and the client is encoding the attachment in a Microsoft way : winmail.dat
    If you are using a Microsoft email client then most likely it will be able to decipher the special attachment but other email client do not know how to process it and thus it will appear as an attachment named 'winmail.dat'
    You can read more about that issue on Microsoft web site in the article "How to Prevent the Winmail.dat File from Being Sent to Internet Users":

    Hope it helps
  • Allan Sampson Level 10 Level 10 (123,375 points)
    This is a Microsoft proprietary/closed standard issue. This is caused by the sender using Outlook and/or an Exchange account and RTF for message composition with Microsoft assuming the recipient of the message is also using Outlook.

    The sender needs to use HTML or Plain Text for message composition - preferably Plain Text. If everyone used Plain Text for message composition, the majority if not all problems associated with email exchange and attachments would be eliminated.

    Outlook includes an option for message composition by individual contacts in the address book. The default message composition can be RTF for all messages, but sending a message with Plain Text can be specified by individual contacts in the address book.
  • JImbo109 Level 1 Level 1 (0 points)
    I'm having a similar problem which I can't find a solution to on the forums or elsewhere on the net. I recently moved my contacts over to my gmail account and then synced them to my iPhone through iTunes. Now when I send an email through my work MS Exchange server on my iPhone to colleagues on Outlook they get winmail.dat files. I understand the problem is sending emails in rtf format but I can't change the preferences in gmail contacts, on iTunes or on my iPhone and I can't access the email prefs on our work MS Exchange folder or on my iPhone for the MS Exchange account and presumably if sending from MS Exchange to Outlook this shouldn't happen anyway. Any ideas???
  • Allan Sampson Level 10 Level 10 (123,375 points)
    winmail.dat files should not been seen, or if seen should not be a problem when the message is received by an Outlook user since this is a Microsoft closed/proprietary issue with Outlook and/or the Exchange server with an Exchange account . Outlook is designed to read a winmail.dat file since it was created by Outlook and/or by the Exchange server intended for Outlook users only - a Microsoft proprietary/closed format associated with Outlook.

    The iPhone's Mail client sends messages with plain text - the iPhone's Mail client does not include an option to compose messages with RTF or HTML.
  • JImbo109 Level 1 Level 1 (0 points)
    Thanks, I checked again and it is still happening, actually it is an ATT######.dat message that comes up, bizarrely if I try and read this on my iPhone it opens the original pdf that i was formatting but on my Outlook it won't open other than in garbage format in notepad/text. Any ideas appreciated. I have changed my gmail account settings to use UTF-8 for outgoing messages. I have changed outlook to send in html format only but it doesn't cause the same problem there anyway, just when i send it from my iPHone.
  • Allan Sampson Level 10 Level 10 (123,375 points)
    Changing anything with Outlook in this regard affects messages sent with Outlook only, not with messages sent by the iPhone's Mail client. And if you are sending messages with your Exchange account using the Exchange SMTP server with the iPhone's Mail client, changing your Gmail account settings won't have any affect on this.

    Are you sending messages with your Exchange account and SMTP server, or with your Gmail account and SMTP server?

    I'm not sure how an ATT######.dat file is included when not using AT&T's SMTP server to send the message - the message is being sent by the Exchange SMTP server, but I'm not sure how such a file would be included regardless.

    If you are also accessing your Gmail account with the iPhone's Mail client, does the same occur when sending messages with your Gmail account and SMTP server?

    If not, the problem lies with the SMTP server used to send messages with your Exchange account or at the Exchange server.
  • JImbo109 Level 1 Level 1 (0 points)
    HI, I am getting the same problem when sending through the Gmail SMTP server as I do when sending through the MS Exchange server (although I don't think this has an SMTP does it?). I have tried sending an email to a contact that I know has the preference of sending emails as plain text and all my outlook settings say to send emails as html files. The problem seems only to occur when sending on my iPhone and if i send directly through gmail or Outlook i don't have any such problems. Strangely if i send through my gmail smtp file, the pdf file is readible if i change the extension to .pdf rather than .dat but there are still problems with other attachments being added or removed.