Previous 1 2 Next 19 Replies Latest reply: Aug 22, 2009 10:01 AM by Joshua Coventry
Rook9566 Level 1 Level 1 (0 points)
This is driving me crazy. I have a wireless bluetooth mouse made by Rocketfish. It won't left-click, but the right-click works for some things. To me it seems like the right-click has taken some of the functions that the left-click used to do. I can select menu items, but I can not click any buttons. So here is the situation.

From the login screen I can r/c and select my profile.

Type in my password and hit enter. That gets me into the desktop.

Immediately I get a message telling me about my computer haveing been restarted after an unexpected shutdown and a iCal notification about an appointment last week. I can't do anything with either of these windows. They don't seem to function like normal windows, so close all doesn't work. The only way to close them is to click the button in the window which I can't do.

So now I am trying to reset the mouse or look at help topics using the combination of the mouse and keyboard, but any window that pops up is hidden by these other two windows, and I can't see what I need to see. Nor can I click on any of the options.

I've changed the mouse with a USB mouse, and even used the mouse off my PC. All do the same.

I tried booting in safe mose, but that didn't fix the problem.

I read somewhere about booting from the disk, but I don't know how to do that. Also someone suggested restarting the disk utilities or something. When I tried that, I got to the point where I needed to click the button and could go no farther.

I have a sneaking suspicion my 11 year old was playing with something she shouldn't have like the universal access stuff, but she won't admit it and I don't know how to fix it.

I'm an old PC user, so if you guys have an idea how to fix it, please be gentle with the mac-lingo. Also keep in mind I can't click on anything, so keyboard shortcuts are a must.

Thank you for your help.

iMac, Mac OS X (10.5.8)
  • Barry Hemphill Level 8 Level 8 (36,960 points)
    Hello rook:

    Welcome to Apple discussions.

    If you are able, boot from your software install DVD (insert it and hold the "C" key down).

    Again, if you are able, run repair disk from disk utilities.

    Barry
  • Rook9566 Level 1 Level 1 (0 points)
    OK I tried that. It boots from the DVD and the mouse works perfectly for about 30 seconds. I can click through some options, but then it stops working and is worse than before. Now neither button works. I can see the arrow moving around with the mouse, but can't click on anything. All I can do is reboot by holding the power switch in. But, now I am worse off.
  • Barry Hemphill Level 8 Level 8 (36,960 points)
    Hello again:

    As you said you have tried different mice with the same result (USB), I suspect we can rule out a mouse problem.

    Have you made software updates just before the problem began?

    Without an operational mouse, the things I would normally suggest will not work. At this point (before a visit to an Apple store +"genius bar,"+ I would attempt to do an archive and install. You would need to boot from the software install DVD and go from there. Since I have always had a working mouse, I am not sure how that would proceed.

    Barry
  • Peter Hillman Level 4 Level 4 (1,150 points)
    If you can navigate your way into System Preferences (in the dock or under the Apple menu), go to Keyboard and Mouse. Then click on the Mouse tab. Check the button layout to make sure left side is Primary, right side Secondary.
  • Rook9566 Level 1 Level 1 (0 points)
    Peter, I can't click on anything that's the problem. I can only select items in the menus, and I can't even do that anymore. I can't even log on now.

    But this is rediculous. I was lured into the Mac world with the promise of ease of use, less hassle, less problems. Isn't that what the whole "I'm a Mac" Commercials are about? Now, my computer is completely hosed because the mouse died??? I can completley re-install Windows without a mouse on a Windows machine. All I have to do is Tab around using enter to select. Macs can't do this? I've read about using the number pad as the mouse, but I don't know how to turn that on. Someone's had to have had this problem before. There's got to be a solution. Please.
  • rkaufmann87 Level 9 Level 9 (50,720 points)
    If you have a USB keyboard and mouse lying around, try using those to do the actions the others have recommended.
  • Carolyn Samit Level 10 Level 10 (100,305 points)
    HI,

    Since Apple doesn't manufacture Ricketfish hardware/software, you can hardly blame Apple for "hosing" your system.





  • Rook9566 Level 1 Level 1 (0 points)
    I've tried two other USB mice. They all do the same. What I need is keyboard equivalents to mouse functions. I've searched and found them, but if I am reading correctly. In order to use the number pad as a mouse, I have to enable it in the Universal Access. Well I can't do that, because I need a mouse to click the buttons. I can open universal access, but I first there's a dialog box that I can't get out of my way. Then second, I can't actually click anything in the window.
  • Rook9566 Level 1 Level 1 (0 points)
    Carolyn,
    <edited by host> All mice don't work. The one that came with the Mac, the Rocketfish, and a logictech mouse. Secondly, I'm not blaming Apple for the problem. I'm questioning why is it so friggen hard to navigate with a keyboard? <edited by host>
  • rkaufmann87 Level 9 Level 9 (50,720 points)
    OK if your machine is covered by warranty or you got AppleCare you can contact Apple tomorrow morning. The number in the US is: (800) 275-2273

    Regards,

    Roger
  • Barry Hemphill Level 8 Level 8 (36,960 points)
    Hello again:

    While you are asking people +"did you read"+ - did you read my post about an archive and install?

    Are all of the USB devices you tried non-Apple?

    Since your keyboard seems to work, try resetting the PRAM and SMU (I cannot link to the specific knowledge base article re: SMU as your profile gives no indiction what Mac model you have).

    http://support.apple.com/kb/HT1379

    http://support.apple.com/kb/HT1767
    http://support.apple.com/kb/HT1543

    By the by, since none of us have seen a similar problem, all of us are trying to troubleshoot YOUR problem from long range. It is unhelpful to blame Apple for something that is localized to your system. It is also way out of line to tell an experienced (volunteer) poster to +"Keep their trap shut."+ Your attitude will have you asking questions of yourself since no one here will bother to help you if you display that kind of hostile behavior.

    Barry

    Message was edited by: Barry Hemphill
  • Rook9566 Level 1 Level 1 (0 points)
    Barry, I do appreciate people taking time to help me with the problem. That particular experienced "volunteer" chose to add to my frustration rather than offer any help on the subject. Nice welcome to the community. Please understand I am not blaming Apple for anything. However, I'm ticked off that something that should be so easy to do is so complicated. If you turn off your Mac right now and unplug the mouse, can you navigate throught the menus and do what you had to do? You're saying this issue is localized on my computer, but what happens when your mouse suddenly stops working?

    To answer your questions. I am using the original mouse that came with the Mac.

    And I explained in my post. I cannot click on any buttons in the windows. I saw where you mentioned the archive and install, but I can not select that option with the keyboard. (At least I don't know how to)

    Please do not take my comments as Mac-Bashing. I was a long time hater of Macs until I bought my iPhone. Again I appreciate the help.
  • Barry Hemphill Level 8 Level 8 (36,960 points)
    OK, left-handed apology accepted.

    Did you read my last post about the PMU and PRAM?

    Barry

    P.S. Carolyn, like many of us, was trying to localize the problem. I agree that if you are using multiple mice with the same behavior, that the problem is not the Rocketfish mouse
  • Rook9566 Level 1 Level 1 (0 points)
    Yes, I was in a hurry when I posted that. I have no idea what a PRAM is or what it takes to reset it, but I was going to look it up when I get back. I also have to checkout the links you posted. Trying to juggle a bunch of stuff here.

    If it helps, my apologies to Carolyn or anyone else. I'm just highly frustrated as it picked the wrong weekend to go bad on me.

    Thank you for baring with me.
Previous 1 2 Next