Previous 1 2 3 Next 41 Replies Latest reply: Jun 22, 2010 7:45 PM by wyomason
Pghpdsgt Level 1 Level 1 (0 points)
I have been having the following problem, I will be working on my MacBook Pro4,1 and for no know reason, the keyboard and trackpad will stop working. I close the lid and the computer goes to sleep. A few moments late I open the lid and all is well again. Although this problem is also fixed with a reboot, it is getting irritating.
Any thoughts on a fix?

Thanks

MacBook Pro, IMac, Mac OS X (10.5.7)
  • jeotero Level 1 Level 1 (10 points)
    I started to have the same problem a week ago. Were you able to find a solution for this problem ?

    Cheers
  • stophi Level 1 Level 1 (0 points)
    I am having the same issue with a Macbook Pro 4,1 , however closing the lid doesnt seem to fix it or even a reboot. Sometimes the Keyboard and Trackpad work and sometimes they don't, I have tried resetting PRAM, NVRAM and Resetting the System Management Controller. none of which help, this is getting quite frustating.

    Love to hear any success stories with this? Getting and Apple Service here can take days/weeks and I'm not looking forward to handing it over!
  • Offside Level 1 Level 1 (0 points)
    I've been having this problem with my trackpad and keyboard. I've had my MBP for about a year now and it just started not responding. Restart only helps for a few minutes then both the trackpad and keyboard stop responding. It's very VERY frustrating.
  • jsargent Level 1 Level 1 (0 points)
    I am experiencing the keyboard lockup on my Mac Pro (early 2008) with the Apple aluminum wired keyboard. Never happened under Leopard...only since my clean install of Snow Leopard.

    After a couple of hours of working, I'll be switching between Spaces, and the Spaces interface locks on the screen for several minutes. During that time I cannot use my keyboard for anything EXCEPT switching between spaces. I can't make it go away and I can't use the keyboard for ANYTHING else. The mouse seems to work totally fine though. I have rebooted to make it go away, but it seems to keep coming back. I just reset my PRAM, so hopefully that will help, but I seriously doubt it.

    Apple, HELP!!!
  • Martin.Harmony Level 1 Level 1 (0 points)
    I got exactly the same problem with my apple aluminium wireless keyboard. While switching through spaces with cmd + arrow shortcut it sometimes freezes with space icon on screen and I'm not able to input any text with my keyobard... I didn't check, if other options (like expose or dasboard) are working from the keyboard during this freeze, but still I can move through the spaces with cmd + arrow... Pretty strange and annoying as I need to log out couple of times a day now.
  • William Lester Level 1 Level 1 (0 points)
    I had the exact problem with my MacBookPro4,1 trackpad and keyboard.

    The only solution I found is to replace the top case. I was able to get Apple to do it for me out of warranty because the issue is well-documented.

    Take it to the Genius Bar at your local store and sternly (and politely) request a replacement of your top case due to this issue. It also helps if you can capture the error from Console.app (Applications>Utilities>Console). I used AirMouse on my iPhone to copy the log files after my keyboard and trackpad failed.

    Don't be surprised if you see:
    kernel AppleUSBMultitouchDriver::message - kIOUSBMessagePortHasBeenReset.
    in the Console.

    Good luck,
    Will Lester
  • bedelman Level 1 Level 1 (10 points)
    I'm having the exact same issue -- also on a MacBook Pro 4,1.

    It only started recently after installing Snow Leopard. I use spaces to keep a VMware Fusion session running Windows XP running in full-screen. I've noticed that the keyboard situation as described comes up when the Windows XP session has been idle for a while and the "login" screen comes up (corporate security setting) and I switch into that "space"

    As described the "spaces" icon stays on the screen and I cannot type anything that gets passed over to the applications running. It is interesting to know that Keyboard Viewer does show the keys being pressed as I press them -- and if I click on the keys on Keyboard Viewer, they don't get sent over to the application either
  • William Lester Level 1 Level 1 (0 points)
    Hi bedelman,
    It sounds like your problem is directly related to VMware's allocation of the keyboard and trackpad. Since it started occurring after the update to SL, I'm almost certain you're looking at a software related issue. Your issue is pretty common for VMware users.

    The issues described in this thread are indicative of a hardware problem.

    I hope you find a solution.
  • bedelman Level 1 Level 1 (10 points)
    William,

    I agree that it is likely a software issue and not a hardware issue. However, I also believe that some of the other posts in this thread also indicate the same. For example, the post by Martin.Harmony and jsargent is exactly identical to what I am seeing and the fact that all of us can continue to use the keyboard to move from space to space, but cannot type any text, indicates that it's not a hardware issue in these cases IMHO -- and all three of us are using Snow Leopard

    As far as it "being pretty common for VMware users, please know that I have been using VMware for almost a year using spaces to switch back and forth -- and it did not show up until I upgraded to Snow Leopard.

    - Bob
  • tnine Level 1 Level 1 (0 points)
    I'm also experiencing this problem. I use VMWare Fusion as well. However, I don't allow its services to start on boot to conserve memory. I execute a start and stop shell script to start/stop the Fusion daemons. I randomly get the keyboard error when the vmware daemons are not running, and I can always reproduce it when Fusion is fired up. It definitely seems to been a bug with Snow Leopard as I never had this with 10.5.
  • Jacob F Level 1 Level 1 (0 points)
    I am also experiencing exactly this problem: keyboard completely freezes while showing the Spaces grid (on an Mac Pro, not a laptop). This started upon installing Snow Leopard. I am not using vmware. The mouse, which is plugged in through the USB port on the keyboard, continues to work. It has happened about 8 times in 3 days of using Snow Leopard.

    I found that I can restart the keyboard by unplugging and replugging the keyboard USB.

    If there's any connection, I've had a number of other problems with Snow Leopard, including numerous corrupted fonts (also reported by others), and at least one program (MS Powerpoint) that won't start at all apparently due to the font problems, which I haven't been able to fix.

    I installed the new update (10.6.1) today. All these problems remain, including one keyboard freeze after the update.
  • neu242 Level 1 Level 1 (10 points)
    I have the exact same problem after upgrading to Snow Leopard. A couple of times a day, when switching spaces, keyboard input stops working. This happens both on my non-unibody Macbook Pro and on my unibody Macbook.

    I wrote about this issue here: http://discussions.apple.com/thread.jspa?messageID=10217704
  • direwolf8 Level 4 Level 4 (1,280 points)
    I reported this previously:
    BUG: Spaces prevents keyboard input
    Follow-Up: 77440885

    It's been a problem for me since Snow Leopard came out. Hopefully with a larger group of people experiencing the problem Apple can fix it.

    A temporarily fix is to open the Activity Monitor and Quit the Dock process. Your keyboard functionality will be restored temporarily.

    There is also a thread on this at <http://discussions.apple.com/thread.jspa?threadID=2161076>
  • cur8or Level 1 Level 1 (0 points)
    I just need to "me too" to these posts. This is getting very frustrating!
Previous 1 2 3 Next