Previous 1 2 3 Next 37 Replies Latest reply: Oct 31, 2009 7:37 PM by Frank Patrick Go to original post
  • pdmeloon Level 1 Level 1 (0 points)
    Seems like a lot of people are having similar problems. Here's some more weird things with my problem. The DVD's that I own and put onto Apple TV (Star Trek episodes) will not even show up in the menu. I shut down iTunes, start her back up and Apple TV will sync and then they will be there in the Apple TV menu, but they still won't play. I get the unreadable format error or whatever. I can view anything else I have in Apple TV, though. The next day will roll around and I will try to watch Star Trek again and it will play perfectly fine. This is what happened between Friday and today (Sunday.) I will try to watch Star Trek again today and see if I can or if this problem continues to do the occasional playing.
  • tmartine Level 3 Level 3 (965 points)
    the reported error is misleading. if it plays at all even just once, even if it is actually even available to be played then there is no problem with the format of the file.

    i assume you are streaming the file... the problem is either you have intermittent loss of connectivity between appleTV and iTunes, your computer or hard drive has gone to sleep etc... basically that error means that appleTV knows about the file and it's location but for whatever reason cannot access that file at this time. if the format is not correct the file will not sync and will not ever be available to be played through streaming either... the error really has nothing to do with the file format.. as i said it's misleading.
  • tmartine Level 3 Level 3 (965 points)
    since it's intermittent it really does sounds like you are getting interference from something in the area.. do you have anything cordless phones, baby monitors etc that operates at 5GHz? could also be a neighbor with a 5GHz network as well that is just hidden so it doesn't show up on when you are selecting a network.

    you could try changing the channel that your router is broadcasting on.. open airport utility > manual > wireless tab

    i think the only choice normally for 802.11 n only is automatic.. but if you press option or shift or control... can't remember which one but just try them you get to choose the channel.. this might mitigate the interference by moving off of a channel that is interfering with your network..
  • Mac Daddy1 Level 1 Level 1 (0 points)
    Well after hours and hours talking to the apple tech we figured out really nothing. After playing around with settings, and configuration, etc I tried to rip a HD movie with different encoder into m4v format not mp4. Watched a movie last night and seemed to be fixed. Now I was using MKV tools and now am using handbrake to encode all of my movies hoping this is the fix. I would suggest different format to those having problems.

    The DVD's that I own and put onto Apple TV (Star Trek episodes) will not even show up in the menu?
    You will need to re sync everytime you add a movie to itunes
  • tmartine Level 3 Level 3 (965 points)
    yup.. handbrake using the straight up appleTV setting (only thing extra is i may add additional audio tracks... wife's family is french) if you don't have a lot of time to waste on this stuff... works like a charm.

    May want to try Meta-X as well to add meta data to your file that you can't add trough iTunes.. especially good if you have kids and want to add movie rating so can work with parental controls, plus there is a database of meta data for tonnes of movies so adding artwork, description, actors, directors, rating etc can be done with one click too a few clicks

    Message was edited by: tmartine
  • Mac Daddy1 Level 1 Level 1 (0 points)
    Tried to use quicktime pro and seems to take way to long (24hrs) to export. Handbrake give me errors at times when exporting would and wont work on certain movies would you recommend anything else to convert .mkv and .mp4?
  • batucaves Level 1 Level 1 (0 points)
    If it helps; I've been having a problem streaming my HD videos via my APE wireless 'n' to my ATV. Like you I get the "format not recognized" warning. My SD videos are mostly fine.

    I turned on network robustness (which does slow down my internet access) and this seems to solve the problem (for now) with the HD videos. So it may be a problem with interference after all. My network is usually at "4 bars" strength and I have a dozen networks within range (neighbours), cordless phone and wireless home alarm (i.e. lots of potential interference).
  • Frank Patrick Level 1 Level 1 (15 points)
    I have been having the same problem from even before the Apple 3.0 upgrade, but with movies and TV shows I bought from iTunes Store. I was hoping the upgrade would fix it. While this was an occasional problem with iTunes 8, it seems to have turned chronic with iTunes 9.

    The annoying "solution" that seems to work is to unplug and replug the Apple TV and quit AND restart iTunes. Even then, while watching TV Shows or Movies continuously it seems to work, but after any interruption, either due to shutting off the Apple TV or letting it go to screen saver for an hour or so between shows or movies, iTunes loses it from the device list, and the "format not recognized" message returns.
Previous 1 2 3 Next